[0.16.51] Error: "Direct3D device lost during loading of sprites"

Post Reply
purdueme91
Long Handed Inserter
Long Handed Inserter
Posts: 82
Joined: Thu Jun 09, 2016 11:39 am

[0.16.51] Error: "Direct3D device lost during loading of sprites"

Post by purdueme91 » Fri Sep 21, 2018 3:55 pm

The issue I have is that maybe 10-15% of the time when I start Factorio, the game will freeze and stop loading. And it always happens at the same point of the loading sequence. It will say either "cropping bitmaps" or "loading sprites" and be stuck at 40% load. The cropping bitmaps is generally the more common occurrence. Generally I have to kill the window through task manager and a restart of the program will get it to load. If it happens 3 or 4 times in a row, I will just do a fresh install.

The CPU and RAM usage when it is locked up is generally very low (<10%).

I am playing outside of Steam and generally heavily modded but this has been happening since February and I have played multiple versions with and without mods with this occurring.

Specs:
Win 10
i5-7400
4GB RX580
8GB Ram (just increased to 16GB)

Loewchen
Global Moderator
Global Moderator
Posts: 4674
Joined: Wed Jan 07, 2015 5:53 pm

Re: [16.51] Game freezes on loading prior to main menu

Post by Loewchen » Fri Sep 21, 2018 4:12 pm

Post the log after a session with the issue.

purdueme91
Long Handed Inserter
Long Handed Inserter
Posts: 82
Joined: Thu Jun 09, 2016 11:39 am

Re: [16.51] Game freezes on loading prior to main menu

Post by purdueme91 » Fri Sep 21, 2018 11:28 pm

Is this what you need?
Attachments
factorio-previous.log
(19.16 KiB) Downloaded 22 times

Loewchen
Global Moderator
Global Moderator
Posts: 4674
Joined: Wed Jan 07, 2015 5:53 pm

Re: [16.51] Game freezes on loading prior to main menu

Post by Loewchen » Fri Sep 21, 2018 11:48 pm

Post your dxdiag output.

purdueme91
Long Handed Inserter
Long Handed Inserter
Posts: 82
Joined: Thu Jun 09, 2016 11:39 am

Re: [16.51] Game freezes on loading prior to main menu

Post by purdueme91 » Sat Sep 22, 2018 1:02 am

Here it is
Attachments
DxDiag.txt
(72.2 KiB) Downloaded 14 times

Loewchen
Global Moderator
Global Moderator
Posts: 4674
Joined: Wed Jan 07, 2015 5:53 pm

Re: [16.51] Game freezes on loading prior to main menu

Post by Loewchen » Sat Sep 22, 2018 1:20 am

I would try to install the latest graphics driver, if this does not help you can force opengl until the next update: viewtopic.php?f=7&t=9300

Ref.: viewtopic.php?f=7&t=61337

posila
Factorio Staff
Factorio Staff
Posts: 2749
Joined: Thu Jun 11, 2015 1:35 pm

Re: [0.16.51] Error: "Direct3D device lost during loading of sprites"

Post by posila » Mon Oct 01, 2018 9:34 am

The error doesn't exist in 0.17 anymore, so it shouldn't cause anymore problems.
Another problem might be that parallel sprite loading failed despite the system having lot of memory. I'll add more memory logging at this error in case it still happens in 0.17

purdueme91
Long Handed Inserter
Long Handed Inserter
Posts: 82
Joined: Thu Jun 09, 2016 11:39 am

Re: [0.16.51] Error: "Direct3D device lost during loading of sprites"

Post by purdueme91 » Mon Oct 01, 2018 12:54 pm

Update: I loaded driver dated 9.18.18 and have not seen the lockup since. The qualification is that I haven't played a lot of sessions since I posted and played this weekend without anything else in the background (libre office and brave browser are my most common ones). Did a number of starts then quits this morning with no issues.

Post Reply

Return to “Resolved for 0.17”