[15.37] Toggle Menu Not Working Properly

This subforum contains all the issues which we already resolved.

[15.37] Toggle Menu Not Working Properly

Postby Roy » Wed Oct 25, 2017 12:39 pm

Toggle menu is normally bound to escape, it allows you to go back to the previous menu, open the menu in-game, or close that menu in-game. But there are three problems with that key.

The first one is that it doesn't work for the mods menu (I mean this one; where you toggle mods on or of), if you want to go back to the main menu, you have to click the back button, you can't use escape for that.

The second is when you rebind toggle menu to something else than escape, for example tab. Then you can't back out of certain menus (options, game, multiplayer). This also happens with the menu if you're in-game, so you have to click resume to close it.

The third one happens when you rebind it to mouse button 4 (the back button on most mice). Now backing out of menus works completely, but you can't open the menu in-game (so you can't even close the game or rebind the key again).
Roy
Burner Inserter
Burner Inserter
 
Posts: 5
Joined: Tue Jan 31, 2017 4:50 pm

Re: [15.37] Toggle Menu Not Working Properly

Postby Rseding91 » Wed Oct 25, 2017 4:23 pm

The mods menu is already fixed for 0.16: viewtopic.php?f=213&t=49486

The others: I would say we don't allow re-binding it from escape. But someone else can make that decision.
If you want to get ahold of me I'm almost always on IRC and Discord.
Rseding91
Factorio Staff
Factorio Staff
 
Posts: 6333
Joined: Wed Jun 11, 2014 5:23 am


Return to Resolved Problems and Bugs

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 4 guests