[0.15.34] Programmable speakers not playing sounds Correct

Post your bugs and problems so we can fix them.

[0.15.34] Programmable speakers not playing sounds Correct

Postby Early Wynn » Sun Oct 08, 2017 5:46 pm

Hi i notice this issue 3 days now i had server Version [0.15.34] since today [0.15.35]. I have made a Knight Rider welcome tune at my Spawn Area via Programmable speakers. it was working perfectly since 3 days ago its not playing correctly anymore. i teared down the hole Array and set it many times up new. Same error occurs after rebuild. First i thought the blueprint got damaged, but i tried it on a new map and the Blueprint is fine. Then i notice some other ingame sounds not working correctly eighter alert sounds when beein attacked, walking sounds not always there, etc... so i think my save file has got corrupted somehow. The game was on a Headless server running on the same mashine i was playing. I had the Headless server running in a sandbox. Windows 10 - Sandboxie - Steam version of Factorio.

game is still running fine with no lags or slowdowns. We are running it now on a Dedicated Linux Root server and we wish we could have all our sounds back to enjoy our Map.
Attachments
factorio-previous.log
(3.72 KiB) Downloaded 6 times
Early_Wynn_Coaching_server.zip
(37.32 MiB) Downloaded 3 times
factorio-current.log
(407.75 KiB) Downloaded 5 times
Early Wynn
Manual Inserter
Manual Inserter
 
Posts: 4
Joined: Sun Oct 08, 2017 5:30 pm

Re: [0.15.34] Programmable speakers not playing sounds Correct

Postby daniel34 » Sun Oct 08, 2017 8:26 pm

I think you are playing too many sounds at the same time. In the south at your storage area (the flashing ores on the map) you have some speakers that are set to global playback with the volume set to 0 that are constantly outputting (silent) alarm sounds. If you remove them or disable global playback on them then your Knight Rider tune plays.

Not sure if it's a game limitation or bug, though.
daniel34
Global Moderator
Global Moderator
 
Posts: 2720
Joined: Thu Dec 25, 2014 7:30 am
Location: Austria

Re: [0.15.34] Programmable speakers not playing sounds Correct

Postby Bilka » Sun Oct 08, 2017 9:09 pm

daniel34 wrote:Not sure if it's a game limitation or bug, though.

Game limit is 32 sounds at once.

Maybe it can be fixed in the way that silent sounds dont count towards that limit.
Bilka
Filter Inserter
Filter Inserter
 
Posts: 380
Joined: Sat Aug 13, 2016 9:20 am

Re: [0.15.34] Programmable speakers not playing sounds Correct

Postby Early Wynn » Tue Oct 10, 2017 3:41 pm

but if you destruct everything the sound problems still remains over the entire sound spektrum.
Early Wynn
Manual Inserter
Manual Inserter
 
Posts: 4
Joined: Sun Oct 08, 2017 5:30 pm

Re: [0.15.34] Programmable speakers not playing sounds Correct

Postby Early Wynn » Tue Oct 10, 2017 3:44 pm

we could replicate the problem on any map by using this Blueprint seen in the Factorio - Tetris Theme A - Programmable speakers https://www.youtube.com/watch?v=41jxe1MbBhs. Build destruct build again wait play once and voila... sounds are broken and stays broken even if you destruct it again.
Early Wynn
Manual Inserter
Manual Inserter
 
Posts: 4
Joined: Sun Oct 08, 2017 5:30 pm

Re: [0.15.34] Programmable speakers not playing sounds Correct

Postby daniel34 » Tue Oct 10, 2017 3:47 pm

Early Wynn wrote:but if you destruct everything the sound problems still remains over the entire sound spektrum.

?

If I start the tune (set the Play combinator to on and the Reset combinator to off) I can hear a note every few seconds. If I then run down to your storage area where the uranium ore is flashing (-18, 1083) and remove the two speakers then the sound comes through.

Early Wynn wrote:we could replicate the problem on any map by using this Blueprint seen in the Factorio - Tetris Theme A - Programmable speakers https://www.youtube.com/watch?v=41jxe1MbBhs. Build destruct build again wait play once and voila... sounds are broken and stays broken even if you destruct it again.

Please post the map where you can replicate it. If you have additional programmable speakers on that map then make sure they are not set to global playblack.
daniel34
Global Moderator
Global Moderator
 
Posts: 2720
Joined: Thu Dec 25, 2014 7:30 am
Location: Austria

Re: [0.15.34] Programmable speakers not playing sounds Correct

Postby Early Wynn » Wed Oct 11, 2017 7:02 am

We had the Bug before we build the giant Supply area!
Early Wynn
Manual Inserter
Manual Inserter
 
Posts: 4
Joined: Sun Oct 08, 2017 5:30 pm


Return to Bug Reports

Who is online

Users browsing this forum: AntiElite, Choumiko, Google [Bot], jonatkins, Oxyd, posila, steinio, Tony3D, wheybags and 10 guests