[1.1.68] Current signal not preserved in some signal selection dialogs

Post your bugs and problems so we can fix them.
Post Reply
sparr
Smart Inserter
Smart Inserter
Posts: 1278
Joined: Fri Feb 14, 2014 5:52 pm
Contact:

[1.1.68] Current signal not preserved in some signal selection dialogs

Post by sparr »

When selecting a signal, such as for a filter or combinator, the currently/previously/already selected signal should be highlighted, and pressing E or clicking Set should preserve that selection. This is the case in approximately half of places, and I refer to it below as "works". In the other half of places, the currently selected signal is not highlighted, and pressing E or clicking Set changes the signal to the default constant of zero, and I refer to this below as "broken".

Enabled Condition for wired inserters, belts, train stops, etc works on the left side of the condition, broken on the right side.
Inserter stack size Control Signal works.
Constant combinator signals work.
Decider combinator works on the left side of the condition and the output, broken on the right side.
Arithmetic combinator works on the output, broken on both sides of the input

Steps to reproduce:
1. Place a decider or arithmetic combinator.
2. Click the combinator to open its GUI.
3. For each of the three signal fields, click it and set it to an arbitrary signal.
4. Click the first signal field again.
5. Observe whether the previously selected signal for that field is highlighted in the signal selection interface.
6. Press "e" or click "Set". Observe that the field has been preserved or reset depending on #5.
7. Repeat 4-6 for the other two signal fields.

I can make an exhaustive list of cases if necessary, but I suspect that a brief review of these examples is likely to illustrate a consistent failure mode that can be more easily found across all signal input interfaces in the source rather than from in-game.

Post Reply

Return to “Bug Reports”