[1.1.59] Relative GUI causes "Create blueprint" button to disappear

Post your bugs and problems so we can fix them.
Post Reply
majoca
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sun Dec 20, 2020 8:50 pm
Contact:

[1.1.59] Relative GUI causes "Create blueprint" button to disappear

Post by majoca »

For blueprints that are sufficiently tall, adding a LuaGuiElement anchored to the setup_blueprint GUI causes the green "Create blueprint" button to disappear. Also, the bottom portion of the GUI can be clicked through (you can interact with the taskbar even if the bottom of the setup_blueprint GUI is covering it).

What did I do/What happened?
I started a fresh save in 1.1.59 vanilla and placed the starter mining drill and furnace with 20 tiles of vertical space in between them. I then set up a new blueprint with both entities selected, and everything was normal.
Normal GUI.png
Normal GUI.png (2.39 MiB) Viewed 104 times
I then ran the command

Code: Select all

/c game.player.gui.relative.add({type = "button", anchor = {gui = defines.relative_gui_type.blueprint_setup_gui, position = defines.relative_gui_position.right}})
and tried making the blueprint again. This time, the bottom portion of the GUI looked like it didn't line up right, and there was no "Create blueprint" button.
Bugged GUI.png
Bugged GUI.png (2.44 MiB) Viewed 104 times
What did I expect to happen?
I expected the bottom of the setup_blueprint GUI to behave normally after adding the LuaGuiElement. The anchored element does not affect the height of the overall GUI, so there should not be any issues with the bottom being cut off or buttons disappearing.
Attachments
factorio-current.log
(6.38 KiB) Downloaded 20 times

Xorimuth
Filter Inserter
Filter Inserter
Posts: 429
Joined: Sat Mar 02, 2019 9:39 pm
Contact:

Re: [1.1.59] Relative GUI causes "Create blueprint" button to disappear

Post by Xorimuth »

Same effect as viewtopic.php?f=48&t=98151, although in this case it is the base game GUI that is too tall rather than the relative GUI. Maybe that means that it requires fixing ;)

We also ran into this problem in Space Exploration with a tall relative GUI added to the train GUI.

Post Reply

Return to “Bug Reports”