[Rseding91] Filter inserters' filter setting is not kept when built from blueprints under certain conditions.

Bugs that we just recently fixed in our development version, and will get to you in the next release.
Post Reply
Moosfet
Inserter
Inserter
Posts: 42
Joined: Fri Jun 10, 2016 1:50 pm
Contact:

[Rseding91] Filter inserters' filter setting is not kept when built from blueprints under certain conditions.

Post by Moosfet »

Filter inserters' filter setting is not kept when built from blueprints under certain conditions.

1. Place a new filter inserter.
2. Connect a circuit network wire to the inserter.
3. Configure the circuit connection mode of operation to "set filters."
4. Remove the circuit network wire.
5. Manually configure the filter for an item.
6. Connect the logistic network. (you don't need to configure it, just connect it)
7. Copy and paste the inserter.

The placed ghost inserter will show the filter settings if alt mode is enabled, but once the inserter is actually placed, the filter setting is cleared.

To reproduce this bug, it is required that both the (not active since the wire is no longer connected) circuit network setting is "set filters" and that the logistic network is connected. If you skip either of those two steps, the filter setting won't be cleared when the inserter is built.

DarkShadow44
Long Handed Inserter
Long Handed Inserter
Posts: 88
Joined: Thu Jun 01, 2017 12:05 pm
Contact:

Re: Filter inserters' filter setting is not kept when built from blueprints under certain conditions.

Post by DarkShadow44 »

Just to be sure, this only happens when in step 6 you "Connect" the inserter without connecting a wire, right? Using the logistics network checkbox "Connected", that is.

Moosfet
Inserter
Inserter
Posts: 42
Joined: Fri Jun 10, 2016 1:50 pm
Contact:

Re: Filter inserters' filter setting is not kept when built from blueprints under certain conditions.

Post by Moosfet »

Yes, you just open it up and click the "connect" checkbox to connect it to the logistics network.

Rseding91
Factorio Staff
Factorio Staff
Posts: 11885
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [Rseding91] Filter inserters' filter setting is not kept when built from blueprints under certain conditions.

Post by Rseding91 »

Thanks for the report. It's now fixed for the next release.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved for the next release”