[15.23] Modding: on_research_finished event does not fire

Bugs that are actually features.

[15.23] Modding: on_research_finished event does not fire

Postby Aidiakapi » Mon Jul 17, 2017 12:03 pm

The on_research_finished event does not fire when you complete a research with multiple levels, like an infinite research.

To the best of my knowledge, no other event fires when such a thing happens. If breaking previous mods is a concern, perhaps another event should be added to cover this scenario.
Last edited by Aidiakapi on Mon Jul 17, 2017 9:12 pm, edited 1 time in total.
Aidiakapi
Burner Inserter
Burner Inserter
 
Posts: 6
Joined: Fri Apr 14, 2017 6:13 pm

Re: [15.30] Modding: on_research_finished event does not fire

Postby Rseding91 » Mon Jul 17, 2017 3:26 pm

I can't reproduce. When I test the event fires exactly as it should. Are you using any mods that may be adjusting the research during the finished event?
If you want to get ahold of me I'm almost always on IRC.
My Github page with my mods: https://github.com/Rseding91?tab=repositories
Find my mods on the mod portal: https://mods.factorio.com/mods/Rseding91
Rseding91
Factorio Staff
Factorio Staff
 
Posts: 5744
Joined: Wed Jun 11, 2014 5:23 am

Re: [15.23] Modding: on_research_finished event does not fire

Postby Aidiakapi » Mon Jul 17, 2017 9:20 pm

The report is invalid! Sorry for taking up some of your time.

The version was incorrect, as I was running [15.23] not [15.30] as I thought. The issue appears to have been fixed in [15.24]. I sadly wasted too much time trying to debug this. I should not have 7 installations at the same, I lost track of which ones were updated and which ones weren't, and when I made the report I apparently had a different install open, and checked the version on that.
Aidiakapi
Burner Inserter
Burner Inserter
 
Posts: 6
Joined: Fri Apr 14, 2017 6:13 pm


Return to Not a bug

Who is online

Users browsing this forum: No registered users and 2 guests