[Rseding91] [0.15.13] LuaCommand/LuaRemote bug

This subforum contains all the issues which we already resolved.

[Rseding91] [0.15.13] LuaCommand/LuaRemote bug

Postby folk » Fri May 19, 2017 5:03 pm

Hi,
I haven't investigated it fully, because frankly it's such a weird issue there is almost certainly something going on behind the scenes that is breaking it. I am 99% confident that this is a problem with the game engine, and not an issue with the individual mods.
Install these two mods:
https://mods.factorio.com/mods/ludsoe/moweather
https://mods.factorio.com/mods/folk/folk-shuttle

And you will get something like this error when you start a new game.
968.023 Error AppManager.cpp:421: __folk-shuttle__/control.lua:268 attempt to index a function value

Though the line number is probably different for the live version of folk-shuttle, this is not relevant. The relevant line in the code is something like:
require("lib-reset")(reset)

Now, unzip moweather 0.4.0, open control.lua, and comment out this line:
commands.add_command("dumpsettings","",function() game.write_file("MLCDump.txt", DumpScan(settings.runtime,0), false) end)
At control.lua, line 88

Start a new game, and the error is gone.
Last edited by folk on Tue May 23, 2017 4:07 pm, edited 1 time in total.
folk
Long Handed Inserter
Long Handed Inserter
 
Posts: 96
Joined: Fri Mar 03, 2017 5:00 pm

Re: [0.15.12] LuaCommand/LuaRemote bug

Postby Rseding91 » Fri May 19, 2017 8:08 pm

I get no such error when i load up the game with those 2 mods.

Is there something I need to do to make it happen beyond starting a new game?
If you want to get ahold of me I'm almost always on IRC.
My Github page with my mods: https://github.com/Rseding91?tab=repositories
Find my mods on the mod portal: https://mods.factorio.com/mods/Rseding91
Rseding91
Factorio Staff
Factorio Staff
 
Posts: 6035
Joined: Wed Jun 11, 2014 5:23 am

Re: [0.15.12] LuaCommand/LuaRemote bug

Postby folk » Fri May 19, 2017 9:43 pm

That's weird, I get it immediately upon creation of a new game and it drops back to the new-game settings screen.
folk
Long Handed Inserter
Long Handed Inserter
 
Posts: 96
Joined: Fri Mar 03, 2017 5:00 pm

Re: [0.15.12] LuaCommand/LuaRemote bug

Postby Rseding91 » Fri May 19, 2017 9:45 pm

Please upload your mods. Maybe the ones off the mod portal aren't the same as the ones you're using.
If you want to get ahold of me I'm almost always on IRC.
My Github page with my mods: https://github.com/Rseding91?tab=repositories
Find my mods on the mod portal: https://mods.factorio.com/mods/Rseding91
Rseding91
Factorio Staff
Factorio Staff
 
Posts: 6035
Joined: Wed Jun 11, 2014 5:23 am

Re: [0.15.12] LuaCommand/LuaRemote bug

Postby folk » Fri May 19, 2017 9:46 pm

folk
Long Handed Inserter
Long Handed Inserter
 
Posts: 96
Joined: Fri Mar 03, 2017 5:00 pm

Re: [0.15.12] LuaCommand/LuaRemote bug

Postby folk » Fri May 19, 2017 9:50 pm

Rseding91 wrote:Please upload your mods. Maybe the ones off the mod portal aren't the same as the ones you're using.

They are, I just downloaded both mods from the portal and ran the game with those zips only before I captured the log I posted in the previous comment.
folk
Long Handed Inserter
Long Handed Inserter
 
Posts: 96
Joined: Fri Mar 03, 2017 5:00 pm

Re: [0.15.12] LuaCommand/LuaRemote bug

Postby folk » Fri May 19, 2017 9:52 pm

Ooookay, so I just cleared my mod folder so that only those two zips existed, and now there is no error.
That log was produced when all other mods were disabled.
folk
Long Handed Inserter
Long Handed Inserter
 
Posts: 96
Joined: Fri Mar 03, 2017 5:00 pm

Re: [0.15.12] LuaCommand/LuaRemote bug

Postby folk » Fri May 19, 2017 10:02 pm

It's this mod https://mods.factorio.com/mods/Optera/VehicleGrid
With only folk-shuttle + moweather existing in the mods folder, there is no error.
With those two + vehiclegrid either enabled OR NOT enabled, the error is there.
Last edited by folk on Fri May 19, 2017 10:07 pm, edited 1 time in total.
folk
Long Handed Inserter
Long Handed Inserter
 
Posts: 96
Joined: Fri Mar 03, 2017 5:00 pm

Re: [0.15.12] LuaCommand/LuaRemote bug

Postby folk » Fri May 19, 2017 10:04 pm

Which means this is probably relevant:
info.json from folk-shuttle
Code: Select all
{
   "name": "folk-shuttle",
   "version": "0.1.12",
   "factorio_version": "0.15",
   "title": "Shuttle Train Lite",
   "author": "folk",
   "contact": "",
   "homepage": "https://forums.factorio.com/viewtopic.php?f=94&t=45554",
   "description": "A remake of the classic Shuttle Train by Simwir.",
   "license": "MIT",
   "dependencies": ["? VehicleGrid", "? FARL"]
}
folk
Long Handed Inserter
Long Handed Inserter
 
Posts: 96
Joined: Fri Mar 03, 2017 5:00 pm

Re: [0.15.13] LuaCommand/LuaRemote bug

Postby folk » Tue May 23, 2017 4:09 pm

Still present in 0.15.13
folk
Long Handed Inserter
Long Handed Inserter
 
Posts: 96
Joined: Fri Mar 03, 2017 5:00 pm

Re: [0.15.13] LuaCommand/LuaRemote bug

Postby Rseding91 » Tue May 23, 2017 4:17 pm

I've found what's wrong but the fix will take some time to finish.

Disabled/inactive mods are effecting other mods sort order which in turn effects event order.
If you want to get ahold of me I'm almost always on IRC.
My Github page with my mods: https://github.com/Rseding91?tab=repositories
Find my mods on the mod portal: https://mods.factorio.com/mods/Rseding91
Rseding91
Factorio Staff
Factorio Staff
 
Posts: 6035
Joined: Wed Jun 11, 2014 5:23 am

Re: [0.15.13] LuaCommand/LuaRemote bug

Postby Choumiko » Tue May 23, 2017 5:13 pm

Rseding91 wrote:Disabled/inactive mods are effecting other mods sort order which in turn effects event order.


That sounds nasty. I imagine there can be cases where it doesn't create an error but simply displays wierd behavior because of the changed order.

(Mostly posting so i can find this report easier :D)
Choumiko
Smart Inserter
Smart Inserter
 
Posts: 1214
Joined: Fri Mar 21, 2014 10:51 pm
Location: Germany

Re: [Rseding91] [0.15.13] LuaCommand/LuaRemote bug

Postby Rseding91 » Wed May 24, 2017 1:29 am

Ok, I actually found 3 bugs with this report :P

All 3 are now fixed for the next version of 0.15.
If you want to get ahold of me I'm almost always on IRC.
My Github page with my mods: https://github.com/Rseding91?tab=repositories
Find my mods on the mod portal: https://mods.factorio.com/mods/Rseding91
Rseding91
Factorio Staff
Factorio Staff
 
Posts: 6035
Joined: Wed Jun 11, 2014 5:23 am


Return to Resolved Problems and Bugs

Who is online

Users browsing this forum: No registered users and 1 guest