Improve/fix latency on vehicles on multiplayer

Post your ideas and suggestions how to improve the game.

Moderator: ickputzdirwech

Post Reply
alessandrouw
Burner Inserter
Burner Inserter
Posts: 6
Joined: Fri Jun 29, 2018 2:29 pm
Contact:

Improve/fix latency on vehicles on multiplayer

Post by alessandrouw »

TL;DR
When playing multiplayer, while in a vehicle (car/train/tank/etc) your movement should be treated somewhat client-based, same way it works when on foot

What ?
When you play in another friend's game/server, there is obviously a latency, even if very small. I play with a friend with 50 or less ms, which is very acceptable for mosts games such as moba and shooters. Factorio is fine, but entering a vehicle is a suicidal mission. That is because your movement seems to be totally validated server-side when in a vehicle. It takes miliseconds to accelerate, steer, brake, etc. I can drive just fine if I'm hosting or playing offline, but on a server I'm just a dangerous projectile waiting to crash at something. The controls are very unreliable. On foot the movement is fine, it's much more client side. Vehicles should follow the same rule for quality of life reasons. (Also, forgive my server/client side statements, I'm not completely sure how it works for real)
Why ?
Because playing with friends is so much fun, and I'm always restricted with movement when the base gets big because I avoid cars. It would benefit every player and there is no downside from the player perspective, I hope.

User avatar
eradicator
Smart Inserter
Smart Inserter
Posts: 5202
Joined: Tue Jul 12, 2016 9:03 am
Contact:

Re: Improve/fix latency on vehicles on multiplayer

Post by eradicator »

+infinity

I don't even bother trying vehicles in multiplayer anymore, becaues even if i carry my laptop over to my friends place and play via WIFI they're still too laggy to be useful, let alone enjoyable. This makes me very sad. Especially when said friend is having fun with modded cars :/.

This does apply to all combat in multiplayer with non-perfect-ping thought. On foot you get random jumping/teleporting instead the moment you start shooting :x. So my hopes for fixability are...low *sigh*.

User avatar
cpy
Filter Inserter
Filter Inserter
Posts: 835
Joined: Thu Jul 31, 2014 5:34 am
Contact:

Re: Improve/fix latency on vehicles on multiplayer

Post by cpy »

Yeah vehicles + wifi do not mix. Why can't you fix that?

User avatar
BlueTemplar
Smart Inserter
Smart Inserter
Posts: 2339
Joined: Fri Jun 08, 2018 2:16 pm
Contact:

Re: Improve/fix latency on vehicles on multiplayer

Post by BlueTemplar »

You have to remember the context of this suggestion - in preparation for and then during 0.17 Wube toyed with the idea of latency hiding during combat :
kovarex wrote:
Wed May 01, 2019 9:23 am
Hello. We have a latency hiding system, and it only contains some specifically programmed parts. Car handling isn't one of them.
It is in our schedule for 0.18 to add latency hiding to car driving, but it is not really a bug, but rather a feature to be programmed.
Philip017 wrote:
Thu Jul 04, 2019 8:02 pm
[*]Better latency hiding in multiplayer when experiencing connection issues. Less issues with rubber-banding or character teleporting.
[*]Latency hiding is no longer completely disabled when the character is shooting. Character position and animation are still not latency-hidden while the character is in combat (10 seconds after shooting or taking damage). This should make combat smoother in multiplayer.
I would have also liked to see latency hiding when connecting to a server for driving a car, sometimes it is very hard to drive when the response time till the car moves from when you press the button is too long and i crash into things. it would be nice if it was as smooth as when playing local.
Twinsen wrote:
Thu Jul 18, 2019 1:17 pm
Reverted it in Version: 0.17.59

It doesn't work identically to how it was before: Now it only disables latency hiding when your character is shooting(or trying to shoot) in the game state. Otherwise it's always doing latency hiding.

As far as i tested it feels pretty decent. Let me know what you think.
Now, I assume that the issue is that vehicle driving is considered to be part of combat (for some very good reasons).

But then you can often drive for very long stretches without any collisions, and I'm not sure how problematic it would be to have to handle in the latency state a few (?) entities getting destroyed by vehicle collisions ?

----

WiFi is a separate issue : it's inherently slow so Wube can't do anything about that - you're better off to avoid using it for real time tasks.

----

Finally, latency hiding doesn't come for "free" - if your latency is bad, you'll still have "rubber-banding" issues when your history doesn't correspond to the server's history.
But I think too that it would be *really* nice to have, because right now the vehicles that you have to manually drive are almost unusable at high latencies...
BobDiggity (mod-scenario-pack)

User avatar
cpy
Filter Inserter
Filter Inserter
Posts: 835
Joined: Thu Jul 31, 2014 5:34 am
Contact:

Re: Improve/fix latency on vehicles on multiplayer

Post by cpy »

I have crappy wifi but when walking and doing stuff in game even with bad latency is great! Why can't this system works for vehicles too? I don't care about combat I just use car to move around factory quickly and use it as an extra portable inventory.

User avatar
ptx0
Smart Inserter
Smart Inserter
Posts: 1358
Joined: Wed Jan 01, 2020 7:16 pm
Contact:

Re: Improve/fix latency on vehicles on multiplayer

Post by ptx0 »

cpy wrote:
Mon Jan 10, 2022 11:18 am
Yeah vehicles + wifi do not mix. Why can't you fix that?
works for me on LTE, your Wifi must be awful.

User avatar
BlueTemplar
Smart Inserter
Smart Inserter
Posts: 2339
Joined: Fri Jun 08, 2018 2:16 pm
Contact:

Re: Improve/fix latency on vehicles on multiplayer

Post by BlueTemplar »

What are your pings ?

LTE is "advanced 3G", right ? I shudder to think at the kind of ping you would get on cellular ?

(I have 4ms to factorio.com on fiber + 30m ethernet cable... but Factorio gameplay servers on another continent are another matter...)

P.S.: Just looking at the Wube-matchmaked servers, for the 5+ players ones I see pings between 24 and 172 ms (median 40 ms).
(Most of them though, I can't even ping/connect to - they probably didn't set them up properly - no port forwarding.)
BobDiggity (mod-scenario-pack)

User avatar
cpy
Filter Inserter
Filter Inserter
Posts: 835
Joined: Thu Jul 31, 2014 5:34 am
Contact:

Re: Improve/fix latency on vehicles on multiplayer

Post by cpy »

ptx0 wrote:
Wed Jan 12, 2022 3:22 pm
cpy wrote:
Mon Jan 10, 2022 11:18 am
Yeah vehicles + wifi do not mix. Why can't you fix that?
works for me on LTE, your Wifi must be awful.
Image

My pings are random 30ms-130ms

User avatar
ptx0
Smart Inserter
Smart Inserter
Posts: 1358
Joined: Wed Jan 01, 2020 7:16 pm
Contact:

Re: Improve/fix latency on vehicles on multiplayer

Post by ptx0 »

BlueTemplar wrote:
Wed Jan 12, 2022 5:01 pm
What are your pings ?

LTE is "advanced 3G", right ? I shudder to think at the kind of ping you would get on cellular ?
85ms. LTE is 4G. it's throughput that struggles when i download mods more than latency. when i'm in the middle of nowhere it's either good latency or absolutely awful packet loss.

Post Reply

Return to “Ideas and Suggestions”