Check for vehicle speed before releasing personal robots

Post your ideas and suggestions how to improve the game.

Moderator: ickputzdirwech

Post Reply
User avatar
Ingolifs
Long Handed Inserter
Long Handed Inserter
Posts: 78
Joined: Fri Mar 17, 2017 3:18 am
Contact:

Check for vehicle speed before releasing personal robots

Post by Ingolifs »

I think we've all had that moment when we're speeding away from a bunch of aliens in a slightly damaged car when a construction robot pops out to repair the car, gets outpaced and damaged by the pursuing aliens, another robot pops out to repair that robot and meets a similar fate, and soon you have ten robots trailing you getting eaten.

I understand that scalability of logistic robot task-setting is very important, and that having dumb robots is the price we pay for having a lot of them. So what I hope is a simple solution for this problem would be the following...

Check before releasing a robot that the player's (in vehicle) speed is greater than the robot's max speed. If the player is moving, say, faster than 0.75 times the max robot speed, do not release the robot.
While this doesn't eliminate the problem entirely (the retreating player could still crash into a rock, at which point the construction robots would leap out and get overwhelmed anyway), it would still serve to mitigate some of the more annoying robot behaviours, at presumably low CPU cost.

Roxor128
Fast Inserter
Fast Inserter
Posts: 143
Joined: Sun Oct 02, 2016 9:48 am
Contact:

Re: Check for vehicle speed before releasing personal robots

Post by Roxor128 »

It's not just when using vehicles that this happens. It happens when on foot, too. Both in early stages of using the personal roboport when the bots are still slow and especially when you have one or more exoskeletons in your powered armour.

User avatar
Ingolifs
Long Handed Inserter
Long Handed Inserter
Posts: 78
Joined: Fri Mar 17, 2017 3:18 am
Contact:

Re: Check for vehicle speed before releasing personal robots

Post by Ingolifs »

Roxor128 wrote:It's not just when using vehicles that this happens. It happens when on foot, too. Both in early stages of using the personal roboport when the bots are still slow and especially when you have one or more exoskeletons in your powered armour.
True, but it's generally easier to backtrack to get them when on foot, and also construction robots don't jump out and attempt to repair you while you're on foot. As far as I know, people by and large don't place blueprints while traveling in a vehicle either.

Roxor128
Fast Inserter
Fast Inserter
Posts: 143
Joined: Sun Oct 02, 2016 9:48 am
Contact:

Re: Check for vehicle speed before releasing personal robots

Post by Roxor128 »

Ingolifs wrote:
Roxor128 wrote:It's not just when using vehicles that this happens. It happens when on foot, too. Both in early stages of using the personal roboport when the bots are still slow and especially when you have one or more exoskeletons in your powered armour.
True, but it's generally easier to backtrack to get them when on foot, and also construction robots don't jump out and attempt to repair you while you're on foot. As far as I know, people by and large don't place blueprints while traveling in a vehicle either.
True, but it does, however, happen when you're trying to retreat from a mob of biters and run past something damaged. Robots try to go and fix it, and end up getting destroyed by the biters because they just love attacking robots.

leoch
Fast Inserter
Fast Inserter
Posts: 134
Joined: Fri Dec 16, 2016 9:37 pm
Contact:

Re: Check for vehicle speed before releasing personal robots

Post by leoch »

Please fix this! Please! Please!

Happens to me more using trains than any other time. When fighting in a tank I usually end up putting all my construction robots into the tanks inventory so that they can't fly.

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 12719
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: Check for vehicle speed before releasing personal robots

Post by ssilk »

Added to viewtopic.php?f=80&t=20566 Changes for the Personal Roboport
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

AntiBlueQuirk
Long Handed Inserter
Long Handed Inserter
Posts: 61
Joined: Wed May 03, 2017 2:57 pm
Contact:

Robots shouldn't jump out of speedy trains

Post by AntiBlueQuirk »

Simply put, construction robots should not leave the player's inventory (and vehicle inventories, for modded games) if the player is moving above a certain speed. (Maybe no faster than the robot's own speed?) This would prevent robots from leaping out of trains moving at 300 km/h to repair or build things and then getting lost because the player is long gone. I don't think this would be hard to implement, just disable the roboport from releasing robots when the containing entity is moving above the speed limit.

Factoruser
Fast Inserter
Fast Inserter
Posts: 139
Joined: Tue Sep 16, 2014 5:48 pm
Contact:

Re: Robots shouldn't jump out of speedy trains

Post by Factoruser »

Well thought out. But the speed limit should be already about 10 km/h, i.e. when nearly standing still.

Better suggestion: make a hotkey for toggling the personal roboport / => releasing of repair robots.

SuicideJunkie
Fast Inserter
Fast Inserter
Posts: 120
Joined: Wed Aug 23, 2017 10:17 pm
Contact:

Re: Robots shouldn't jump out of speedy trains

Post by SuicideJunkie »

At the least, the bots should grab the item from your inventory on the same tick as they leave, before you have a chance to move out of range.

I wouldn't mind having bots jump out to lay down some solar panels as I scream by on my way to somewhere and have them eventually catch up, as long as they actually complete the job.
Jumping out empty handed and then making sad robot noises is disappointing.

BHakluyt
Fast Inserter
Fast Inserter
Posts: 241
Joined: Sat Oct 08, 2016 12:43 pm
Contact:

Re: Robots shouldn't jump out of speedy trains

Post by BHakluyt »

I agree, robots shouldn't jump out when moving too fast. Currently I am having quite a fun game with Mods "Helicopters" and "Oh stop that silly robot." The latter mod allows you to change the percentage of speed at which construction robots will deploy when moving. With robot speed research 15 going I can nicely glide above railway blue prints with my chopper at about 100 km/h and have them recharge easily.

For some weird reason, occasionally you have to completely stop still for all to charge and get back in, otherwise the functionality is quite good. No more robots disembarking when at high speeds to build blueprints or repair stuff. I think the devs should definitely consider some nice touches like these for 0.17..

seanbrockest
Burner Inserter
Burner Inserter
Posts: 10
Joined: Sun Mar 30, 2014 7:44 pm
Contact:

Re: Robots shouldn't jump out of speedy trains

Post by seanbrockest »

BHakluyt wrote:I agree, robots shouldn't jump out when moving too fast. Currently I am having quite a fun game with Mods "Helicopters"
LOL, you don't need a helicopter or a train to have this problem. Just try sticking some exoskeletons in your power armor before you've researched enough drone speed upgrades.

I'm always leaving them behind :)

Koub
Global Moderator
Global Moderator
Posts: 6754
Joined: Fri May 30, 2014 8:54 am
Contact:

Re: Check for vehicle speed before releasing personal robots

Post by Koub »

[Koub] Merged topic into older one.
Koub - Please consider English is not my native language.

zOldBulldog
Smart Inserter
Smart Inserter
Posts: 1112
Joined: Sat Mar 17, 2018 1:20 pm
Contact:

Re: Robots shouldn't jump out of speedy trains

Post by zOldBulldog »

seanbrockest wrote:
BHakluyt wrote:I agree, robots shouldn't jump out when moving too fast. Currently I am having quite a fun game with Mods "Helicopters"
LOL, you don't need a helicopter or a train to have this problem. Just try sticking some exoskeletons in your power armor before you've researched enough drone speed upgrades.

I'm always leaving them behind :)
You don't even need exoskeletons. Early robots are so slow you'll leave them behind just walking.

Cars and trains make the problem worse, much worse. When you really feel it is when you are building a perimeter rail, and your bots take off midway to the worksite.

I've had bots take over 10 min IRL to catch up if I stand still, because the train loops in an arc around the perimeter and the bots start trying to reach me through a straight line with no charge and they could have launched in mid-ride at the opposite side of the map.

I think my record was about 1 hour, when I got fed up of waiting and started laying track by hand, running out of supplies and going back to base for more, rinse and repeat. The bots never reached me (as a matter of fact, in that map they are still lost somewhere). At least in-base I build with a grid of regular roboports or I'd be even more frustrated.

Post Reply

Return to “Ideas and Suggestions”