[0.17.x] Bob's Mods: General Discussion

Some mods, made by Bob. Basically streaks every Factroio-area.

Moderator: bobingabout

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6853
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by bobingabout » Thu Oct 03, 2019 10:26 pm

Maybe not the best example, but this was one of my main oil AND lithia water unloading station. Either train can arrive at either station and it works, but, only 2 pumps per wagon (for each fluid).

EDIT: Forgot the link
https://www.dropbox.com/s/u63x41vgvfx8p ... 0.png?dl=0
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

RocketManChronicles
Filter Inserter
Filter Inserter
Posts: 332
Joined: Mon Aug 01, 2016 2:38 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by RocketManChronicles » Thu Oct 03, 2019 11:29 pm

RocketManChronicles wrote:
Thu Oct 03, 2019 11:29 am
enchant wrote:
Wed Oct 02, 2019 6:47 pm
I've got a question. I'm sure this must have been discussed before, but I searched around in this thread and couldn't find what I'm looking for.

Especially in the late game, I find myself needing to move massive amounts of liquid from here to there. My 500 boilers need water from yonder lake way over there. My plastic plant needs petgas from the refineries up north. I'd love to have a mod that incorporates high capacity pipelines, but I've got to live with what we've got.

As soon as they're introduced, I use plastic pipes for everything. So I'll place down 12 offshore pumps that each feed into a pump-4, then three spans of underground pipes, another layer of pumps, three spans of undergrounds, etc., etc. I have no idea what they best layout would be, and I'm hoping someone could tell me here.
You are on the right track (see what I did there?) if you need lots of fluids everywhere. Like bob responded, I usually keep my power plants next to water sources, it is just one less liquid to move around. Now as for other fluids, trains are the way to go to move medium to long distances. The nice part about these is that you can have the train stations pump in/out of the tank wagons very quickly. Each tank wagon can have three pumps feeding or emptying it. so what you want to do is have three pumps connecting to each "top" of the tank wagon; those pumps are connected directly to a storage tank, and then connect all of the tanks together with pipes and undergrounds to help them act as one collection. you should have three storage tanks for each tank wagon at each end of the line. I am at work now, but will share a screenshot of what I have when I get home.

Also, I control the destination station with a simple circuit network, that connects and reads from all of the storage tanks at the station, and only allow train to enter when there is enough room in the tanks to accept a full train. This makes logistics easier so that you do not have a train waiting here to drop off the fluids. With this, I can have one train manage three or more destination stations as opposed to having one train for each route. Again, I will share screenshots later.
Image


Image

Ezarkal
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Apr 24, 2019 11:55 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by Ezarkal » Wed Oct 09, 2019 11:21 pm

Hello!

Currently having an issue with boblogistics.

"Failed to load mods: Error while running setup for entity prototype "pump" (pump): next:upgrade target (bob-pump-2) must have the same bounding box."

Haven't played in a while, so I don't know with which update this started up. It seems to be too late to easily roll back to a version prior to 0.17.69, so I'll just wait for the fix.

Cheers!


EDIT: Ignore that. My mods were not up-to-date. Everything works fine.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6853
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by bobingabout » Thu Oct 10, 2019 1:18 am

Ezarkal wrote:
Wed Oct 09, 2019 11:21 pm
Hello!

Currently having an issue with boblogistics.

"Failed to load mods: Error while running setup for entity prototype "pump" (pump): next:upgrade target (bob-pump-2) must have the same bounding box."

Haven't played in a while, so I don't know with which update this started up. It seems to be too late to easily roll back to a version prior to 0.17.69, so I'll just wait for the fix.

Cheers!


EDIT: Ignore that. My mods were not up-to-date. Everything works fine.
Yup, happens.

I've had a lot of reports like this actually, and at least half of them did just what you did... report, fix it yourself, add and edit to say it's fixed.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

mrvn
Smart Inserter
Smart Inserter
Posts: 3853
Joined: Mon Sep 05, 2016 9:10 am
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by mrvn » Thu Oct 10, 2019 10:51 am

bobingabout wrote:
Thu Oct 10, 2019 1:18 am
Ezarkal wrote:
Wed Oct 09, 2019 11:21 pm
Hello!

Currently having an issue with boblogistics.

"Failed to load mods: Error while running setup for entity prototype "pump" (pump): next:upgrade target (bob-pump-2) must have the same bounding box."

Haven't played in a while, so I don't know with which update this started up. It seems to be too late to easily roll back to a version prior to 0.17.69, so I'll just wait for the fix.

Cheers!


EDIT: Ignore that. My mods were not up-to-date. Everything works fine.
Yup, happens.

I've had a lot of reports like this actually, and at least half of them did just what you did... report, fix it yourself, add and edit to say it's fixed.
Isn't that a case of not having the right version in the dependencies/conflicts then?

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6853
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by bobingabout » Thu Oct 10, 2019 10:56 am

mrvn wrote:
Thu Oct 10, 2019 10:51 am
bobingabout wrote:
Thu Oct 10, 2019 1:18 am
Ezarkal wrote:
Wed Oct 09, 2019 11:21 pm
Hello!

Currently having an issue with boblogistics.

"Failed to load mods: Error while running setup for entity prototype "pump" (pump): next:upgrade target (bob-pump-2) must have the same bounding box."

Haven't played in a while, so I don't know with which update this started up. It seems to be too late to easily roll back to a version prior to 0.17.69, so I'll just wait for the fix.

Cheers!


EDIT: Ignore that. My mods were not up-to-date. Everything works fine.
Yup, happens.

I've had a lot of reports like this actually, and at least half of them did just what you did... report, fix it yourself, add and edit to say it's fixed.
Isn't that a case of not having the right version in the dependencies/conflicts then?
you can update newer versions to work, and even in most cases work with older versions of the game.

you can't go and edit older versions that people already have installed to with breaking game updates. This is the one I keep getting bug reports, the game updated and breaks a mod, you need a new mod to fix the error, but the game doesn't know this, and just errors at you... until you disable the mod, then check for mod updates.

This is one of the reasons why I think a launcher (Even though you can still start the game without it) is vitally important.
1. You can check for and install updates without loading the game itself (Which can save several minutes)
2. It can check for updates of mods too, not just the game, which gets around these bug reporting issues.
3. You could also use it to edit the game and mod settings, so you don't have even more restarts later.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

mrvn
Smart Inserter
Smart Inserter
Posts: 3853
Joined: Mon Sep 05, 2016 9:10 am
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by mrvn » Thu Oct 10, 2019 11:06 am

bobingabout wrote:
Thu Oct 10, 2019 10:56 am
mrvn wrote:
Thu Oct 10, 2019 10:51 am
bobingabout wrote:
Thu Oct 10, 2019 1:18 am
Ezarkal wrote:
Wed Oct 09, 2019 11:21 pm
Hello!

Currently having an issue with boblogistics.

"Failed to load mods: Error while running setup for entity prototype "pump" (pump): next:upgrade target (bob-pump-2) must have the same bounding box."

Haven't played in a while, so I don't know with which update this started up. It seems to be too late to easily roll back to a version prior to 0.17.69, so I'll just wait for the fix.

Cheers!


EDIT: Ignore that. My mods were not up-to-date. Everything works fine.
Yup, happens.

I've had a lot of reports like this actually, and at least half of them did just what you did... report, fix it yourself, add and edit to say it's fixed.
Isn't that a case of not having the right version in the dependencies/conflicts then?
you can update newer versions to work, and even in most cases work with older versions of the game.

you can't go and edit older versions that people already have installed to with breaking game updates. This is the one I keep getting bug reports, the game updated and breaks a mod, you need a new mod to fix the error, but the game doesn't know this, and just errors at you... until you disable the mod, then check for mod updates.

This is one of the reasons why I think a launcher (Even though you can still start the game without it) is vitally important.
1. You can check for and install updates without loading the game itself (Which can save several minutes)
2. It can check for updates of mods too, not just the game, which gets around these bug reporting issues.
3. You could also use it to edit the game and mod settings, so you don't have even more restarts later.
Yes, nothing you can do if the base mod breaks stuff. I was more thinking along the line of bobfoo breaking older bobbla. The update f bobfoo should then conflict with older versions of bobbla since you can't change the old version of bobbla.

Although it would be nice if the devs had a test system that would try to load every mod with the new version and let the mod authors know when something breaks compared to the last version.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6853
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by bobingabout » Thu Oct 10, 2019 11:10 am

mrvn wrote:
Thu Oct 10, 2019 11:06 am
bobingabout wrote:
Thu Oct 10, 2019 10:56 am
mrvn wrote:
Thu Oct 10, 2019 10:51 am
bobingabout wrote:
Thu Oct 10, 2019 1:18 am
Ezarkal wrote:
Wed Oct 09, 2019 11:21 pm
Hello!

Currently having an issue with boblogistics.

"Failed to load mods: Error while running setup for entity prototype "pump" (pump): next:upgrade target (bob-pump-2) must have the same bounding box."

Haven't played in a while, so I don't know with which update this started up. It seems to be too late to easily roll back to a version prior to 0.17.69, so I'll just wait for the fix.

Cheers!


EDIT: Ignore that. My mods were not up-to-date. Everything works fine.
Yup, happens.

I've had a lot of reports like this actually, and at least half of them did just what you did... report, fix it yourself, add and edit to say it's fixed.
Isn't that a case of not having the right version in the dependencies/conflicts then?
you can update newer versions to work, and even in most cases work with older versions of the game.

you can't go and edit older versions that people already have installed to with breaking game updates. This is the one I keep getting bug reports, the game updated and breaks a mod, you need a new mod to fix the error, but the game doesn't know this, and just errors at you... until you disable the mod, then check for mod updates.

This is one of the reasons why I think a launcher (Even though you can still start the game without it) is vitally important.
1. You can check for and install updates without loading the game itself (Which can save several minutes)
2. It can check for updates of mods too, not just the game, which gets around these bug reporting issues.
3. You could also use it to edit the game and mod settings, so you don't have even more restarts later.
Yes, nothing you can do if the base mod breaks stuff. I was more thinking along the line of bobfoo breaking older bobbla. The update f bobfoo should then conflict with older versions of bobbla since you can't change the old version of bobbla.

Although it would be nice if the devs had a test system that would try to load every mod with the new version and let the mod authors know when something breaks compared to the last version.
I must admit, that when I know a mod update isn't compatible with an older one, I change the dependencies to match, however, when I do it vs when it should be done in this 0.17 run is probably only about half the time.
For example, I made a few updates that used the new corpse graphics... but forgot to set the dependency to the version of the game that added it.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6853
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by bobingabout » Sun Oct 13, 2019 12:43 pm

I guess this is the (Bi)monthly update run. I'm slipping a bit.


Electronics 0.17.7:
Changed crude oil processing recipe to have oil input on only one pipe, like new basic oil processing.

Logistics 0.17.17:
Fixed turbo inserter locale entries.
Fixed "Mod contents are different even though versions are the same" error.

Mining 0.17.6:
Change all recipe enabled = "false" lines to enabled = false
Added a steam filter to the input of the steam powered mining drill.
Changed collision_box size of pumpjacks and water miners to match the base game pumpjack to fix fast replace and upgrade.

MCI 0.17.12:
Changed crude oil processing recipe to have oil input on only one pipe, like new basic oil processing.

Revamp 0.17.8:
Fixed the coal liquifaction changes.
Balanced enriched fuel from hydrazine recipe.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

Mecejide
Inserter
Inserter
Posts: 29
Joined: Mon Sep 23, 2019 8:12 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by Mecejide » Sun Oct 13, 2019 6:22 pm

Can you add a fusion-powered laser robot and a fusion-powered laser robot capsule with an unlimited lifespan?

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6853
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by bobingabout » Sun Oct 13, 2019 7:06 pm

Mecejide wrote:
Sun Oct 13, 2019 6:22 pm
Can you add a fusion-powered laser robot and a fusion-powered laser robot capsule with an unlimited lifespan?
This question was asked on the mod portal somewhere.

You can't do infinite lifespan, the game won't let you, however, you could set the expiry to... UINT32 maximum.. which works out at about 828 and a half days.
I'll consider it.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

Mecejide
Inserter
Inserter
Posts: 29
Joined: Mon Sep 23, 2019 8:12 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by Mecejide » Sun Oct 13, 2019 9:02 pm

bobingabout wrote:
Sun Oct 13, 2019 7:06 pm
This question was asked on the mod portal somewhere.
That was me. I posted it in both places in case you only read one of them.

RocketManChronicles
Filter Inserter
Filter Inserter
Posts: 332
Joined: Mon Aug 01, 2016 2:38 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by RocketManChronicles » Sun Oct 13, 2019 11:28 pm

Mecejide wrote:
Sun Oct 13, 2019 6:22 pm
Can you add a fusion-powered laser robot and a fusion-powered laser robot capsule with an unlimited lifespan?
This feels way overpowered... lol.

User avatar
BlueTemplar
Smart Inserter
Smart Inserter
Posts: 1812
Joined: Fri Jun 08, 2018 2:16 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by BlueTemplar » Mon Oct 14, 2019 8:11 am

But, they're fusion robots ! (remember that this means that they would take a fusion reactor to craft !)

Also, overpowered ? Have you played Bob's ? :lol:

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6853
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by bobingabout » Mon Oct 14, 2019 8:13 am

RocketManChronicles wrote:
Sun Oct 13, 2019 11:28 pm
Mecejide wrote:
Sun Oct 13, 2019 6:22 pm
Can you add a fusion-powered laser robot and a fusion-powered laser robot capsule with an unlimited lifespan?
This feels way overpowered... lol.
they're combat robots, they'll still die from being hit.
BlueTemplar wrote:
Mon Oct 14, 2019 8:11 am
But, they're fusion robots ! (remember that this means that they would take a fusion reactor to craft !)

Also, overpowered ? Have you played Bob's ? :lol:
Sounds expensive :P
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

halwap
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sat Sep 28, 2019 10:49 am
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by halwap » Mon Oct 14, 2019 6:06 pm

I'm playing Bob's for the first time and I am quite confused about belt speed. If I leave 'belt speed overhaul' unchecked is the speed of yellow, red etc. 15, 30 etc.? If so, what is the speed of basic belt?

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6853
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by bobingabout » Mon Oct 14, 2019 6:39 pm

halwap wrote:
Mon Oct 14, 2019 6:06 pm
I'm playing Bob's for the first time and I am quite confused about belt speed. If I leave 'belt speed overhaul' unchecked is the speed of yellow, red etc. 15, 30 etc.? If so, what is the speed of basic belt?
Half of yellow, 7.5
It's probably best to leave it off, it's a 0.16 setting, and it turns out that they've changed things in such a way that my old speeds don't work right anymore (they tell you they're moving at the speed you tell them to, but the items actually move slower)
I think they only work in steps of 1.875 (which is the default speed of 15 divided by 8. the speed is actually measured in pixels per tick, so the base is something like 60/32, and although 60/32 is 1.875, this isn't how you get to the 1.875 steps, the maths to explain that is actually quite long, and is related to the "fixed point" maths system they're using to measure the position of items on the belt, and the fact that an item takes up 8 pixels of a 32 pixel belt, with 2 lanes, therefore holding 8 items on a tile.), everything inbetween is rounded down to this number, so if you were to try and do 12.5 (which is the 0.16 speed I used) you actually get 11.25, because the step after that is 13.125, which is higher than the 12.5 we're after.

So belt speed overhaul defaults will just set grey belt to 15, yellow to 30, etc.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.
I also have a Patreon.

User avatar
BlueTemplar
Smart Inserter
Smart Inserter
Posts: 1812
Joined: Fri Jun 08, 2018 2:16 pm
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by BlueTemplar » Mon Oct 14, 2019 9:56 pm

I feel like this mention in the "Transport Belt Speed Overhaul" tooltip about speed multiples should instead (or also) be for the "Transport belt for tier" tooltip ?
Attachments
Screenshot from 2019-10-14 23-52-24.png
Screenshot from 2019-10-14 23-52-24.png (138.42 KiB) Viewed 492 times

evandy
Long Handed Inserter
Long Handed Inserter
Posts: 65
Joined: Mon Apr 15, 2019 2:54 am
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by evandy » Mon Oct 28, 2019 3:06 am

Is Cobaltite a really rare spawn chance? I just spent about 15 minutes driving around in the car as soon as I unlocked it, and saw some of everything else. Single patches of Rutile and Gemstones, 2-3 of Uranium, Tungsten, Silver, & Gold. Plenty of Nickel, Galena, Zinc, Silicon, etc. I am using RSO with default settings, which will likely make a difference here.

This is my first Bob's only game (did Bobs & Angels together last time), so I'm still getting used to the number of raw ores with plain-Bob.

orzelek
Smart Inserter
Smart Inserter
Posts: 3610
Joined: Fri Apr 03, 2015 10:20 am
Contact:

Re: [0.17.x] Bob's Mods: General Discussion

Post by orzelek » Mon Oct 28, 2019 8:22 am

evandy wrote:
Mon Oct 28, 2019 3:06 am
Is Cobaltite a really rare spawn chance? I just spent about 15 minutes driving around in the car as soon as I unlocked it, and saw some of everything else. Single patches of Rutile and Gemstones, 2-3 of Uranium, Tungsten, Silver, & Gold. Plenty of Nickel, Galena, Zinc, Silicon, etc. I am using RSO with default settings, which will likely make a difference here.

This is my first Bob's only game (did Bobs & Angels together last time), so I'm still getting used to the number of raw ores with plain-Bob.
Did you enable the ore? From what I recall it's not enabled by default. You will get it as side product from some other production chain.
Also it seems tht for some reason it's set to be slightly more rare in RSO anyway so it might require a bit of searching even when enabled.

Post Reply

Return to “Bob's mods”

Who is online

Users browsing this forum: No registered users