Page 1 of 1

Cant Join Friends Multiplayer Map Fix

Posted: Wed Jul 14, 2021 8:13 am
by MittensX11
I tried everything possible to be able to join my friends game but to no avail.
i tried port forwarding, changing OS, static IPs, Direct IP connect with port number, Allowing through firewall, creating custom firewall rules, changing game versions, wiping Factorio app data and more i cant remember.

what i notice was that although i port forwarded the correct Factorio ports, the port was constantly changing, and i could see this in the dropped packet logging on my modem router. it would drop packets from that port and my friends IP address every time i tried to connect. when i allowed the port it was randomly changing to, in the port forwarding section i would try to connect again and would be using a different port.

because my friend uses a static IP address i was able to set the "source IP" in the port forwarding section to his IP. i then allowed the maximum port range "1:65535", so no matter the port it wants to use, it will allow it, but only from the Source IP. that allowed the map to download as normal and not get stuck on 0kbs downloading screen.