Migrated 1.0 save not loading in 1.1

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
DarkShadow44
Long Handed Inserter
Long Handed Inserter
Posts: 56
Joined: Thu Jun 01, 2017 12:05 pm
Contact:

Migrated 1.0 save not loading in 1.1

Post by DarkShadow44 »

I tried to use the "Movie player" save from viewtopic.php?f=193&t=37490

Save download, converted and saved by the latest 1.0 stable: https://www.mediafire.com/file/qdu91zow ... m.zip/file

I converted the saves over a few versions (0.15, 0.17, 1.0), but it won't load in 1.1:
factorio.png
factorio.png (15.1 KiB) Viewed 250 times

Note: I tried to edit the save, but the control.lua doesn't cause the error... It's something inside level.dat, which I can't unpack.

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 4865
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: Migrated 1.0 save not loading in 1.1

Post by Klonan »

Hi,

Please try to follow the steps listed here:

viewtopic.php?f=49&t=95422

The error is caused by the control lua

DarkShadow44
Long Handed Inserter
Long Handed Inserter
Posts: 56
Joined: Thu Jun 01, 2017 12:05 pm
Contact:

Re: Migrated 1.0 save not loading in 1.1

Post by DarkShadow44 »

Thanks for the reply,

I looked at the steps, and then figured out that, somewhere in the migration, it created a folder "sandstorm" (= name of my save!) in the scenarios folder. I have no idea why that was created, but deleting it makes the save work.

Maybe something to add in your post as well..?

Thanks for your help (awesome as usual), and sorry for the useless bugreport...

Post Reply

Return to “Technical Help”