[1.1.6] Loading Blueprint storage failed

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
GoRingo
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Jun 08, 2019 11:16 pm
Contact:

[1.1.6] Loading Blueprint storage failed

Post by GoRingo »

Hi,
I went from 0.17 to 1.1 lately, to play few hours - my blueprint library was fine. Today I updated to 1.1.6 and I am getting this error:

Loading blueprint storage failed: Map version 0.17.79-0 cannot be loaded because it is lower than the minimum input version (0.18.0-0).. Backing up current storage...

So in my Factorio folder I have new blueprint-storage.dat which is empty.. and the backup (4MB). Renaming and copying only results to same error. I quite dont understand how to fix it - I didnt performed any downgrade, only updates. Could you please help me to retrieve my blueprints?

Thanks
Tomas

Loewchen
Global Moderator
Global Moderator
Posts: 7076
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [1.1.6] Loading Blueprint storage failed

Post by Loewchen »

Copy the backup bp file into a 1.0.0 installation and rename it, ad some bp to the library, move the file to your up to date installation.

GoRingo
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Jun 08, 2019 11:16 pm
Contact:

Re: [1.1.6] Loading Blueprint storage failed

Post by GoRingo »

Thanks.. that recovered some. When starting game I have received a lot of "too old" message and 30 - 40 % blueprints are gone..

cantina_fly
Burner Inserter
Burner Inserter
Posts: 8
Joined: Fri Jul 19, 2019 5:35 pm
Contact:

Re: [1.1.6] Loading Blueprint storage failed

Post by cantina_fly »

I just hit this after coming back to 1.1 after not playing a while. I did play some 1.0, but apparently never created any new blueprints so my library was still 0.17.79 I'm going through trying to fix this now and wanted to add some additional info to save anyone else this headache.

I loaded up a 1.0 game with my .17 library backup and made a dump blueprint of the starting furnace and miner, but make sure you drag it to your "My Blueprints" tab or it won't update your library.

The next wrinkle I hit is I'm a 100% BA player. When I loaded up a new 1.1 game after updating, all my blueprints that contained BA items were blank. My ones from vanilla were fine. So I'm assuming I now need to go recreate my 1.0 mod list and redo the update so all the relevant mod entities are present when I update the library.

I'm not really griping, you accept certain "challenges" when playing with mods and Wube has gone out of their way to make that easy. But I've spent 100's or hours on that library so starting a game without it feels "naked" for lack of a better word.

cantina_fly
Burner Inserter
Burner Inserter
Posts: 8
Joined: Fri Jul 19, 2019 5:35 pm
Contact:

Re: [1.1.6] Loading Blueprint storage failed

Post by cantina_fly »

To wrap this up I was finally able to fully recover my blueprint library today. Luckily my daughters computer still had a 1.0 build with all mods from our last multiplayer game, so I was able to drop my 0.17 backup on her machine and upgrade. Was 95% recovered on the first try. There were 6 blueprints that were still blank in 1.1 and looking at them in 1.0 I could not edit them and they had a message "The blueprint cannot be altered, its data is saved separately..." This was a big deal as those blueprints made up my mall. Reddit said to put them down in a sandbox game and resave them which did indeed let them work properly in 1.1 afterward.

Hopefully this helps anyone that comes after. :D

Post Reply

Return to “Technical Help”