[1.0.0] Crash, out of memory

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
michelguenette
Manual Inserter
Manual Inserter
Posts: 1
Joined: Tue Nov 10, 2020 9:41 pm
Contact:

[1.0.0] Crash, out of memory

Post by michelguenette »

I will try to explain what happened. Sorry for the novella you are about to read.

Last night, my time zone, I finished working on some blueprints. As usual, I hit Escape and saved the current map following my own file naming convention. It saved without any warnings or issues and I exited Factorio before heading to bed.

This afternoon, I wanted to resume working on the same blueprints. When I attempted to open the file, I received a "bad allocation" message in a pop-up window. I dismissed it and I tried again. It happened again. I quickly checked my autosave files to verify the game-time. The previous autosave was less than 3 minutes before. I decided to exit the game before trying to open any other files.

I exited and launched Factorio a second time. I tried to load the same file with the bad allocation message. It happened again. This time, I resorted to opening the autosave file that was closest to my own file. It opened without any messages. Within 15 seconds, I saved a new file to give myself a jumping off point for any other problems that might arise.

Just over an hour ago (yes, it has taken me this long to get to this stage since the crash), I had just finished editing some blueprints. They are in "My blueprints". The book is Malls and it has books for my preparation to complete a "There is no spoon" speedrun. I believe that are two levels of nesting: My blueprints > Malls > [There is no spoon -- Building; There is no spoon -- Furnaces; etc.] > [Various malls | Stone Furnaces; Steel Furnaces]. I was working on designs for my furnaces just before the crash.

I started a digital timer as a reminder that I needed to take a break to make supper, shortly after that, I zoomed out and started to move East while looking for an area to alter with the editor. (I neglected to mention at the beginning that I was in the sandbox campaign with the editor enabled.) It is at this time that all three of my screens went black. I could still hear the game music, but I lost the ability to do anything with the laptop.

Turning off and on one of my monitors seemed to be enough to force the laptop to refresh its screens and try to display something. My attempts to interact with any application or window was thwarted. I could not access anything on the task bar. It would just disappear. Trying to use a browser was almost as pointless. When I finally managed to get Task Manager to display something, I noted the error window listed under Factorio. Whenever I attempted to click on the pop-up window or its buttons, I would lose the ability to interact with the applications and the windows again. Finally, I managed to get a screen shot using SnagIt, so that is how I managed to get here in the end.

Whatever that crash did, it did a number on my ability to use my laptop and my operating system in order to dismiss it.

So, the important information that you probably wanted at the beginning of this novella.
[*]Vanilla only (I have never downloaded and installed mods). I upgraded from [0.17.79] to [1.0.0] on or just before Halloween night. (I hit the limitations with the blueprint library in the previous version and I wanted to start my achievement hunt on November 1 without any issues.)
[*]Sandbox world with the editor enabled
[*]I had just finished sorting some blueprints in some nested books
[*]Zoomed out to maximum, I believe
[*]Started to travel East in order to scout out a new set of chunks to prepare the terrain for designing more blueprints
[*]Screens turned off as the same time and I could not interact with the game

I took a look at the log file. I noted in the file's comments where you might want to focus your efforts.

I will take a break for supper and try to load my autosave files. According to the log file, the latest one was saved less than a minute before the crash happened. I will probably duplicate the files first before they get overwritten during another design session.

I hope that this helps you to determine what happened to my game and my laptop for it requiring a restart to allow me to use it as normal again.

Thank you.

P.S.: Please let me know if you need any other files from me. I will put side copies of the saved games in a separate folder. They should be under 20MB in size, if it helps you to know that.
Attachments
factorio-current.log
Search for "6329.767 Time travel logging:". That seems to be when my screens turned off and I lost the ability to access any application on my laptop without using Task Manager for each action.
(11.36 KiB) Downloaded 51 times

Loewchen
Global Moderator
Global Moderator
Posts: 6433
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [1.0.0] Crash, out of memory

Post by Loewchen »

You ran out of memory, close other programs before starting factorio and restart your system from time to time to prevent that.

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: No registered users