[1.0.0] Crash loading save: Entity::setup

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
vereathor
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sun Oct 25, 2020 9:25 am
Contact:

[1.0.0] Crash loading save: Entity::setup

Post by vereathor »

Hello together,

my actual savegame and the last Autosaves are corrupted. This happend the 3rd time. 2 Times i was able to "repair" it via loading an other old Savegame and load the wanted Savegame then.


The error can be triggered by simply loading the Savegame. It doesen't matter if you use the "last-Savegame" button or "singleplayer/load savegame". Please be aware, I'm using the german UserInterface, so the buttons may differ.

I tried loading the Savegame with/without Mods, Other Programs running, etc. I didn't recognice any common cause issuse to those modifications.


best regards
Vere'Athor
Attachments
GLEISWAHN.zip
(46.42 MiB) Downloaded 14 times
factorio-previous.log
(16.03 KiB) Downloaded 17 times

vereathor
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sun Oct 25, 2020 9:25 am
Contact:

Re: [1.0.0] Crash loading save: Entity::setup

Post by vereathor »

The problem is still a problem. I just tried the actual 1.1 experimental without any changes.

I also tested two other PC. The problem persists.

I have no Idea how to fix the issue
Attachments
factorio-current.log
logfile 1.1 experimental
(20.51 KiB) Downloaded 8 times

vereathor
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sun Oct 25, 2020 9:25 am
Contact:

Re: [1.0.0] Crash loading save: Entity::setup

Post by vereathor »

thanks to the latest Experimental version i found out the position of the problem[Position.png].
after i managed to load the save via repetetiv loading try'n'errors
the problem is: i can't diassamble it [Bugfinder.png] due to the enemys belonging
the next logical step was to kill it. [factorio.current.log]

that doesn't works either

anyone an idea how to solve the problem? e.g. external map editor?
Attachments
Bugfinder.png
Bugfinder.png (2.01 MiB) Viewed 92 times
Bugfinder.png
Bugfinder.png (2.01 MiB) Viewed 92 times
factorio-current.log
(22.57 KiB) Downloaded 4 times

Loewchen
Global Moderator
Global Moderator
Posts: 6613
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: [1.0.0] Crash loading save: Entity::setup

Post by Loewchen »

Try deleting the entity, load the save in the latest experimental version, go in editor mode (/editor), delete the rail.

Rseding91
Factorio Staff
Factorio Staff
Posts: 11669
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [1.0.0] Crash loading save: Entity::setup

Post by Rseding91 »

I can fix the save file but it's in 1.1 so you'll have to opt into the experimental branch if you want to keep playing it.

You had a random bit flip on that entities force. It could have been random or it could be bad RAM on your computer.
GLEISWAHN-fixed.zip
(45.87 MiB) Downloaded 4 times
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: No registered users