Page 1 of 1

[1.0.0] Sulfur researched, not craftable

Posted: Tue Sep 15, 2020 9:05 pm
by Dragonkiller1777
Hey there,

I've started hunting some achivements in factorio, and since I did not want to start from scratch, I used a savegame that was modded previously. It was from version 0.18.18-1
Full mod list:

Code: Select all

Factorissimo2 2.4.1
base 0.18.18
bobassembly 0.18.4
bobclasses 0.18.2
bobelectronics 0.18.1
bobenemies 0.18.3
bobequipment 0.18.1
bobgreenhouse 0.18.0
bobinserters 0.18.1
boblibrary 0.18.3
boblogistics 0.18.7
boblogistics-belt-reskin 0.18.3
bobmining 0.18.1
bobmodules 0.18.2
bobores 0.18.1
bobplates 0.18.5
bobpower 0.18.4
bobrevamp 0.18.1
bobtech 0.18.3
bobvehicleequipment 0.18.1
bobwarfare 0.18.3
I had to use this save, since all my other saves were too old. Converting it went fine, lost lots of things, but that was to be expected.

Now I played this savegame for a while, and noticed, that I was not able to craft sulfur. It does simply not show up in the crafting menu of the chemical plant, or even my personal crafting menu:
NoSulfur.png
NoSulfur.png (3.51 MiB) Viewed 117 times
I do have sulfur processing researched:
YesSulfur.png
YesSulfur.png (1.57 MiB) Viewed 117 times


As for troubleshooting steps: I did reload a save, and deleted the sulfur processing research via a lua command, and re-researched it normally. that worked, but unfortunately even removing a technology makes achievements unavailable, thus negating the point of the savegame.

Is there any way, I can get my recipe back, withput loosing the access to achivements?

Thanks in advance,
Chris

Re: [1.0.0] Sulfur researched, not craftable

Posted: Tue Sep 15, 2020 9:11 pm
by Loewchen
See 54297.

Re: [1.0.0] Sulfur researched, not craftable

Posted: Fri Sep 18, 2020 6:48 pm
by Dragonkiller1777
Hey Loewchen,

Thanks for the quick reply!
As said, I tried to delete the research via a lua command, and that worked. But that also disables achivements.
I guess there is just no way around this issue for me, and I have to start from scratch.

Thanks for your help

Chris ;)