Page 1 of 1

Map/minimap sprites messed up

Posted: Thu Sep 12, 2019 8:07 am
by husnikadam
Hi,
I've encountered a bug, so I decided to report it - a bug regarding map and minimap sprites. I don't know, how to explain it, so I just show you:
Capture.PNG
Capture.PNG (128.16 KiB) Viewed 231 times
This happens to me quite often on my machine since I started playing it on this machine (it's about 6 weeks = 6 new Factorio versions without a fix). Doesn't matter on zoom level, In game (standard, no-map view) there are no problems. I think it more related to graphics settings and machine specs rather than a map save. Used latest Factorio version
Graphics settings (in Czech):
Capture1.PNG
Capture1.PNG (43.07 KiB) Viewed 231 times
Some system specs: 16GB RAM, Intel Xeon CPU E5-1620 v3 3.5GHz (8 logical processors), 256GB SSD, Nvidia Quatro 400 (512MB), 2 monitors (2k and FullHD)

Re: Map/minimap sprites messed up

Posted: Thu Sep 12, 2019 8:10 am
by Loewchen
Post the log please, see my signature.

Re: Map/minimap sprites messed up

Posted: Thu Sep 12, 2019 8:12 am
by husnikadam
Update: this is new to me. I've restarted the game (restarted a client, game runs on a server) and completely new sprites problem:
Capture.PNG
Capture.PNG (488.65 KiB) Viewed 225 times

Re: Map/minimap sprites messed up

Posted: Thu Sep 12, 2019 8:15 am
by husnikadam
Log as requested
factorio-current - Copy.log
(13.18 KiB) Downloaded 17 times

Re: Map/minimap sprites messed up

Posted: Thu Sep 12, 2019 8:24 am
by TheBloke
I saw something like this 8 months ago, Jan 2019, in 0.16.51.

I was exploring the map at the time, driving around to areas far from my normal base, in a car (or tank, can't remember), and on several occasions had a situation where the map/minimap would corrupt, exactly as the OP describes - although my corruptions looked a bit different.

Here's two screenshots I took at the time, when I posted about it on Reddit.
Screenshots
Then it stopped happening, and never happened again, so I didn't think any more about it. I've never seen it in 0.17.

At the time I was playing on 0.16.51, in macOS 10.14.1, on AMD 7970Ghz (R9 280X) 3GB GPU. Not sure as to graphical settings, but likely lowered from default.

Re: Map/minimap sprites messed up

Posted: Thu Sep 12, 2019 9:12 am
by posila
Hello, there's not really much I can do. Try to restart the computer.

Re: Map/minimap sprites messed up

Posted: Thu Sep 12, 2019 10:01 am
by husnikadam
Restarting did help, but for how long? It's really annoying bug

Re: Map/minimap sprites messed up

Posted: Thu Sep 12, 2019 11:10 am
by posila
husnikadam wrote:
Thu Sep 12, 2019 10:01 am
Restarting did help, but for how long? It's really annoying bug
I would suggest to update the graphics driver, but the one you have is already the latest one nVidia released for your GPU and you already play on the lowest graphics settings, so I don't have any software-side solution for this problem. You can try to disable "Use flip presentation model" and see if it makes any difference, but that's just a shot in the dark.

Re: Map/minimap sprites messed up

Posted: Thu Sep 12, 2019 2:08 pm
by husnikadam
I've tried to disable the setting and after fast check the glitches don't occur, let me play the game and after day or two I can confirm either fix or bug still present.

Re: Map/minimap sprites messed up

Posted: Sat Sep 14, 2019 6:10 pm
by husnikadam
Toggling the settings maybe has helped, but didn't solve the problem.