Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Thu Sep 05, 2019 5:32 am

I've been playing Factorio on my 2 laptops for a while (MacBook Pro with dedicated graphics and a Dell Vostro 7590 with dedicated GTX 1650). Recently I got an LG 4K HDR monitor (27UK650_600). The monitor is connected to my Dell laptop via thunderbolt port through an HDMI to USB-C adapter.

In this setup, somehow Factorio doesn't use the dedicated 1650 GPU to its full potential. I can barely get 31 FPS/49 UPS on the base I'm playing right now. There's no performance drop when I play the game directly on either laptop or with my MacBook Pro connected to the monitor. Problem is only with Windows laptop connected to the monitor.

When I'm playing the game, CPU doesn't exceed 50%. Integrated GPU stays around 55% and the dedicated GPU is only at 25%.

Things I've tried so far -

- Nvidia GeForce Experience detects the 1650 GPU properly
- Intel UHD graphics control panel detects the monitor as 4k 60Hz properly
- 1650 GPU is set for 3d settings in Nvidia Control Panel
- Whisper mode and Battery boost are disabled on the Nvidia GeForce Experience

factorio_current.log showing all the hardware information

Code: Select all

   0.000 2019-09-04 22:16:59; Factorio 0.17.68 (build 47074, win64, steam)
   0.000 Operating system: Windows 10 (version 1903) 
   0.000 Program arguments: "C:\Program Files (x86)\Steam\steamapps\common\Factorio\bin\x64\Factorio.exe" 
   0.000 Read data path: C:/Program Files (x86)/Steam/steamapps/common/Factorio/data
   0.000 Write data path: C:/Users/conta/AppData/Roaming/Factorio [390029/470922MB]
   0.000 Binaries path: C:/Program Files (x86)/Steam/steamapps/common/Factorio/bin
   0.007 System info: [CPU: Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz, 12 cores, RAM: 6782/16164 MB, page: 9331/19108 MB, virtual: 4325/134217727 MB, extended virtual: 0 MB]
   0.007 Display options: [FullScreen: 1] [VSync: 1] [UIScale: automatic (100.0%)] [Native DPI: 1] [Screen: 255] [Special: 0000] [Lang: en]
   0.018 Available displays: 2
   0.018  [0]: \\.\DISPLAY1 - Intel(R) UHD Graphics 630 {0x05, [0,0], 3840x2160, 32bit, 60Hz}
   0.018  [1]: \\.\DISPLAY2 - Intel(R) UHD Graphics 630 {0x01, [3840,0], 1920x1080, 32bit, 60Hz}
   0.367 Initialised OpenGL:[0] GeForce GTX 1650/PCIe/SSE2; driver: 3.3.0 NVIDIA 436.15
   0.367   [Extensions] s3tc:yes; KHR_debug:yes; ARB_clear_texture:yes, ARB_copy_image:yes
   0.367   [Version] 3.3
   0.368 Graphics settings preset: very-high
   0.368   Dedicated video memory size 4096 MB
   0.404 Desktop composition is active.
   0.404 Graphics options: [Graphics quality: high] [Video memory usage: all] [Light scale: 100%] [DXT: high-quality]
   0.404                   [Max load threads: 32] [Max texture size: 0] [Tex.Stream.: 0] [Rotation quality: normal] [Color: 32bit]
   0.683 DSound: Starting _dsound_update thread
   0.683 DSound: Enter _dsound_update; tid=7416
   
Album of all the relevant settings screens - https://imgur.com/a/6gtSpab

Koub
Global Moderator
Global Moderator
Posts: 5032
Joined: Fri May 30, 2014 8:54 am
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by Koub » Thu Sep 05, 2019 7:32 am

Could you show us the CPU tab, with display divided into logical cores ?
Like so
Koub - Please consider English is not my native language.

posila
Factorio Staff
Factorio Staff
Posts: 3864
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by posila » Thu Sep 05, 2019 9:15 am

Please provide also information requested here: 68653

You are using OpenGL renderer, I assume you got "Factorio crashed due to video card reset or removal." error and switched to OpenGL because of that?

Do you have the issue also on a new singleplayer map?

For OpenGL there are not many options that you could try - basically just try to turn off "Wait for V-sync" in graphics options (you might need to restart the game after that - nVidia OpenGL often fails to change the v-sync setting during runtime)

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Thu Sep 05, 2019 3:54 pm

Koub wrote:
Thu Sep 05, 2019 7:32 am
Could you show us the CPU tab, with display divided into logical cores ?
Like so
Here you go -
cpu_logical_processors.jpg
CPU divided into logical processors
cpu_logical_processors.jpg (224.05 KiB) Viewed 398 times

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Thu Sep 05, 2019 4:17 pm

posila wrote:
Thu Sep 05, 2019 9:15 am
Please provide also information requested here: 68653

Do you have the issue also on a new singleplayer map?

For OpenGL there are not many options that you could try - basically just try to turn off "Wait for V-sync" in graphics options (you might need to restart the game after that - nVidia OpenGL often fails to change the v-sync setting during runtime)
Attached all the information mentioned in the linked post.
You are using OpenGL renderer, I assume you got "Factorio crashed due to video card reset or removal." error and switched to OpenGL because of that?
I didn't observe any crashes. I've been playing normally directly on the laptop. Performance drop is seen when connected to the 4K monitor.

I've tried turning the "Wait for V-sync" off and on but that hasn't helped.

Mods and my savefile are in this Google Drive folder - https://drive.google.com/open?id=1i6bFo ... _lfm05kjvq
Attachments
factorio-current-new-single-player.log
Log from new single player game
(7.96 KiB) Downloaded 5 times
factorio-current-my-save-game.log
Log from my save game
(8.01 KiB) Downloaded 8 times
new_single_player_game.jpg
Screenshot for new single player game
new_single_player_game.jpg (3.19 MiB) Viewed 391 times
screenshot_with_debug_info.jpg
Screenshot with debug info ON
screenshot_with_debug_info.jpg (2.93 MiB) Viewed 391 times

posila
Factorio Staff
Factorio Staff
Posts: 3864
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by posila » Thu Sep 05, 2019 4:24 pm

manjhi wrote:
Thu Sep 05, 2019 4:17 pm
You are using OpenGL renderer, I assume you got "Factorio crashed due to video card reset or removal." error and switched to OpenGL because of that?
I didn't observe any crashes. I've been playing normally directly on the laptop. Performance drop is seen when connected to the 4K monitor.
In that case, can you open Factorio properties in Steam Library and set launch options to

Code: Select all

--force-d3d
and see if that changes anything?

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Thu Sep 05, 2019 4:26 pm

Attaching screenshot and log from the same setup where my MacBook Pro is connected to the same monitor (with the same cable through the same adapter) instead of the Dell.
Attachments
Screen Shot 2019-09-05 at 9.21.04 AM copy.jpg
Screenshot when the MBP is attached to the same monitor
Screen Shot 2019-09-05 at 9.21.04 AM copy.jpg (3.4 MiB) Viewed 385 times
factorio-current.log
Log from same save but running on the MBP attached to the same monitor
(7.38 KiB) Downloaded 9 times

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Thu Sep 05, 2019 5:40 pm

posila wrote:
Thu Sep 05, 2019 4:24 pm
manjhi wrote:
Thu Sep 05, 2019 4:17 pm
You are using OpenGL renderer, I assume you got "Factorio crashed due to video card reset or removal." error and switched to OpenGL because of that?
I didn't observe any crashes. I've been playing normally directly on the laptop. Performance drop is seen when connected to the 4K monitor.
In that case, can you open Factorio properties in Steam Library and set launch options to

Code: Select all

--force-d3d
and see if that changes anything?
I'll try this today evening when I'm back home.

Koub
Global Moderator
Global Moderator
Posts: 5032
Joined: Fri May 30, 2014 8:54 am
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by Koub » Thu Sep 05, 2019 7:24 pm

manjhi wrote:
Thu Sep 05, 2019 3:54 pm
Koub wrote:
Thu Sep 05, 2019 7:32 am
Could you show us the CPU tab, with display divided into logical cores ?
Like so
Here you go -

cpu_logical_processors.jpg
Factorio is mostly single threaded, or more precisely, most of the load will be distributed in one thread, and a bit less on a second one. The rest that can be spread out is insignificant. Seeing your screenshot, I'd say your CPU is the limiting factor :
CPU limited
When you say (emphasis mine) :
manjhi wrote:
Thu Sep 05, 2019 5:32 am
When I'm playing the game, CPU doesn't exceed 50%. Integrated GPU stays around 55% and the dedicated GPU is only at 25%.
I feel you're excluding the fact your CPU is not the limiting factor. I thik it is. It might be because your GPU doesn't do all what could be expected from it though.
Koub - Please consider English is not my native language.

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Thu Sep 05, 2019 8:06 pm

I feel you're excluding the fact your CPU is not the limiting factor. I thik it is. It might be because your GPU doesn't do all what could be expected from it though.
That makes sense. Another thing I noticed is when I play the game on Mac, Factorio detects the monitor as 1920x1080. However, on Windows, it's detected as a 4K monitor. May be Mac is rendering everything at a lower resolution? Also, Factorio doesn't even list the integrated GPU on Mac, just the dedicated GPU.

I need to figure out 2 things -
  • Why is the dedicated GPU not being used primarily on Windows when connected to the external monitor?
  • Is Factorio rendering everything in 1080p on Mac vs 4K on Windows?
These 2 must be contributing to the performance problem I'm having.

posila
Factorio Staff
Factorio Staff
Posts: 3864
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by posila » Thu Sep 05, 2019 8:26 pm

manjhi wrote:
Thu Sep 05, 2019 8:06 pm
Why is the dedicated GPU not being used primarily on Windows when connected to the external monitor?
It is

Code: Select all

0.339 Initialised OpenGL:[0] GeForce GTX 1650/PCIe/SSE2; driver: 3.3.0 NVIDIA 436.15
manjhi wrote:
Thu Sep 05, 2019 8:06 pm
Is Factorio rendering everything in 1080p on Mac vs 4K on Windows?
No, it's 4K on Mac too

Code: Select all

   1.091   [Size] Window: 1920x1080, Backbuffer: 3840x2160

According to screenshots with timings everything is much slower on the Windows machine not just rendering, and there are some extreme spikes. Which is weird given the HW is possibly better than the one in the MacBook. I'd suspect new Cortana update eating lot of CPU power causing the machine to heat a lot and throttle (https://www.techradar.com/news/microsof ... -to-fix-it, https://linustechtips.com/main/topic/11 ... d-testers/) but you say it works fine on the main display, so it sounds like something related to the USB-C adapter you are using. Is this problem only in Factorio?

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Thu Sep 05, 2019 8:37 pm

posila wrote:
Thu Sep 05, 2019 8:26 pm
According to screenshots with timings everything is much slower on the Windows machine not just rendering, and there are some extreme spikes. Which is weird given the HW is possibly better than the one in the MacBook. I'd suspect new Cortana update eating lot of CPU power causing the machine to heat a lot and throttle (https://www.techradar.com/news/microsof ... -to-fix-it, https://linustechtips.com/main/topic/11 ... d-testers/) but you say it works fine on the main display, so it sounds like something related to the USB-C adapter you are using.
So at least we know that Factorio is indeed using the dedicated GPU and is rendering the game in 4K on both platforms.

I'll try the HDMI cable connecting directly to HDMI port on the laptop to rule out the adapter. I'm pretty sure I've tried it but I'll try it again just to make sure. I think I've disabled Cortana, but I'll check that too.
Is this problem only in Factorio?
I wouldn't know. I use the windows laptop just to play Factorio. I don't play any other games either. Are there any gaming benchmarks I can run that can give me more information?

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Fri Sep 06, 2019 3:33 am

Adding --force-d3d to launch options on Steam helped a lot. Now FPS stays consistent with UPS, which hovers anywhere from 47 to 54 depending on what's on the screen. Still not on par with Mac though, which stays at 60 consistently.

Attaching the log file after enabling the launch options.

- Moving the cable from the adapter to directly on the HDMI port on the laptop didn't make any difference. So the adapter seems fine.
- Cortana is disabled entirely. It doesn't show up in the Task Manager either.
Attachments
factorio-current.log
(8.36 KiB) Downloaded 6 times

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Mon Sep 09, 2019 8:26 pm

Is there anything I can do to get consistent 60 FPS/UPS? The CPU and GPU are better in the Windows laptop, but my MBP is able to get better performance. I know I can't compare Windows with Mac straight-up, but I assumed the Windows version of Factorio would be more optimized than the Mac version.

Anything else I can run to figure out what's causing the performance difference between the two?

posila
Factorio Staff
Factorio Staff
Posts: 3864
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by posila » Tue Sep 10, 2019 9:43 am

I am not computer specialist and don't know how to diagnose general PC performance issue, I am sorry.
Just to make sure it's not just Factorio can you try to download Cinebench R20, run it on both Macbook and the Windows laptop, and compare scores?

EDIT: Also, can you please install HWMonitor, and make screenshot of it while running Factorio?

kreeg
Burner Inserter
Burner Inserter
Posts: 9
Joined: Thu Apr 05, 2018 9:18 pm

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by kreeg » Thu Sep 12, 2019 1:42 pm

Excuse me for chiming in here.

Just for the sake of attempting to resolve this issue let us experiment with disabling the integrated graphics and then retry loading the game and see how the performance changes. By disabling the integrated graphics this will force the system to use the Nvidia 1650 under all circumstances. After the experiment you can re-enable the integrated graphics if you need to.

In order to disable the UHD 630 you will need to go into Device Manager. Next restart the computer and double check Device Manager to ensure the UHD 630 is still disabled then run Factorio again.

You should notice immediately an increase in performance. We can double check the log file and task manager again to ensure that the game is utilizing the Nvidia 1650. If so then we have resolved the issue.

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Fri Sep 13, 2019 3:59 am

posila wrote:
Tue Sep 10, 2019 9:43 am
I am not computer specialist and don't know how to diagnose general PC performance issue, I am sorry.
Just to make sure it's not just Factorio can you try to download Cinebench R20, run it on both Macbook and the Windows laptop, and compare scores?

EDIT: Also, can you please install HWMonitor, and make screenshot of it while running Factorio?
I ran Cinebench R20 multiple times and got the scores in range of 1700 to 1880. Attaching the screenshot of HWMonitor when Factorio is running.
Attachments
Annotation 2019-09-12 205828.jpg
Annotation 2019-09-12 205828.jpg (651.29 KiB) Viewed 134 times

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Fri Sep 13, 2019 4:03 am

kreeg wrote:
Thu Sep 12, 2019 1:42 pm
Excuse me for chiming in here.

Just for the sake of attempting to resolve this issue let us experiment with disabling the integrated graphics and then retry loading the game and see how the performance changes. By disabling the integrated graphics this will force the system to use the Nvidia 1650 under all circumstances. After the experiment you can re-enable the integrated graphics if you need to.

In order to disable the UHD 630 you will need to go into Device Manager. Next restart the computer and double check Device Manager to ensure the UHD 630 is still disabled then run Factorio again.

You should notice immediately an increase in performance. We can double check the log file and task manager again to ensure that the game is utilizing the Nvidia 1650. If so then we have resolved the issue.
I've already tried that. Disabling internal GPU makes the game totally unplayable. UI comes to almost stand-still.

kreeg
Burner Inserter
Burner Inserter
Posts: 9
Joined: Thu Apr 05, 2018 9:18 pm

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by kreeg » Sun Sep 15, 2019 4:56 am

Running two monitors on a single video card will also decrease performance.

Did you unplug the second monitor as well or are you still running two monitors from the video card?

manjhi
Inserter
Inserter
Posts: 26
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: Help me diagnose Factorio low FPS/UPS performance on external 4k monitor

Post by manjhi » Sun Sep 15, 2019 7:40 pm

kreeg wrote:
Sun Sep 15, 2019 4:56 am
Running two monitors on a single video card will also decrease performance.

Did you unplug the second monitor as well or are you still running two monitors from the video card?
I'm only running one monitor. The laptop screen is either turned off or the lid is down.

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: Google [Bot]