debian 7 help GLIBC_2.14 GLIBC_2.15 server factorio

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Pyroman_Goliath
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sat Nov 05, 2016 4:43 pm
Contact:

debian 7 help GLIBC_2.14 GLIBC_2.15 server factorio

Post by Pyroman_Goliath »

ENG

I really need help on the subject, please.

Good morning, everyone.

So before we start, a little reminder from me.
Yes I am on Debian 7. Yes, it's an old obsolete version. Yes, it is more up to date. Yes I am an old man:), Yes ,Yes ,Yes yes, etc etc etc etc......

In short, if I am here, it is because I am in a dead end, and I have tried quite a few solutions that have not worked.
Some things are a bit outdated, BUT, if I'm in this kind of case, it's because I don't have the means, whether it's hardware, personnel, technical, etc.....
So I don't accept answers like that. "do an update to solve your problem." I don't want it: 021:

So I'm doing an installation of Debian 7 in x64 on a real machine. (CURRENTLY), A clean installation for a short while.

Although the version is old, I managed to find packages here, which I added to my sources.list in "/etc/apt"
"deb http://archive.debian.org/debian/ wheezy contrib main"
I'm not against finding other sources for sources.list too.

And to their current, or I block, it's for the installation of a factorio server (also an old version in 14.19). But my concern is not about the factorio server itself.

But rather to the packets that the factorio server needs to work. Because yes, for a while, I had managed to make it work. But I forgot to take notes, here it is:(Image

And so right now, when I want to run the factiorio server (no, I'm not going to kill it:)). I get an error message, telling me that I need to install:

GLIBC_2.14 and GLIBC_2.15.

Except I can't find anything concrete for installing these packages.
And I need you to find these packages and install them.

Here, I look forward to your answers.
By thanking you.


FR

J'ai vraiment besoin d'aide sur le sujet s'il vous plait.

Bonjour à tous.

Alors avant de commencé, un petit rappel de ma part.
Oui je suis sur Debian 7. Oui c'est une vieille version obsolète. Oui elle est plus à jour. Oui je suis un vieux :), Oui ,Oui oui, etc etc etc....

Bref, si je suis ici, c'est que je suis dans une impasse, et que j'ai essayé pas mal de solution qui n'ont rien abouti.
Certe pas mal de chose sont un peu dépassé, MAIS, si je suis dans ce genre de cas, c'est que les moyens me manque, que ce sois Hardware, personnel, technique, etc etc....
Donc je n'accepte pas les réponses du genre. "fais une MAJ pour réglé t'on problème". J'en veux pas :021:

Alors je suis en train de faire une installation de Debian 7 en x64 sur une machine réelle. (ACTUELLEMENT), Une installation au propre durant un petit moment.

Malgré que la version soit vieille, j'ai réussi à trouvé des paquets ici, que j'ai ajouté à ma sources.list dans "/etc/apt"
"deb http://archive.debian.org/debian/ wheezy contrib main"
Je ne suis pas contre pour trouvé d'autres sources pour les sources.list aussi.

Et à leur actuelle, ou je bloque, c'est pour l'installation d'un serveur factorio (aussi une vieille version en 14.19). Mais mon souci ne concernant pas le serveur factorio en lui même.

Mais plutôt aux paquets que le serveur factorio à besoin pour fonctionner. Car oui durant une époque, j'avais réussi à le faire fonctionner. Mais j'ai oublié de prendre des notes, Voila :(Image

Et donc à l'heure actuelle, lorsque je veux éxécuté le serveur factiorio (non je ne vais pas le tuer :)). J'ai un message d’erreur , me disant que je dois installé:

GLIBC_2.14 et GLIBC_2.15.

Sauf que je ne trouve rien de concret pour l'installation de ces paquets.
Et j'ai besoin de vous pour trouvé ces paquets et les installers.

Voila, j'attends vos réponses avec impatience.
En vous remerciant.

Zavian
Smart Inserter
Smart Inserter
Posts: 1617
Joined: Thu Mar 02, 2017 2:57 am
Contact:

Re: debian 7 help GLIBC_2.14 GLIBC_2.15 server factorio

Post by Zavian »

If you really do not want to upgrade to a newer version of Debian, then I recommend installing Debian Jessie (or maybe something even more recent) in a chroot environment. (Don't simply upgrade your existing libc. That might cause problems, and recovering from those might be difficult if libc is broken).

For a simplified guide to setting up a chroot see https://www.simplified.guide/debian/bui ... nvironment . But you probably should think about upgrading to something with security support.

cybersteel8
Inserter
Inserter
Posts: 37
Joined: Sat Aug 27, 2016 1:39 pm
Contact:

Re: debian 7 help GLIBC_2.14 GLIBC_2.15 server factorio

Post by cybersteel8 »

Might be related - I am running my headless server on CentOS 7 and that didn't have glibc 2.18 so I had to manually compile it to run the server.

You could do the same thing?

I followed instructions from here: viewtopic.php?f=49&t=54619
More information: 54654

Post Reply

Return to “Technical Help”