[0.17.9] and 0.17 in general: OpenGL 3.3

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
keiner
Manual Inserter
Manual Inserter
Posts: 2
Joined: Mon Mar 11, 2019 1:29 pm
Contact:

[0.17.9] and 0.17 in general: OpenGL 3.3

Post by keiner »

Hey there,

0.17.0 release notes stated this:
Modernized and optimized rendering backend. The game now uses DirectX 11 or OpenGL 3.3 Core and requires DirectX 10 class graphics card.
Is there any chance to ever play 0.17.x on my crappy linux laptop with OpenGL 2.1? Some kind of an old shitty laptop compatibility mode? I actually can't afford a new one right now and really would like to play the new version.

Further on: Any chance to play it (same core-i 1st gen laptop) using windows? I'm a windows noob. So is DirectX 11 support just a software update or is it hardware related?

Thanks for your time and thanks for any help.

posila
Factorio Staff
Factorio Staff
Posts: 4507
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17] OpenGL

Post by posila »

I am sorry, OpenGL 3.3 is the "old shitty laptop compatibility mode".

DirectX 11 is part of Windows 7 and higher, but you still need DirectX 10 compatible graphics card to play the game. AFAIK 1st gen Intel Core-i didn't have GPUs integrated on CPU die, so I don't know what kind of GPU you have, and whether it is DX10 compatible.

keiner
Manual Inserter
Manual Inserter
Posts: 2
Joined: Mon Mar 11, 2019 1:29 pm
Contact:

Re: [0.17] OpenGL

Post by keiner »

posila wrote:
Mon Mar 11, 2019 1:46 pm
DirectX 11 is part of Windows 7 and higher, but you still need DirectX 10 compatible graphics card to play the game.
I'm using a Thinkpad x201 with GMA 5700MHD. Seems like it got hardware support for DirectX 10. So I'll definitely give it a try with Windows . Thanks a lot :)

frenchiveruti
Inserter
Inserter
Posts: 21
Joined: Mon Apr 11, 2016 11:32 pm
Contact:

Re: [0.17.9] and 0.17 in general: OpenGL 3.3

Post by frenchiveruti »

Too bad... :(
I was hoping to be able to run the game on an old laptop but I'm out of the scope of OpenGL, my CPU/GPU combo runs max OpenGL 2.1.
It's a Pentium I give you that, but it's from 2010, but I understand that 10 years it's a lot of time :mrgreen:

Post Reply

Return to “Technical Help”

Who is online

Users browsing this forum: No registered users