Page 1 of 1

[Linux 0.16.51]Linux headless server won't start mapTick(4294967295) changing state from(Ready) to(Closed)

Posted: Sat Feb 02, 2019 11:27 pm
by kentsfield
Hey Folks,

I followed the tutorial on the factorio wiki to set up a Linux headless server, did everything like its described and used the factorio init script for starting/stopping the server like a service. But once the game starts, it immediatly ends. The log file says the following:

Code: Select all

   0.000 2019-02-03 00:01:10; Factorio 0.16.51 (build 36654, linux64, headless)
   0.028 Operating system: Linux (Debian 8.11)
   0.028 Program arguments: "/home/kentsfield/factorio/factorio/bin/x64/factorio" "--config" "/home/kentsfield/factorio/factorio/config/config.ini" "--port" "34197" "--start-server-load-latest" "--server-settings" "/home/kentsfield/fact$
   0.028 Read data path: /home/kentsfield/factorio/factorio/data
   0.028 Write data path: /home/kentsfield/factorio/factorio [1499149/1775740MB]
   0.028 Binaries path: /home/kentsfield/factorio/factorio/bin
   0.041 System info: [CPU:         Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz, 8 cores, RAM: 32123 MB]
   0.041 Environment: DISPLAY=<unset>, WAYLAND_DISPLAY=<unset>
   0.041 Running in headless mode
   0.046 Loading mod core 0.0.0 (data.lua)
   0.062 Loading mod base 0.16.51 (data.lua)
   0.191 Loading mod base 0.16.51 (data-updates.lua)
   0.227 Checksum for core: 840319042
   0.227 Checksum of base: 3323233190
   0.323 Info PlayerData.cpp:65: Local player-data.json available, timestamp 1549148403
   0.323 Info PlayerData.cpp:72: Cloud player-data.json unavailable
   0.324 Custom inputs active: 0
   0.324 Factorio initialised
   0.324 Info GlobalContext.cpp:696: Waiting for child processes to exit:
   0.324 Info ServerMultiplayerManager.cpp:142: Quitting multiplayer connection.
   0.324 Info ServerMultiplayerManager.cpp:699: mapTick(4294967295) changing state from(Ready) to(Closed)
   0.370 Goodbye
Well, this "error" or info code does not really help at all. I tried to search for it on google and found some similar results, but the people just say "nevermind, fixed it, thx" - Also not a great help :|

I hope you can help me. Thanks in advance!