[Solved][15.40] Crackling sound on linux

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
lateGoodbye
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri Feb 03, 2017 9:58 pm

[Solved][15.40] Crackling sound on linux

Post by lateGoodbye » Sat Dec 09, 2017 10:11 am

Firstly: This practically a copy of viewtopic.php?f=49&t=21512&p=135234&hil ... io#p135202
but those fixes there didn't work for me, so I still cannot have Factorio and another application output sound together without one or both of them being distorted or completly muted.

I am running Debian GNU/Linux 9 "stretch" here with pulseaudio 10.0.

Neither the

Code: Select all

load-module module-udev-detect tsched=0
option in default.pa, nor the

Code: Select all

padsp $command
wrapper solved it for me.

This is not game breaking, but very annoying sind I prefer my music or a podcast while playing factorio.
The culprit (as I see it) is the way factorio get the sound into the system, which is by using the alsa-plugin for pulseaudio which doesn't work properly as it seems.
The solution on the top of my head would be to have factorio's sound output directly to pulseaudio to circumvent this. This would require to rewrite part of the sound engine of factorio (I think),
which is work at least, maybe pain to do so too.

If anyone has any idea, let me know it, if you need more details please contact me.
I didn't include any technical specifications, since I don't think, that my hardware specifications are relevant to the issue, but please correct me, if I am wrong here

EDIT:
I discovered, that this problem doesn't occur on my laptop with archlinux, so I took a look at the differences. The most obvious one was, that pulseaudio there was on version 11, so I upgraded pulseaudio to version 11 on debian (from buster) and this solved the problem, although I have to add, that I am back to running the maintainer configuration file now, since they sometimes options get deprecated.

Post Reply

Return to “Technical Help”