Video Memory Usage setting - confusing + constant lags peaks

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Locked
mp0011
Fast Inserter
Fast Inserter
Posts: 216
Joined: Mon Mar 20, 2017 1:17 am
Contact:

Video Memory Usage setting - confusing + constant lags peaks

Post by mp0011 »

I have PC under requirements, and I know it. It's C2Quad 2.8GHz, 8GB, 6850 1GB.

However, game runs just great with everything set to max (sprites, textures, light, smokes etc).
Sometimes drops with high de-zoom near lot of bots, accumulators discharges or other animated entities (to 40FPS), but otherwise it can keep 150FPS (with game.speed increased). (My Factory is not very big...)

There is just one setting causing issues - Video Memory Usage. When it's set to HIGH, strange lag peaks appears. Every (exactly) 3s game everything including background windows pauses for few frames, even if game is paused and/or minimised.

Fps counter drops from 60 to 55, then backs to 60, until next lag.
Even in new game, with nothing around.

So, despite option description (Higher setting => increased performance), performance on HIGH is worst than at MEDIUM or ALL.

As I am assuming now, Medium setting requires <somewhere below 1024> MB of vram, High <somewhere above 1024> MB of vram and All means 1024MB.
So, therefore, High is above my vram limit, and GPU loads additional data every 3s...

But it is not obvious, and I have played long time with lags or unnecessarly reduced quality because of this.

Is it possible to change this setting options to something like this (add predicted/calculated/predefined memory requirements for each setting):
LOW (vram: 512MB-640MB)
MEDIUM (vram: 768MB-900MB)
HIGH (vram: 1210MB-1366MB)
-------
ALL (vram: 1024MB) <= You have so much.

User avatar
Distelzombie
Filter Inserter
Filter Inserter
Posts: 336
Joined: Tue May 02, 2017 4:27 pm
Contact:

Re: Video Memory Usage setting - confusing + constant lags peaks

Post by Distelzombie »

I rember there beeing a warning when you set it to quality to high and you have not enough VRAM
Complete 2-Lane system as a Blueprint-Book! The perfect OCD reactor? Testing chained science lab efficiency Please use real prefixes and proper rounding!

mp0011
Fast Inserter
Fast Inserter
Posts: 216
Joined: Mon Mar 20, 2017 1:17 am
Contact:

Re: Video Memory Usage setting - confusing + constant lags peaks

Post by mp0011 »

Distelzombie wrote:I rember there beeing a warning when you set it to quality to high and you have not enough VRAM
There is, but on Sprites quality, not memory usage. High res sprites works perfect, despite warning... On all settings, except Memory usage = high. There also should be warning, or attached recommended memory amount.

User avatar
Distelzombie
Filter Inserter
Filter Inserter
Posts: 336
Joined: Tue May 02, 2017 4:27 pm
Contact:

Re: Video Memory Usage setting - confusing + constant lags peaks

Post by Distelzombie »

mp0011 wrote:There is, but on Sprites quality, not memory usage. High res sprites works perfect, despite warning... On all settings, except Memory usage = high. There also should be warning, or attached recommended memory amount.
But you are complaining that it does not work perfect.

However I understand you point as: "Please add a message warning you about this combination"
Complete 2-Lane system as a Blueprint-Book! The perfect OCD reactor? Testing chained science lab efficiency Please use real prefixes and proper rounding!

mp0011
Fast Inserter
Fast Inserter
Posts: 216
Joined: Mon Mar 20, 2017 1:17 am
Contact:

Re: Video Memory Usage setting - confusing + constant lags peaks

Post by mp0011 »

What I mean - I can play perfectly well with hi-res sprites after ignoring the warning, with high margin of performance. Sprites size is NOT a performance degrading factor. It's vram memory management. If game can make 150FPS, but in the same time pauses for fraction of second every 3s, because of other setting, it's something wrong here.

I believe, lot of people eg. on laptops keep using medium or low sprites, because they try to increase performance with memory usage setting (description may suggest it), while keeping resolution low. It's big waste of really good hi-res sprites ;)

User avatar
mexmer
Filter Inserter
Filter Inserter
Posts: 860
Joined: Wed Aug 03, 2016 2:00 pm
Contact:

Re: Video Memory Usage setting - confusing + constant lags peaks

Post by mexmer »

game warns you that you need 2GB of VRAM, when using high settings, you have 1GB, so what exactly is you complaining about?

it's not problem of VRAM management, because you can only store so much in VRAM, and they already accounted for it, that's why it gives warning, if you ignore the warning, then you should expect problems.

orzelek
Smart Inserter
Smart Inserter
Posts: 3838
Joined: Fri Apr 03, 2015 10:20 am
Contact:

Re: Video Memory Usage setting - confusing + constant lags peaks

Post by orzelek »

What you are asking for is not that simple.
The fact that on your GPU/driver configuration using high memory with high textures causes lags doesn't mean that it's like that on other configurations.

On the other hand texture memory usage all doesn't mean it uses all mem that you have - it means it tries to load all the data it has to VRAM. After that GPU ends managing what is in actual VRAM or RAM and swapped as needed. And since you are forcing settings you shouldn't (high sprites with 1GB of VRAM) in that configuration it stutters because it needs to swap big texture atlases often. It also doesn't guarantee that it won't do that with all or medium in other circumstances - it might depend on where are you in your factory and how many entities are around that are not in VRAM at that moment. And as you build more and need to render more it's bound to start dropping FPS.

Locked

Return to “Technical Help”