[0.15.3] error updating to [0.15.5]

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Posts: 21
Joined: Sun Oct 02, 2016 2:48 pm

[0.15.3] error updating to [0.15.5]

Post by alefu »

I have currently 0.15.3 installed (originally downloaded 0.15.0 and updated to 0.15.1, 0.15.2 and 0.15.3 without problems when they came out).
Upon starting Factorio, I get the info that 0.15.5 is out and I can update. However, after downloading the first zip file there is a pause of about 5-10 seconds and then I get the following error (OK quits Factorio):
"Error when reading from file."
I have tried several times now.

Running Factorio as administrator doesn't help.
Resetting my router didn't help.
The zip file (in the Factorio temp folder) seems to be fine, I could extract it using 7-zip.
Here are the relevant lines of the file factorio-current.log:
18.129 Info Updater.cpp:743: Downloading https://updater.factorio.com/get-downlo ... iVersion=2
18.719 Info Updater.cpp:232: Downloading http://eu2.factorio.com/updates/core-wi ... 1493569925 to D:\Spiele\Factorio_0.15_vanilla\temp\core-win64-0.15.3-0.15.4-update.zip
22.400 Info Updater.cpp:243: => 200
30.426 Error Util.cpp:58: Error when reading from file.
I "solved" this now by redownloading the complete 0.15.5 version from the Factorio website.
2017-04-30 15_31_40-Factorio 0.15.3.png
2017-04-30 15_31_40-Factorio 0.15.3.png (273.24 KiB) Viewed 406 times

Post Reply

Return to “Technical Help”