Factorio crashing on linux without an errorlog

Anything that prevents you from playing the game properly. Do you have issues playing for the game, downloading it or successfully running it on your computer? Let us know here.
Post Reply
Revilum
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sun Sep 18, 2022 12:38 am
Contact:

Factorio crashing on linux without an errorlog

Post by Revilum »

as soon as I hit play, the game stays in steam on 'running' for ~0.5 seconds after which the button just returns to play. no logfile is create in the ~/.factorio folder.
Running steam in console doesn't give out any errors.
Starting Factorio with proton gives me the following error mesage:

Code: Select all

   0.000 2022-09-18 02:44:19; Factorio 1.1.69 (build 60061, win64, steam)
   0.000 Operating system: Windows 10 (build 19043) 
   0.000 Program arguments: "Z:\home\nils\daten2\SteamLibrary\steamapps\common\Factorio\bin\x64\factorio.exe" 
   0.000 Read data path: Z:/home/nils/daten2/SteamLibrary/steamapps/common/Factorio/data
   0.000 Write data path: C:/users/steamuser/AppData/Roaming/Factorio [266163/703082MB]
   0.000 Binaries path: Z:/home/nils/daten2/SteamLibrary/steamapps/common/Factorio/bin
   0.036 System info: [CPU: AMD Ryzen 7 3700X 8-Core Processor, 16 cores, RAM: 9326/32025 MB, page: 9326/47281 MB, virtual: 142/134217727 MB, extended virtual: 0 MB]
   0.036 Display options: [FullScreen: 1] [VSync: 1] [UIScale: automatic (100.0%)] [Native DPI: 1] [Screen: 255] [Special: lmw] [Lang: de]
   0.053 Available displays: 3
   0.053  [0]: \\.\DISPLAY1 - AMD RADV NAVI10 (ACO) {0x05, [0,0], 1920x1080, 32bit, 144Hz}
   0.053  [1]: \\.\DISPLAY2 - AMD RADV NAVI10 (ACO) {0x01, [1920,0], 1920x1080, 32bit, 144Hz}
   0.054  [2]: \\.\DISPLAY3 - AMD RADV NAVI10 (ACO) {0x01, [-1920,0], 1920x1080, 32bit, 60Hz}
   0.197 [Direct3D11] Display: 0, Output: 0, DisplayAdapter: 0, RenderingAdapter: 0; d3dcompiler_47.dll
   0.246 Initialised Direct3D[0]: AMD RADV NAVI10 (ACO); id: 1002-731f; driver: aticfx64.dll 32767.65535.65535.65535@ 65535.65535.65535.65535
   0.246   D3D Feature Level: 11.1, DXGI 1.5+, SwapChain: 3,flip-discard,-,-,-,none
   0.246   [Local Video Memory] Budget: 6639MB, CurrentUsage: 212MB, Reservation: 0/3319MB
   0.246   [Non-Local Vid.Mem.] Budget: 15861MB, CurrentUsage: 66MB, Reservation: 0/7930MB
   0.246   Tiled resources: Not supported
   0.246   Unified Memory Architecture: No
   0.246   BGR 565 Supported: Yes
   0.246   MaximumFrameLatency: 3, GPUThreadPriority: 0
   0.246 Graphics settings preset: very-high
   0.246   Dedicated video memory size 8192 MB
   0.246 D3D11_ERROR: D3DCompile failed in GraphicsInterfaceDX11::setupShadersForPipelineState::<lambda_3f5d3df3f855b70fec35425caf6dd9c7>::()::<lambda_3a9244df1589d9c453ca07bee3877a59>::operator () on line 2277. Error [0x80004005] - E_FAIL
   0.246 Info GraphicsInterfaceDX11.cpp:2278: Failed to compile shader __core__/graphics/shaders/sprite.vsh as vs_4_0: __core__/graphics/shaders/sprite.vsh:3:48: E5000: syntax error, unexpected '(', expecting ';' or ','

   0.306 Error Util.cpp:83: Failed to compile shader __core__/graphics/shaders/sprite.vsh as vs_4_0: __core__/graphics/shaders/sprite.vsh:3:48: E5000: syntax error, unexpected '(', expecting ';' or ','

   3.861 Steam API shutdown.
   3.864 Goodbye
I'm on debian sid/bookworm and my GPU is a AMD Radeon RX 5700XT if that matters.
I'm clueless how to get an error message so I hope someone here can help me.

Loewchen
Global Moderator
Global Moderator
Posts: 7554
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Factorio crashing on linux without an errorlog

Post by Loewchen »

Restart your machine if you have not already and try without proton, if this does not work check if the non-steam linux version works.

User avatar
jodokus31
Smart Inserter
Smart Inserter
Posts: 1423
Joined: Sun Feb 26, 2017 4:13 pm
Contact:

Re: Factorio crashing on linux without an errorlog

Post by jodokus31 »

I would directly switch to non-steam version.

Revilum
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sun Sep 18, 2022 12:38 am
Contact:

Re: Factorio crashing on linux without an errorlog

Post by Revilum »

ok thanks after downloading the game not from steam it seems to be working. the native steam client also just crashes without any error. no idea what the issue could be...

EDIT: deleting /usr/lib/libsteam_api.so also fixed the problem for steam wtf.

Post Reply

Return to “Technical Help”