[1.1.59] Factorio Modded Server -- Player Instantly Disconnected Upon Load

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Grahnath
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Jun 15, 2022 10:09 pm
Contact:

[1.1.59] Factorio Modded Server -- Player Instantly Disconnected Upon Load

Post by Grahnath »

Hi all,

I have just updated my headless server to 1.1.59, and now when players connect to it, they load in, but they cannot move, and they can't interact with menus very easily. Any attempts at movement or placing blocks causes huge amounts of stuttering and glitchy sounds (repeated attempts to place the block). After 5-30 seconds, the player is disconnected from the game. I have attached factorio-current.log, which should hopefully help. Again, before updating the server and the mods, this was not an issue. I have already backed up the save file, so I'm not worried about that, but it's a pretty weird issue.
factorio-current.log
(58.58 KiB) Downloaded 40 times
Thank you to whoever is able to help!


Grahnath
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Jun 15, 2022 10:09 pm
Contact:

Re: [1.1.59] Factorio Modded Server -- Player Instantly Disconnected Upon Load

Post by Grahnath »

ooh, I'll take a look, thank you! If it works, I'll update here too and marked solved.

Grahnath
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Jun 15, 2022 10:09 pm
Contact:

Re: [1.1.59] Factorio Modded Server -- Player Instantly Disconnected Upon Load

Post by Grahnath »

Ok, I've checked my mod settings, and I do not see the one for flib called "translation per tick." I've checked Startup, Map, and Per Player settings, and the only Factorio Library setting at all is in Map, and it's "Dictionary levels per batch", which defaulted to 15. I tried setting that to 10, but it did not fix the issue.

Also, it's worth mentioning that this issue occurs on a new save file.

Grahnath
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Jun 15, 2022 10:09 pm
Contact:

Re: [1.1.59] Factorio Modded Server -- Player Instantly Disconnected Upon Load

Post by Grahnath »

I looked at the changelog for FLIB and noticed that that specific setting was actually hidden and replaced with `flib-dictionary-levels-per-batch`. I will try lowering this to its minimum, but I tried lowering this before, and it did not work.

Version: 0.8.4
Date: 2021-09-19
Features:
- Added `flib-dictionary-levels-per-batch` setting
Changes:
- Children may now be defined in `gui.add()`
- If you need to return refs to children, use `gui.build()` instead
- `flib-translations-per-tick` setting is now hidden

Grahnath
Burner Inserter
Burner Inserter
Posts: 5
Joined: Wed Jun 15, 2022 10:09 pm
Contact:

Re: [1.1.59] Factorio Modded Server -- Player Instantly Disconnected Upon Load

Post by Grahnath »

THAT WORKED THANK YOU. For anyone looking in on this later on, see my above post where FLIB hid a setting and replaced it with `flib-dictionary-levels-per-batch`. Turn *this* down, and it should hopefully fix the issue. This setting is a map setting, so I had to copy the save file to my local PC, turn down the setting, save the game in Single Player, then re-upload the save to the server.

Post Reply

Return to “Technical Help”