[1.1.59] Mac OS: No sound over USB Headset

Anything that prevents you from playing the game properly. Do you have issues playing for the game, downloading it or successfully running it on your computer? Let us know here.
Post Reply
ShadowLabs
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri Jun 03, 2022 10:55 pm
Contact:

[1.1.59] Mac OS: No sound over USB Headset

Post by ShadowLabs »

Hi folks! Got a peculiar setup for you today: Playing on a 2014 retina 15" with Big Sur on it and I just cannot get the audio output to work consistently over my USB headset. Headset in particular is a Corsair Void Pro Wireless and it's set properly in the System Preferences to be the proper audio device. All other sounds play just fine over it but Factorio remains silent. If I use any other audio device (Built in speakers, Wired Earbuds or the HDMI output) Factorio outputs fine. I've attached the log files.
Attachments
factorio-previous.log
(5.48 KiB) Downloaded 39 times
factorio-current.log
(6.31 KiB) Downloaded 40 times

LordBlackwood
Manual Inserter
Manual Inserter
Posts: 3
Joined: Thu Jun 04, 2020 9:45 am
Contact:

Re: [1.1.59] Mac OS: No sound over USB Headset

Post by LordBlackwood »

I'm experiencing a similar issue: there's no sound when using my AirPods, though this is only the case when i connect the AirPods while Factorio is already running.
If i connect them first, and then start Factorio, the sound works fine (until i disconnect them). All other audio works fine, it seems to be just Factorio that somehow has an issue.

Using version 1.1.68, via steam, on a M1 MacBook Pro running macOS 12.5.1

Post Reply

Return to “Technical Help”