1.1.59 - issues with mod compatibility

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
User avatar
MrBadDragon
Inserter
Inserter
Posts: 37
Joined: Thu Jan 31, 2019 3:33 am
Contact:

1.1.59 - issues with mod compatibility

Post by MrBadDragon »

I'm having issues in 1.1.59 with mod dependencies when creating a new game.

Affecting Kratstorio 2 where it says that requires Krastorio 2 assets >= 1.1.0 and K2 assets says requires version of K2 >= 1.2.7. current K2 version is 1.2.25

Also noticing this impacting space ex and aai industries

All mods in question are up to date according to the mod portal.
Attachments
Capture1.PNG
Capture1.PNG (14.86 KiB) Viewed 99 times
Capture.PNG
Capture.PNG (25.16 KiB) Viewed 99 times

robot256
Filter Inserter
Filter Inserter
Posts: 407
Joined: Sun Mar 17, 2019 1:52 am
Contact:

Re: 1.1.59 - issues with mod compatibility

Post by robot256 »

Are they still disabled after you restart with them both selected? The "warning" doesn't go away until the dependencies are actually loaded, just checking them doesn't do it.

User avatar
MrBadDragon
Inserter
Inserter
Posts: 37
Joined: Thu Jan 31, 2019 3:33 am
Contact:

Re: 1.1.59 - issues with mod compatibility

Post by MrBadDragon »

Thanks! That was the reason. I have never noticed this before.

Post Reply

Return to “Technical Help”