Status Code 0

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.
Post Reply
Tattered
Manual Inserter
Manual Inserter
Posts: 1
Joined: Wed May 16, 2018 5:21 pm

Status Code 0

Post by Tattered » Wed May 16, 2018 5:28 pm

Couldn't find a post about this but I tried to join a friends server and the game locked up. I tried to join using the server browser and I can't find any of them. It's showing "status code 0"

Code: Select all

   0.001 2018-05-16 12:18:26; Factorio 0.16.36 (build 36253, win64, steam)
   0.001 Operating system: Windows 7 Service Pack 1
   0.001 Program arguments: "D:\SteamLibrary\steamapps\common\Factorio\bin\x64\Factorio.exe" 
   0.001 Read data path: D:/SteamLibrary/steamapps/common/Factorio/data
   0.001 Write data path: C:/Users/Michael/AppData/Roaming/Factorio [2923/121751MB]
   0.001 Binaries path: D:/SteamLibrary/steamapps/common/Factorio/bin
   0.008 System info: [CPU:        Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz, 4 cores, RAM: 6468/16278 MB, page: 8375/32554 MB, virtual: 167/8388607 MB, extended virtual: 0 MB]
   0.008 Display options: [FullScreen: 0] [VSync: 1] [UIScale: system (100.0%)] [MultiSampling: OFF] [Screen: 255] [Lang: en]
   0.010 Available display adapters: 2
   0.010  [0]: \\.\DISPLAY1 - NVIDIA GeForce GTX 970 {0x05, [0,0], 1920x1200, 32bit, 59Hz}
   0.010  [1]: \\.\DISPLAY2 - NVIDIA GeForce GTX 970 {0x01, [1920,0], 900x1440, 32bit, 60Hz}
   0.010 Create display on adapter 0. Size 1280x720 at position [310, 222].
   1.023 Initialised Direct3D:[0] NVIDIA GeForce GTX 970; driver: nvd3dumx.dll 23.21.13.8813
   1.035   Video memory size (dedicated video/dedicated system/shared system/available): 4007/0/7883/3695 MB
   1.091 DSound: Starting _dsound_update thread
   1.091 DSound: Enter _dsound_update; tid=11796
   1.092 Device reset internal.
   1.094 Desktop composition is active.
   1.094 WARNING: You have vsync and desktop composition enabled on Direct3D. Consider disabling vsync to increase performance on some configurations.
   1.094 Graphics settings preset: extreme
   1.095 Graphics options: [Graphics quality: normal] [Video memory usage: all] [Light scale: 100%] [DXT: false] [Shader: 1]
   1.095                   [Parallel sprite loading: 1] [Max texture size: 0/8192] [Bmp cache: 0] [Sprite slicing: 1] [Low quality rotation: 0]
   1.157 Error GlobalModSettings.cpp:107: Failed to migrate mod settings file: Error when opening C:\Users\Michael\AppData\Roaming\Factorio\mods\mod-settings.json for reading: No such file or directory
   1.158 Loading mod core 0.0.0 (data.lua)
   1.186 Loading mod base 0.16.36 (data.lua)
   1.336 Loading mod base 0.16.36 (data-updates.lua)
   1.406 Checksum for core: 1316978547
   1.406 Checksum of base: 4140083139
   1.537 Loading sounds...
   1.601 Info PlayerData.cpp:67: Local player-data.json unavailable
   1.601 Info PlayerData.cpp:70: Cloud player-data.json available, timestamp 1526489542
   1.713 Loaded shader file D:/SteamLibrary/steamapps/common/Factorio/data/core/graphics/shaders/game.cso
   1.713 Loaded shader file D:/SteamLibrary/steamapps/common/Factorio/data/core/graphics/shaders/zoom-to-world.cso
   1.713 Loaded shader file D:/SteamLibrary/steamapps/common/Factorio/data/core/graphics/shaders/alpha-mask.cso
   1.741 Initial atlas bitmap size is 16384
   1.746 Created atlas bitmap 16384x8428 [none]
   2.159 Created atlas bitmap 16384x2124 [shadow]
   2.238 Created atlas bitmap 16384x682 [decal]
   2.259 Created atlas bitmap 8192x1492 [mipmap]
   2.304 Created atlas bitmap 8192x800 [mipmap, smoke]
   2.315 Created atlas bitmap 8192x2376 [linear-minification, mipmap, terrain]
   2.365 Created atlas bitmap 8192x1036 [no-crop, trilinear-filtering, icon, light]
   2.378 Created atlas bitmap 8192x238 [alpha-mask]
   6.430 Sprites loaded
   6.430 Convert atlas 8192x1492 to: mipmap 
   6.467 Convert atlas 8192x800 to: mipmap 
   6.486 Convert atlas 8192x2376 to: min-linear 
   6.543 Convert atlas 8192x1036 to: trilinear-filtering 
   6.568 Convert atlas 8192x238 to: alpha-mask
   6.789 Custom inputs active: 0
   6.833 Factorio initialised
  15.584 Info UDPSocket.cpp:27: Opening socket at (d2e9f5ecae41d73c22fb24630f66de13f5d626b6)
  35.834 code:28, 1c; Operation too slow. Less than 1 bytes/sec transferred the last 20 seconds
  35.834 Info HttpSharedState.cpp:143: Downloading https://multiplayer.factorio.com/get-games?username=Tattered&token=<private>
  35.834 Info HttpSharedState.cpp:145: Status code: 0
  65.693 code:28, 1c; Operation too slow. Less than 1 bytes/sec transferred the last 20 seconds
  65.693 Info HttpSharedState.cpp:143: Downloading https://multiplayer.factorio.com/get-games?username=Tattered&token=<private>
  65.693 Info HttpSharedState.cpp:145: Status code: 0

Loewchen
Global Moderator
Global Moderator
Posts: 4567
Joined: Wed Jan 07, 2015 5:53 pm

Re: Status Code 0

Post by Loewchen » Wed May 16, 2018 5:51 pm

As the log says, the transfer speed is too slow, this is either a server or a network issue.

Matrop
Burner Inserter
Burner Inserter
Posts: 5
Joined: Sat Apr 21, 2018 9:47 am

Re: Status Code 0

Post by Matrop » Wed May 16, 2018 6:03 pm

Hi,

Playing with a friend, we both have the same issue (status code 0) when trying to join any multiplier server game.

The list of servers sometimes appears, and is sometimes replaced with "Status code 0"; when the list appears, the button "join" stay grey and un-clicable.

Tried to re-DL the game; tried to change the beta version through steam, the issue remains.

By the way, we used to play using a private server and me connecting directly to his server using his IP address. It used to work until last Saturday (12/05/2018), then it stopped to work for me, but a third friend still achieved to connect to his server. Therefore the problem may come from my game/PC/connection. However the public server way worked, so we moved onto this solution with a password... until today.

User avatar
HanziQ
Factorio Staff
Factorio Staff
Posts: 617
Joined: Fri Mar 27, 2015 7:07 am

Re: Status Code 0

Post by HanziQ » Wed May 16, 2018 6:47 pm

We are resolving issues with the matching server

Post Reply

Return to “Technical Help”