Missing Token Error on Headless Server When Token Present

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.

Missing Token Error on Headless Server When Token Present

Postby besselfunction » Wed May 16, 2018 1:57 pm

Hi All,

I eventually resolved this, but I'm not satisfied with how it was done.

I'm hosting a headless 0.16.36 server on Google Compute Engine. I should also say that I'm a materials engineer, not a comp. sci. person, so the finer points of network engineering and UNIX are lost on me. I installed factorio via the dtandersen docker container, and managed to edit the server-settings.json file to my liking, with my username and secure token found in the appdata folder. I then launched the server successfully without a password in the password field of the .json file. I joined my server, and everything was fine. I then shut down the server, and tried to restart it, and got a missing token error. I tried several times to fix this, even going as far as starting a new instance to see if I could recreate my previous result. Still got a missing token error. I've checked the token against the original in the appdata file, and everything checks out. I was eventually able to resolve the issue by including my password in the server .json file.

Here's my main question/statement:
I thought the point of the token was to isolate your username from your password. If this is the case, why does my server no longer work with only a token? Again, I'm certain that the token is entered correctly, and that the docker container is pointing to the correct file, especially since the addition of my password fixed the issue. Am I misunderstanding the purpose of the token? Should the password field be commented out if you're using the token? As I said before, I was able to get my server working, but I feel like I should be able to do it "properly".

The only other documentation I've been able to find for this issue is from 0.14 and apparently an update fixed it.
besselfunction
Manual Inserter
Manual Inserter
 
Posts: 3
Joined: Thu May 18, 2017 4:23 pm

Return to Technical Help

Who is online

Users browsing this forum: No registered users and 6 guests