[0.15]Toolbelt Alert Icon Not Appearing

Anything that prevents you play the game properly. Do you have issues with paying for the game, downloading it or properly running it on your computer? Let us know here.

[0.15]Toolbelt Alert Icon Not Appearing

Postby PotatoFactory » Wed Jan 10, 2018 4:12 pm

Hello all. As above, the alert icon that pops up when there is turret fire/damaged structures etc is no longer popping up. Alerts are appearing alright though on the minimap. I have a mod that hides the minimap but I've never had any issues before today. I am running a few other mods, but again only today have I noticed this. I have the game about 3 months now and the toolbelt alert has always worked. The sound alert does come on when something is has been destroyed by biters. I loaded up a previous save from a world I stopped playing on a week or so ago, and the alerts seems to work just fine there.

I don't play betas/experimentals so I'm playing the latest official version of 0.15.

The only thing different I've done is using concrete for creating floors so maybe I disabled the alerts somehow using the + and - keys to change the size of the brush. It was working fine last night, it's only been today that I've noticed it. I know it's such a small thing but those alerts are so handy.

I tried enabling alerts via the console as it says on the wiki, using the various parameters however each one I've tried, it came back saying "invalid parameter". I entered it exactly as it said to on the wiki as well, straight copy and paste. Did some general Googling as well and didn't find anything similar.

I got the game in November after simply not having enough of the demo and it's been probably the single best purchase ever. This is the first time since I've actually had any sort of problem with it whatsoever. And of course it's probably something simple that I've done and I'm just being a derp, If anyone could offer any advice I'd be very grateful. As I said, it's such a small issue, but it's like that old saying "you don't miss the water till it's gone".

Thank you.
Factorio: single greatest purchase of my life!
PotatoFactory
Burner Inserter
Burner Inserter
 
Posts: 8
Joined: Wed Jan 10, 2018 3:40 pm
Location: Factorio

Re: [0.15]Toolbelt Alert Icon Not Appearing

Postby Loewchen » Wed Jan 10, 2018 4:18 pm

You can load the game after renaming your mods folder to test if it works wo any mods. If this does not do it, post the save please.
Loewchen
Global Moderator
Global Moderator
 
Posts: 4392
Joined: Wed Jan 07, 2015 5:53 pm

Re: [0.15]Toolbelt Alert Icon Not Appearing

Postby PotatoFactory » Wed Jan 10, 2018 4:27 pm

Loewchen wrote:You can load the game after renaming your mods folder to test if it works wo any mods. If this does not do it, post the save please.


Didn't work, still not getting the alert next to the toolbelt. How do I post the save, just upload it as an attachment?
Factorio: single greatest purchase of my life!
PotatoFactory
Burner Inserter
Burner Inserter
 
Posts: 8
Joined: Wed Jan 10, 2018 3:40 pm
Location: Factorio

Re: [0.15]Toolbelt Alert Icon Not Appearing

Postby PotatoFactory » Wed Jan 10, 2018 6:44 pm

Save File:
Rail World - Copy.zip
(6.82 MiB) Downloaded 7 times
Factorio: single greatest purchase of my life!
PotatoFactory
Burner Inserter
Burner Inserter
 
Posts: 8
Joined: Wed Jan 10, 2018 3:40 pm
Location: Factorio

Re: [0.15]Toolbelt Alert Icon Not Appearing

Postby PotatoFactory » Thu Jan 11, 2018 8:00 pm

Quick update. I used the console to enable various alerts (turret fire, damage, etc) and it said "[alert] is not disabled. Commands didn't work before because I was entering the < >. I used a speaker to see if there was some similar issue and there was. Set it up so that it would flash and sound when there were less than 100 coal in a chest. Tested it, sound worked fine and the alert icon flashed on the minimap, but still no alert flash next to the toolbelt. Tested this on a new sandbox world and it worked fine. I'm thinking I'm gonna have to start a new world because although it's a small thing in the scheme of things, those alert flashes are very useful. The only thing I'm afraid of is this error repeating itself on a new world.
Factorio: single greatest purchase of my life!
PotatoFactory
Burner Inserter
Burner Inserter
 
Posts: 8
Joined: Wed Jan 10, 2018 3:40 pm
Location: Factorio

Re: [0.15]Toolbelt Alert Icon Not Appearing

Postby Loewchen » Thu Jan 11, 2018 8:46 pm

I can confirm the behaviour with the provided save loaded in 16.16.
Loewchen
Global Moderator
Global Moderator
 
Posts: 4392
Joined: Wed Jan 07, 2015 5:53 pm

Re: [0.15]Toolbelt Alert Icon Not Appearing

Postby PotatoFactory » Fri Jan 12, 2018 2:06 pm

Loewchen wrote:I can confirm the behaviour with the provided save loaded in 16.16.


Any idea of what the cause is? I'm not technical in the least, but since you've experienced the same issue then surely there's something wrong with the save file?
Factorio: single greatest purchase of my life!
PotatoFactory
Burner Inserter
Burner Inserter
 
Posts: 8
Joined: Wed Jan 10, 2018 3:40 pm
Location: Factorio

Re: [0.15]Toolbelt Alert Icon Not Appearing

Postby Rseding91 » Sun Jan 14, 2018 1:26 am

One of the mods you're using set show_alert_gui to false:

Image
If you want to get ahold of me I'm almost always on IRC and Discord.
Rseding91
Factorio Staff
Factorio Staff
 
Posts: 7476
Joined: Wed Jun 11, 2014 5:23 am

Re: [0.15]Toolbelt Alert Icon Not Appearing

Postby PotatoFactory » Sun Jan 14, 2018 3:47 am

Rseding91 wrote:One of the mods you're using set show_alert_gui to false:

Image


I know exactly what caused it now. I'm using the minimap autohide mod and there's an option to disable the alerts with control + N. I must have pressed that when trying to hide the map, which is control + M. The thing is now though that control + N doesn't work to enable the alerts, and yet all other hotkeys of the mod do still work (to hide minimap, the research bar at the top and the toobelt. I've tried rebinding the key but nothing's working. Even on other worlds pressing control + N doesn't disable the alerts. Any idea what I can do or is it a problem with the mod? Thanks for your help btw.
Factorio: single greatest purchase of my life!
PotatoFactory
Burner Inserter
Burner Inserter
 
Posts: 8
Joined: Wed Jan 10, 2018 3:40 pm
Location: Factorio


Return to Technical Help

Who is online

Users browsing this forum: No registered users and 7 guests