[0.16.51] Items on belt static after removing modded item

We are aware of them, but they have low priority. We have more important things to do. They go here in order not to take space in the main bug thread list.
Post Reply
User avatar
Muppet9010
Fast Inserter
Fast Inserter
Posts: 138
Joined: Sat Dec 09, 2017 6:01 pm
Contact:

[0.16.51] Items on belt static after removing modded item

Post by Muppet9010 » Mon Feb 04, 2019 1:58 pm

We found that our belt's items were static with gaps in after removing a mod that added an item present on that belt.
https://gfycat.com/UnconsciousMadeupEel


To Witness Issue
  1. load mod that added the charcoal item (fws_0.1.11): https://mods.factorio.com/download/fws/ ... 000b412b43
  2. load save which has full belts of mixed items, everything is fine:
    test.zip
    (1.76 MiB) Downloaded 6 times
  3. remove mod and load save, static items on belt with gaps occur.
  4. if you interact with the belt in any way it recovers.


In the real game the belt was a long straight with many splitters sending fuel down feeder lines to furnaces, rather than it being a loop as per this demo. However, the belt was fully backed up and stationary with the mixed items prior to the mods removal.
Attachments
factorio-previous.log
(4.37 KiB) Downloaded 7 times
factorio-current.log
(4.07 KiB) Downloaded 6 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 9055
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.51] Items on belt static after removing modded item

Post by Rseding91 » Mon Feb 04, 2019 9:17 pm

Thanks for the report. This is working as intended: the belt doesn't wake up due to migration removal of items. Most of the game works this way as an intended simplification. If you just go touch the belts (remove an item) they will wake up and start normal movement.
If you want to get ahold of me I'm almost always on Discord.

User avatar
darkfrei
Smart Inserter
Smart Inserter
Posts: 1898
Joined: Thu Nov 20, 2014 11:11 pm
Contact:

Re: [0.16.51] Items on belt static after removing modded item

Post by darkfrei » Tue Feb 05, 2019 8:16 am

Rseding91 wrote:
Mon Feb 04, 2019 9:17 pm
Thanks for the report. This is working as intended: the belt doesn't wake up due to migration removal of items. Most of the game works this way as an intended simplification. If you just go touch the belts (remove an item) they will wake up and start normal movement.
Can it be force restarted while such migration?

Post Reply

Return to “Minor issues”

Who is online

Users browsing this forum: No registered users