Map De-sync with Biters

Things that has been reported already before.
Post Reply
djvanryan
Burner Inserter
Burner Inserter
Posts: 13
Joined: Sat May 24, 2014 3:41 pm
Contact:

Map De-sync with Biters

Post by djvanryan »

When Biters approach and we start to attack, everyone gets a De-Sync screen, which leads us to have to restart the game. Anyone else getting this? We are currently running with 3 players, and no problems until biters come. Anyone know/find a solution for this?

leg1onfwam
Manual Inserter
Manual Inserter
Posts: 3
Joined: Thu Aug 07, 2014 3:00 am
Contact:

Re: Map De-sync with Biters

Post by leg1onfwam »

I am also getting this, but unfortunately no solutions yet. Could someone tell me how to get a log so i could be a bit more helpful?

*Edit: I should also mention that we are playing on LAN with two people and I didn't try forwarding ports yet. I'll give that a try when I get home. Would port forwarding have an effect if I'm not sending data outside the network?

User avatar
GewaltSam
Filter Inserter
Filter Inserter
Posts: 341
Joined: Thu May 08, 2014 5:42 pm
Contact:

Re: Map De-sync with Biters

Post by GewaltSam »

leg1onfwam wrote:*Edit: I should also mention that we are playing on LAN with two people and I didn't try forwarding ports yet. I'll give that a try when I get home. Would port forwarding have an effect if I'm not sending data outside the network?
I am no expert, but I don't think so. If that would be a problem, the connection shouldn't work in the first place.

BTW, we are playing with three people over internet and got no such problems with biters so far.

leg1onfwam
Manual Inserter
Manual Inserter
Posts: 3
Joined: Thu Aug 07, 2014 3:00 am
Contact:

Re: Map De-sync with Biters

Post by leg1onfwam »

Cheers man. Thats how I understood it as well, hence why I haven't tried it.

The problem seems to lie in us firing our weapons, as when the biters attack and we try to fight back, we desynch. The host saves, loads up the world solo and deals with it, then we both jump back in and place turrents. As long as we dont engage them directly there seems to be no problem.

Its an odd one, and I'd like to get a log, because as our factory grows this is becoming more frequent. If it is related to us engaging them (and we have blue science automated right now) It will be a living hell to get purple.

User avatar
azurelinctus
Inserter
Inserter
Posts: 25
Joined: Tue Sep 16, 2014 10:52 am
Contact:

Re: Map De-sync with Biters

Post by azurelinctus »

I had that problem and after removing all adapters other than the one that is used to connect to the internet, the problem never happened again. I had an adapter for Tunggle which was set to first priority, im not sure if during syncing of data between players maybe other adapters cause a conflict. If anyone having this problem tries this and it works then post back here or on a thread I already made about it https://forums.factorio.com/forum/vie ... f=5&t=6398
if it doesnt resolve the issue post about it too, it would be good to either eliminate or prove this as a posibility.

slpwnd
Factorio Staff
Factorio Staff
Posts: 1835
Joined: Sun Feb 03, 2013 2:51 pm
Contact:

Re: Map De-sync with Biters

Post by slpwnd »

Moved to bugreports. In our testing games we have battled quite a few enemies so in some cases it works:) What weapons are you using, anything else you can think of, maybe a save game very soon before desync?

ZJAYISBACK
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sat Nov 01, 2014 5:03 am
Contact:

Re: Map De-sync with Biters

Post by ZJAYISBACK »

Me and my brother had this problem it turned out he installed 32 bit vs. And I had 64 bit so I told him to get the 64 bit vs. And it worked fine many hours killing buyers after that (we both have 64 bit os he just didn't read)

knightrath
Burner Inserter
Burner Inserter
Posts: 6
Joined: Sun Sep 14, 2014 6:27 am
Contact:

Re: Map De-sync with Biters

Post by knightrath »

I had the same problem and we did the opposite of the last poster. My friend downgraded his 64bit to 32 that fixed it. Seems when the client has to be exact...they really mean...exact

leg1onfwam
Manual Inserter
Manual Inserter
Posts: 3
Joined: Thu Aug 07, 2014 3:00 am
Contact:

Re: Map De-sync with Biters

Post by leg1onfwam »

Thanks everyone!

The 32 bit + 64 bit conflict was my issue. downloaded the 32 bit version and played 4 hours-ish without a hiccup. fun times were had by all

User avatar
cube
Former Staff
Former Staff
Posts: 1111
Joined: Tue Mar 05, 2013 8:14 pm
Contact:

Re: Map De-sync with Biters

Post by cube »

Thanks for the report, but the way it turned out it is a duplicate of https://forums.factorio.com/forum/vie ... =52&t=6326.

Post Reply

Return to “Duplicates”

Who is online

Users browsing this forum: No registered users