[1.1.50] Controls settings window cuts off long keyboard combinations

Things that has been reported already before.
Post Reply
luziferius
Inserter
Inserter
Posts: 31
Joined: Thu Jun 01, 2017 12:59 pm
Contact:

[1.1.50] Controls settings window cuts off long keyboard combinations

Post by luziferius »

The settings window for keyboard controls cuts off long texts. I assume it only affects translations, here shown for German.

This causes some issues with actions bound to the numpad. Marked in red are “Increase game speed”, “Decrease game speed” and “Set game speed to 1”, which are all three by default bound to [Shift]+Something on the number pad. But you can’t know which key it is, because the number (or symbol) is cut off. The only way to find out is by reading the config.ini file or by simply trying all keys and observe what happens.
Screenshot_20220110_124527.png
Screenshot_20220110_124527.png (77.79 KiB) Viewed 158 times
There are three possible solutions I can suggest:
  • When text is cut off, add the full text to the tooltip. I.e. If the text is shortened to fit, change the tooltip from „Right click to un-bind.“ to be „Full text of the assigned keyboard combination \n Right click to un-bind.“
  • (Dynamically) widen the window a bit, so that it fits. There is still screen space available at the left and right side, even on square screens.
  • Change the translation for German key pad symbols from „Nummernblock X“ to “X (Nummernblock)”, where X is the symbol on the key pad. This way, it still cuts off parts of the text, but it will remove redundant information instead of the crucial part. When going this route, other languages should probably checked as well
On a somewhat related, but tangential note, the number keys are translated inconsistently (as seen on the two entries directly above the marking in the screenshot: The comma key is translated as „Keypad ,“, while all other keys are translated as “Nummernblock X

GrumpyJoe
Filter Inserter
Filter Inserter
Posts: 433
Joined: Fri Apr 06, 2018 7:10 pm
Contact:

Re: [1.1.50] Controls settings window cuts off long keyboard combinations

Post by GrumpyJoe »

luziferius wrote:
Mon Jan 10, 2022 12:10 pm

There are three possible solutions I can suggest:
  • Change the translation for German key pad symbols from „Nummernblock X“ to “X (Nummernblock)”, where X is the symbol on the key pad.

I'm German and I've never heard anybody say the word Nummernblock. It's always been the NUM block. Some German keyboards have it spelled out iirc, but everyone should know what NUM is, without looking at their keyboard.

Also, context is key here.
"You" (not luzi, more like general) are looking to check/change keybings here.
If you don't know where to look for NUM keys when in the keyboard settings menu, you can't be helped anyway.

That being said, IMHO, the translation should just be NUM-X
Last edited by GrumpyJoe on Mon Jan 10, 2022 4:50 pm, edited 1 time in total.


ixu
Long Handed Inserter
Long Handed Inserter
Posts: 84
Joined: Sun May 29, 2016 6:18 pm
Contact:

Re: [1.1.50] Controls settings window cuts off long keyboard combinations

Post by ixu »


Post Reply

Return to “Duplicates”