[1.1.47] Near-train placement-helping rectangles misalignment

Things that has been reported already before.
Post Reply
ftvkyo
Manual Inserter
Manual Inserter
Posts: 2
Joined: Tue Nov 23, 2021 7:26 pm
Contact:

[1.1.47] Near-train placement-helping rectangles misalignment

Post by ftvkyo »

What I did
I tried placing pumps next to fluid wagons and inserters next to cargo wagons.

What happened
In case of pumps, the yellow rectangle that is supposed to show which fluid tank the pump is going to connect to on the wagon doesn't account for gaps betwen the wagons. In other words, the rectangle is offset by one tile for each second wagon. See screenshots.
The same rectangles (but in red) appear if you hover a cursor holding an inserter (or other placeables) over a wagon (the rectangle that is supposed to show you that you can't place a thing there because it will intersect with something).

What I expected
The rectangles mentioned would be aligned with the wagons, accounting for gaps between them.
Attachments
Wrong rendering on the second wagon.
Wrong rendering on the second wagon.
20211123193126_1.jpg (2.81 MiB) Viewed 146 times
Correct rendering on the first wagon.
Correct rendering on the first wagon.
20211123193121_1.jpg (2.83 MiB) Viewed 146 times
factorio-current.log
The log file.
(6.12 KiB) Downloaded 44 times


ftvkyo
Manual Inserter
Manual Inserter
Posts: 2
Joined: Tue Nov 23, 2021 7:26 pm
Contact:

Re: [1.1.47] Near-train placement-helping rectangles misalignment

Post by ftvkyo »

Oh, I see, thanks Loewchen. I failed to find it.

However, are you sure this behaviour is desired? To me it seems most of people who encounter this thing will get confused. After all, what is actually the reason to highlight rails when you place pumps next to them? Especially that these rails don't get highlighted when the same thing is done with inserters. And fluid wagons don't have separate sections anymore (although they still have 3 connection points).

User avatar
Silari
Filter Inserter
Filter Inserter
Posts: 287
Joined: Sat Jan 27, 2018 10:04 pm
Contact:

Re: [1.1.47] Near-train placement-helping rectangles misalignment

Post by Silari »

ftvkyo wrote:
Wed Nov 24, 2021 2:51 pm
Oh, I see, thanks Loewchen. I failed to find it.

However, are you sure this behaviour is desired? To me it seems most of people who encounter this thing will get confused. After all, what is actually the reason to highlight rails when you place pumps next to them? Especially that these rails don't get highlighted when the same thing is done with inserters. And fluid wagons don't have separate sections anymore (although they still have 3 connection points).
It's in "Won't Fix", that doesn't mean the behavior is desired, it means that the behavior isn't desired but also isn't feasible to fix at this time for some reason. Either because the engine simply can not support it, or because the time investment isn't worth it, or the performance impact would be too great, etc. From posila's post in the linked thread, the last one would be the issue with highlighting the wagons directly, so it's going to end up doing this because wagons aren't perfectly sized to match rail sizes.

FuryoftheStars
Filter Inserter
Filter Inserter
Posts: 494
Joined: Tue Apr 25, 2017 2:01 pm
Contact:

Re: [1.1.47] Near-train placement-helping rectangles misalignment

Post by FuryoftheStars »

I wonder if it'd be better to make it not highlight the rail segment at all? That would eliminate this confusion and be in line with inserters, iirc.

Post Reply

Return to “Duplicates”