Page 1 of 1

[0.18.26] Savegame crashed

Posted: Sat May 23, 2020 6:01 pm
by cablegunmaster
My game crashed when I tried to save it, I got 529 hours in it and with the version 0.18.26 it crashed.

Also tried to load the savegame, I got "Bad allocation" as a response.
Luckily I have a autosave which I can load and allot of oldersaves I can work off but I can't save it.

I tried to save it but It crashed.
citygrid v1.0 12-07-2019
citygrid v1.0 18-05-2020

657.943 Loading map C:\Users\**\AppData\Roaming\Factorio\saves\citygrid v1.0 18-05-2020 109287597 bytes.
657.969 Loading level.dat: 314352494 bytes.
657.974 Info Scenario.cpp:187: Map version 0.18.26-0
660.036 Warning Map.cpp:344: Map loading failed: bad allocation
660.107 Error AppManagerStates.cpp:1455: bad allocation

Free space 80 GB. so that should be fine.
No errors on error checking.

Re: [0.18.26] Savegame crashed

Posted: Sat May 23, 2020 6:16 pm
by Rseding91
Thanks for the report. Based off the log file you had memory corruption (a single flipped bit). It could have been completely random or you could have failing hardware (most likely memory).

I recommend running this and seeing if it spots anything:

Re: [0.18.26] Savegame crashed

Posted: Sat May 23, 2020 6:21 pm
by cablegunmaster
Yeah, I checked crystaldisk smartinfo of my hdd, got some uncorrectable issues here, it could be the hdd is failing, thx for helping.

I ordered a new 6TB hdd. guess my old one is failing and checking with memtest aswell :).