[1.1.72] Invalid TransportLineIndex Exception: 206

Place for things which are bugs but we have no idea how to solve them. Things related to hardware, libraries, strange setups, etc.
Post Reply
thedoh
Burner Inserter
Burner Inserter
Posts: 13
Joined: Tue May 02, 2017 1:37 pm
Contact:

[1.1.72] Invalid TransportLineIndex Exception: 206

Post by thedoh »

So there I was, trying to reproduce viewtopic.php?f=7&t=104099 while recording in OBS. I completed the 100% run (10 minutes red :( ). While reviewing a save created from the replay, I encountered this Invalid TransportLineIndex Exception while reviewing part of the factory in /editor mode with the game paused. The part of the factory I was observing is the South West part of the factory (the big 4 red belt mining setup on the patch next to some furnaces).

Unfortunately, since I wasn't able to reproduce the aforementioned crash (see linked thread) I stopped the recording and so I don't have video of what I was doing at the time. I do have video of me making the savegames, but not of this exception. :( I'm not sure the video will be very relevant, but if it is, let me know and I'll put it on youtube as it's a large file.

I'll attach three files:

1. The Factorio log file
2. The final savegame
3. The savegame generated from the previous savegame

I tried briefly to load the save (eg from the third file) to reproduce this crash, but I wasn't able. Again, I don't know what the circumstances are that might have caused this.
Attachments
file 3 - nov17 - fixed rocket side ghost issue.zip
(25.85 MiB) Downloaded 12 times
file 2 - nov17 - why did outpost train wedge on blue inserters finished.zip
(50.05 MiB) Downloaded 17 times
file 1 - factorio-current sanitized.log
(14.81 KiB) Downloaded 12 times

Rseding91
Factorio Staff
Factorio Staff
Posts: 12413
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [1.1.72] Invalid TransportLineIndex Exception: 206

Post by Rseding91 »

Thanks for the report. Every instance of this kind of crash i've seen had ended up being unstable/bad hardware. Are you overclocking your CPU or RAM? If so, try turning that off.

If you are able to get a save file that reproduces the issue every time then for sure let us know. But random un-reproducible crashes have historically been hardware issues on the players end.
If you want to get ahold of me I'm almost always on Discord.

thedoh
Burner Inserter
Burner Inserter
Posts: 13
Joined: Tue May 02, 2017 1:37 pm
Contact:

Re: [1.1.72] Invalid TransportLineIndex Exception: 206

Post by thedoh »

I'm not intentionally doing anything strange with my CPU/memory, but I'll keep hwinfo up next time to see if there's something strange going on automatically that's trying to be helpful.

Post Reply

Return to “1 / 0 magic”