[1.1.59] Downloading a mod's dependency ignores the base version requirement (unlike downloading the mod directly)

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
Wiwiweb
Inserter
Inserter
Posts: 29
Joined: Sat May 08, 2021 2:36 am
Contact:

[1.1.59] Downloading a mod's dependency ignores the base version requirement (unlike downloading the mod directly)

Post by Wiwiweb »

Currently the "jetpack" mod has 2 versions:
* 0.3.2 works on the stable branch
* 0.3.3 depends on base mod 1.1.61 and therefore needs the experimental branch

On the stable branch:
When trying to install jetpack, Factorio will be aware of the requirement of 0.3.3, and will instead download 0.3.2, correctly:
jetpack-download.png
jetpack-download.png (81.06 KiB) Viewed 880 times
But if you install a mod that depends on jetpack, such as Space Exploration, Factorio will incorrectly download 0.3.3: (Starting from an empty mod folder)
20220624203606_1.jpg
20220624203606_1.jpg (254.89 KiB) Viewed 880 times
This is causing some bug reports in the SE discord from people installing SE for the first time.

Rseding91
Factorio Staff
Factorio Staff
Posts: 12284
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [1.1.59] Downloading a mod's dependency ignores the base version requirement (unlike downloading the mod directly)

Post by Rseding91 »

Thanks for the report. It's now fixed for the next release.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”