[Dominik] [0.17.68]Crash loading save after updating mods (Repaired wrong fluid system disconnect.)

This subforum contains all the issues which we already resolved.
Post Reply
Icelight
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Jul 31, 2019 3:21 am
Contact:

[Dominik] [0.17.68]Crash loading save after updating mods (Repaired wrong fluid system disconnect.)

Post by Icelight » Wed Sep 11, 2019 2:58 am

ImageAfter ~3 weeks away I went to reload an old save. The base game had already updated itself. I first updated all mods that had new updates since the last time I played (11, I do not remember exactly which ones). I then opened the old save game, and the game crashed while loading. The green loading bar fills completely, then there is a "bong" and the error screen appears. Loading older versions of the save re-creates the crash as well. Starting a new game with the same mod list loads successfully. I'm just over 220 hours into this save, so I'd like to be able to continue from its current state (or close to it), rather than starting over.

Save file wouldn't upload, here's a link to a dropbox upload: https://www.dropbox.com/s/jk75m6idx515q ... 1.zip?dl=0
Attachments
factorio-current.log
Log File
(28.34 KiB) Downloaded 16 times

Dominik
Factorio Staff
Factorio Staff
Posts: 649
Joined: Sat Oct 12, 2013 9:08 am
Contact:

Re: [Dominik] [0.17.68]Crash loading save after updating mods (Repaired wrong fluid system disconnect.)

Post by Dominik » Wed Sep 11, 2019 9:37 am

Thanks for the report. I have seen these crashes in the automated logs but needed a save to reproduce it.

Dominik
Factorio Staff
Factorio Staff
Posts: 649
Joined: Sat Oct 12, 2013 9:08 am
Contact:

Re: [Dominik] [0.17.68]Crash loading save after updating mods (Repaired wrong fluid system disconnect.)

Post by Dominik » Wed Sep 11, 2019 3:09 pm

I have made a mistake when fixing something about underground pipes with different lengths. Your save will load in the next version.

Icelight
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Jul 31, 2019 3:21 am
Contact:

Re: [Dominik] [0.17.68]Crash loading save after updating mods (Repaired wrong fluid system disconnect.)

Post by Icelight » Wed Sep 11, 2019 11:28 pm

That's amazing. Thank you so much. Glad I could help.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users