[kovarex] [0.17.47] Scrolling in view for "trains with this stop" broken

This subforum contains all the issues which we already resolved.
Post Reply
gHoST INFERNO
Long Handed Inserter
Long Handed Inserter
Posts: 50
Joined: Sun Nov 15, 2015 11:06 pm
Contact:

[kovarex] [0.17.47] Scrolling in view for "trains with this stop" broken

Post by gHoST INFERNO » Sun Jun 09, 2019 7:51 pm

Hi,

This is just a really minor UI bug: When I click on a station which is frequented by a large number of trains, the part of the window called "trains with this stop" gets a scrollbar. However, using the mouse's scroll wheel works only while hovering the minimaps, the actual big scrollbar, or empty space. It does /not/ work when hovering the list of stations a train has in its schedule (underneath the minimaps).

I'm guessing that's because that list captures the event itself, in case the list itself has a scrollbar. I don't have a great solution, but it currently seems confusing, because you e.g. start scrolling while hovering a minimap, but then as such a list gets moved under the mouse cursor, it stops working.

Maybe the list should pass the scroll even to the containing pane if (a) it doesn't have a scrollbar itself or (b) it has a scrollbar, but is already fully scrolled into the requested direction? That way at least something would keep happening as I use the scroll wheel.

Thanks for an awesome game! (Been playing since 0.12, maybe even 0.11 not sure anymore)

kovarex
Factorio Staff
Factorio Staff
Posts: 7287
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [kovarex] [0.17.47] Scrolling in view for "trains with this stop" broken

Post by kovarex » Thu Jun 13, 2019 12:54 pm

This most probably related to a bugfix I just solved (reported on a different place). The problem was, that inactive scrollbar (without scroll wheel) consumed the mouse wheel action and didn't let the parent scrollbar eat it.

I tested it, and I can scroll just fine there, so I guess it is confirmed to be fixed (for the next release).

Thanks for the report.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users