Version 0.17.42

Information about releases and roadmap.
Post Reply
User avatar
FactorioBot
Fast Inserter
Fast Inserter
Posts: 214
Joined: Tue May 12, 2015 1:48 pm
Contact:

Version 0.17.42

Post by FactorioBot » Tue May 21, 2019 4:06 pm

Changes
  • Tweaked default graphics settings. The game should choose better default graphics settings for computers with integrated GPUs or less than 6 GB of RAM.
Bugfixes
  • Fixed that GUI element size wasn't updated in inactive tabs when ui scaled changed. (70649)
  • Fixed "Confirm Message" conflicting with some key-bindings. "Confirm Message" can no longer be bound to mouse input. (70910)
  • Fixed possible crash when rendering GUI element with dynamically loaded sprite. (66507)
  • Fixed recipe window showing wrong item count or not enough ingredients in some situations. (67592)
  • Fixed a crash when deleting the force of a car with an active logistic network through vehicle equipment grid. (70734)
  • Mod names are no longer allowed to contain rich text. (70895)
  • Fixed IME (Input Method Editors) did not work (Windows only). (65358)
  • Fixed placement of oil and uranium patches back to that of 0.17.40. (70967)
  • Fixed that roboports with a request_to_open_door_timeout of 0 wouldn't work correctly. (70973)
  • Fixed that products wouldn't allow amount_min of 0 for items. (71014)
  • Fixed that migrated/removed fuel items could leave the game in an invalid state. (71029)
  • Fixed a crash when building combat robots after resetting the achievements in-game. (71041)
  • Fixed that assembler ghosts would carry over the unresearched blueprint bug from 0.17.38. (708990)
  • Fixed crash related to clearing a blueprint book from the cursor. (70955)
  • Fixed that the rotation of blueprint was not saved to the blueprint library in some situations.
  • Fixed bad icon in pollution statistics. (71011)
  • Fixed hand icon not disappearing when you grab a blueprint from chat. (70971)
  • Fixed that reviving modded tile ghost entities could destroy other entities in some situations. (70606)
  • Fixed car tooltip showing it's moving when it's not actually moving.
  • Fixed car rotating in place when the speed is very low. (71076)
  • Fixed that fluid wagons could not carry fluids with sub-zero temperatures. (71013)
  • Fixed that rolling stock "must be build on rails" error was not using the name of the rolling stock. (71087)
  • Possibly handled fullscreen window being moved to screen of different size on Windows. (63292)
  • Fixed a crash when using table_size() without any argument. (71090)
  • Fixed players getting a new player character when they connect after disconnecting, connecting and disconnecting again from a paused game. (71017)
Modding
  • Added map-gen-seed-max command line parameter.
  • Added generate-map-preview-random command line parameter.
  • Changed generate-map-preview command line parameter to need PATH instead of PNGFILE, the file name is now always the seed.
  • Made "apply_recipe_tint" be applied also to "light" working visualization effects of crafting machines.
  • Added "use_fuel_glow_color" property to reactor prototype.
Use the automatic updater if you can (check experimental updates in other settings) or download full installation at http://www.factorio.com/download/experimental.

User avatar
SuperSandro2000
Filter Inserter
Filter Inserter
Posts: 672
Joined: Sun Jan 12, 2014 3:54 am
Contact:

Re: Version 0.17.42

Post by SuperSandro2000 » Tue May 21, 2019 4:11 pm

Yeah! No breaking changes!

User avatar
arrow in my gluteus
Inserter
Inserter
Posts: 46
Joined: Mon Apr 24, 2017 1:52 pm
Contact:

Re: Version 0.17.42

Post by arrow in my gluteus » Tue May 21, 2019 4:12 pm

SuperSandro2000 wrote:
Tue May 21, 2019 4:11 pm
Yeah! No breaking changes!
You sure about that? https://xkcd.com/1172/

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6660
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: Version 0.17.42

Post by bobingabout » Tue May 21, 2019 4:25 pm

I've been waiting for this one.

Time to put use_fuel_glow_color to use!
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.

User avatar
boskid
Fast Inserter
Fast Inserter
Posts: 177
Joined: Thu Dec 14, 2017 6:56 pm
Contact:

Re: Version 0.17.42

Post by boskid » Tue May 21, 2019 5:26 pm

FactorioBot wrote:
Tue May 21, 2019 4:06 pm
Bugfixes
  • Fixed that assembler ghosts would carry over the unresearched blueprint bug from 0.17.38. (708990)
Broken link. Should be 70899

LordWampus
Burner Inserter
Burner Inserter
Posts: 16
Joined: Mon Feb 25, 2019 7:46 pm
Contact:

Re: Version 0.17.42

Post by LordWampus » Tue May 21, 2019 6:00 pm

bobingabout wrote:
Tue May 21, 2019 4:25 pm
Time to put use_fuel_glow_color to use!
Moar stuff coming to Bob's Mods?

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6660
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: Version 0.17.42

Post by bobingabout » Tue May 21, 2019 6:27 pm

LordWampus wrote:
Tue May 21, 2019 6:00 pm
bobingabout wrote:
Tue May 21, 2019 4:25 pm
Time to put use_fuel_glow_color to use!
Moar stuff coming to Bob's Mods?
Yup, released earlier today.
however, angel's mod breaks it due to me updating some icons to size 64, and angle just replacing them with his size 32 icons without setting icon_size.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.

Adamo
Long Handed Inserter
Long Handed Inserter
Posts: 69
Joined: Sat May 24, 2014 7:00 am
Contact:

Re: Version 0.17.42

Post by Adamo » Tue May 21, 2019 10:50 pm

use_fuel_glow_color = false is commented out on the vanilla reactor -- is that intended? Does it default to true, or do I need to turn it on in data-updates to use it? It's not listed on the prototype/reactor page. Also, the only item prototype I see that has a -- albeit commented-out -- fuel_glow_color is the nuclear-fuel item, which would never be used in a reactor. Is that a mistake or am I confused? It doesn't seem to work by simply adding "fuel_glow_color" to the fuel and setting "use_fuel_glow_color = true" on the reactor. In fact, doing this makes the reactor not glow at all. Anyone know how to use this?

kuhave
Manual Inserter
Manual Inserter
Posts: 4
Joined: Wed Mar 20, 2019 5:54 pm
Contact:

Re: Version 0.17.42

Post by kuhave » Wed May 22, 2019 4:45 am

FactorioBot wrote:
Tue May 21, 2019 4:06 pm
Bugfixes
[*]Fixed IME (Input Method Editors) did not work (Windows only). (65358)
Image

Korean IME is still broken..
Any IME(Microsoft IME, Nalgaeset IME) isn't worked as expect.
I wrote same post at (71123)

Post Reply

Return to “Releases”

Who is online

Users browsing this forum: No registered users