Version 0.17.1

Information about releases and roadmap.
khadgarion
Inserter
Inserter
Posts: 21
Joined: Sun Dec 25, 2016 3:34 am
Contact:

Re: Version 0.17.1

Post by khadgarion » Wed Feb 27, 2019 3:50 am

A suggestion for the campaign:

Give splitters and underground belts to the player, or allow them to be researched. I kind of feel like I had my hands tied behind my back when trying to automate all the things during the last phase of the biter attack, not being able to organize my spaghetti. I ended up going to freeplay instead.

One other small detail, at the beginning of the campaign where the objective is to "gather scrap" it took me a minute to figure out exactly what that meant. Maybe have the little helper go over to the scrap to show where it is, and what to do with it.

Other than that, I have really enjoyed the new UI and graphics. Good job!

Cisz
Inserter
Inserter
Posts: 37
Joined: Mon May 09, 2016 6:41 am
Contact:

Re: Version 0.17.1

Post by Cisz » Wed Feb 27, 2019 3:55 am

BlueTemplar wrote:
Wed Feb 27, 2019 3:44 am
Cisz wrote:
Wed Feb 27, 2019 2:50 am
And the feeder keeps using up my copper, after it allready has the requested ammount. So it is possible for a player to run out of copper ore before finishing this task.
Why would that be an issue ?
It gives the plates back to your inventory afterward.
I found that to be a nice touch !)
Ohh - didn't notice that. Nice touch indeed. :)

DorianTheFactorian
Manual Inserter
Manual Inserter
Posts: 1
Joined: Wed Feb 27, 2019 5:28 am
Contact:

Re: Version 0.17.1

Post by DorianTheFactorian » Wed Feb 27, 2019 5:42 am

I'm seeing serious performance issues with GUI responsiveness on macOS (relative to 0.16 stable; I didn't get a chance to try 0.17.0).

Sometimes everything is smooth, but very often (several times a minute) the player character will continue walking after I release the key, or it will take several seconds for an open inventory keypress to go through, or the cursor of the item I'm carrying will slowly drift towards the real cursor. The animations of belts, furnaces, miners, etc don't seem to be impacted, nor is sound. Leaving Activity Monitor open while in windowed mode shows that the game is not even close to memory, CPU, or GPU limits.

macOS Mojave 10.14.2
MacBook Pro (15-inch, 2018)
2.2 Ghz i7
16GB DDR4 RAM
Intel UHD Graphics 630 and AMD Radeon Pro 560

Anson
Fast Inserter
Fast Inserter
Posts: 235
Joined: Sun May 22, 2016 4:41 pm
Contact:

Re: Version 0.17.1

Post by Anson » Wed Feb 27, 2019 6:06 am

Tankh wrote:
Tue Feb 26, 2019 9:47 pm
I hope Wube is buyin y'all some pizza for the all-nighter ;)
typically factorio and it's crew :-)

and also typical that only when reading the timestamp of that message i noticed that it's already past 11pm (to be exact: past 6am), LOL

nobeerleft
Manual Inserter
Manual Inserter
Posts: 4
Joined: Tue Nov 29, 2016 11:04 pm
Contact:

Re: Version 0.17.1

Post by nobeerleft » Wed Feb 27, 2019 6:31 am

DorianTheFactorian wrote:
Wed Feb 27, 2019 5:42 am
macOS Mojave 10.14.2
MacBook Pro (15-inch, 2018)
2.2 Ghz i7
16GB DDR4 RAM
Intel UHD Graphics 630 and AMD Radeon Pro 560
I have that almost exact same machine (mine is 2017, but everything else is the same). Never seen any problem with 0.15, 0.16 or 0.17

Always runs smoothly. Has done for hundreds of hours.

Koub
Global Moderator
Global Moderator
Posts: 4680
Joined: Fri May 30, 2014 8:54 am
Contact:

Re: Version 0.17.1

Post by Koub » Wed Feb 27, 2019 6:46 am

To all people who report bug reports or technical issues :
There is a "Bug report" subforum for reporting bugs (including in the campaign)
There is a Technical Help for people who experience technical issues that don't seem to be bugs
There is also a Balancing subforum for those who think some things need a balance tweak (including campaign).

Posted here, a bug report is extremely hard to handle.
Thank you for your comprehension.
Koub - Please consider English is not my native language.

wahming
Fast Inserter
Fast Inserter
Posts: 186
Joined: Sun May 17, 2015 8:30 pm
Contact:

Re: Version 0.17.1

Post by wahming » Wed Feb 27, 2019 8:45 am

Wait - I went to sleep, woke up, and we're still at 0.17.1? I had expected to wake up to 0.17.5 at the very least!

Oh right... Factorio dev is still hand crafted.

User avatar
bobingabout
Smart Inserter
Smart Inserter
Posts: 6658
Joined: Fri May 09, 2014 1:01 pm
Contact:

Re: Version 0.17.1

Post by bobingabout » Wed Feb 27, 2019 8:52 am

First I can't update 0.16 to 0.17.0, because it can't see it. now that it can, I can't update to 0.17.1 due to the error posted previously.

I'm just going to wait until a 0.17.2 or something, unless someone tells me the update issue is in 0.17.0, in which case, I'll have to just download it, again.

You should offer the 0.17.0 to 0.17.1 update on the website so I don't have to download the whole damn thing again.
Creator of Bob's mods. Expanding your gameplay since version 0.9.8.

abregado
Factorio Staff
Factorio Staff
Posts: 245
Joined: Sat Aug 30, 2014 9:43 am
Contact:

Re: Version 0.17.1

Post by abregado » Wed Feb 27, 2019 10:10 am

Cisz wrote:
Wed Feb 27, 2019 2:50 am
The damaged reactor mouseoverr text is not displayed properly (full screen mode, 1.9k res). "Containing a li(..)" - a what battery?
Also a known issue. Will be fixed with the new tooltips.
Cisz wrote:
Wed Feb 27, 2019 2:50 am
The feeder is called a loader?
A quest to Load items using a Loader was considered too generic in the context of the game. The loaders should be renamed to Feeder, since we are not using that entity anyway.
Cisz wrote:
Wed Feb 27, 2019 2:50 am
And the feeder keeps using up my copper, after it allready has the requested ammount. So it is possible for a player to run out of copper ore before finishing this task.
if refunds the excess but does not tell the player.. probably should have compi say something
Cisz wrote:
Wed Feb 27, 2019 2:50 am
Compilatron is doing a good job - I allready hate them. I tried to wall in (with a wall) the little menace, and failed..
I will report you for cruelty to robots
Cisz wrote:
Wed Feb 27, 2019 2:50 am
There is no brownout warning, noone tells the player to increase steam power generation. Took me a while to notice why everything was running so slow.
This is not a simple problem to detect without often giving false positives to the player. I didnt want to delay the release for this but it will come. If anyone has ideas for this (and are willing to think about it longer than 5 minutes before replying) please PM me.

wahming
Fast Inserter
Fast Inserter
Posts: 186
Joined: Sun May 17, 2015 8:30 pm
Contact:

Re: Version 0.17.1

Post by wahming » Wed Feb 27, 2019 10:21 am

abregado wrote:
Wed Feb 27, 2019 10:10 am
Cisz wrote:
Wed Feb 27, 2019 2:50 am
Compilatron is doing a good job - I allready hate them. I tried to wall in (with a wall) the little menace, and failed..
I will report you for cruelty to robots
-15 drone relations, +15 biter relations.
abregado wrote:
Wed Feb 27, 2019 10:10 am
Cisz wrote:
Wed Feb 27, 2019 2:50 am
There is no brownout warning, noone tells the player to increase steam power generation. Took me a while to notice why everything was running so slow.
This is not a simple problem to detect without often giving false positives to the player. I didnt want to delay the release for this but it will come. If anyone has ideas for this (and are willing to think about it longer than 5 minutes before replying) please PM me.
Possibly a few different warnings depending on situation?

- Boilers are full of coal, and running at 90+% capacity: Time to increase generation capacity. Also a note that one boiler can support two engines.
- Boilers are running low on coal (before they stop completely): Check coal supply
- Boilers are empty: Red alert!

Boilers should only be monitored once they are operational to avoid new boilers triggering false alerts.

sathill
Long Handed Inserter
Long Handed Inserter
Posts: 51
Joined: Mon May 29, 2017 10:16 am
Contact:

Re: Version 0.17.1

Post by sathill » Wed Feb 27, 2019 1:08 pm

wahming wrote:
Wed Feb 27, 2019 10:21 am
abregado wrote:
Wed Feb 27, 2019 10:10 am
Cisz wrote:
Wed Feb 27, 2019 2:50 am
Compilatron is doing a good job - I allready hate them. I tried to wall in (with a wall) the little menace, and failed..
I will report you for cruelty to robots
-15 drone relations, +15 biter relations.
abregado wrote:
Wed Feb 27, 2019 10:10 am
Cisz wrote:
Wed Feb 27, 2019 2:50 am
There is no brownout warning, noone tells the player to increase steam power generation. Took me a while to notice why everything was running so slow.
This is not a simple problem to detect without often giving false positives to the player. I didnt want to delay the release for this but it will come. If anyone has ideas for this (and are willing to think about it longer than 5 minutes before replying) please PM me.
Possibly a few different warnings depending on situation?

- Boilers are full of coal, and running at 90+% capacity: Time to increase generation capacity. Also a note that one boiler can support two engines.
- Boilers are running low on coal (before they stop completely): Check coal supply
- Boilers are empty: Red alert!

Boilers should only be monitored once they are operational to avoid new boilers triggering false alerts.
Lol in 1.8 version rockets will build without need of a player.

Why not use combinators or even simple cicruic condition with chest plus alarm if content its lower than x coal trigger alarm.

HandsomeTurtle
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Feb 27, 2019 1:39 pm
Contact:

Re: Version 0.17.1

Post by HandsomeTurtle » Wed Feb 27, 2019 1:47 pm

I got problem updating from 0.17.0
After clicking update an error appears: "Value must be list or dictionary in property tree at ROOT.updates"

wahming
Fast Inserter
Fast Inserter
Posts: 186
Joined: Sun May 17, 2015 8:30 pm
Contact:

Re: Version 0.17.1

Post by wahming » Wed Feb 27, 2019 2:13 pm

sathill wrote:
Wed Feb 27, 2019 1:08 pm
wahming wrote:
Wed Feb 27, 2019 10:21 am
abregado wrote:
Wed Feb 27, 2019 10:10 am
Cisz wrote:
Wed Feb 27, 2019 2:50 am
Compilatron is doing a good job - I allready hate them. I tried to wall in (with a wall) the little menace, and failed..
I will report you for cruelty to robots
-15 drone relations, +15 biter relations.
abregado wrote:
Wed Feb 27, 2019 10:10 am
Cisz wrote:
Wed Feb 27, 2019 2:50 am
There is no brownout warning, noone tells the player to increase steam power generation. Took me a while to notice why everything was running so slow.
This is not a simple problem to detect without often giving false positives to the player. I didnt want to delay the release for this but it will come. If anyone has ideas for this (and are willing to think about it longer than 5 minutes before replying) please PM me.
Possibly a few different warnings depending on situation?

- Boilers are full of coal, and running at 90+% capacity: Time to increase generation capacity. Also a note that one boiler can support two engines.
- Boilers are running low on coal (before they stop completely): Check coal supply
- Boilers are empty: Red alert!

Boilers should only be monitored once they are operational to avoid new boilers triggering false alerts.
Lol in 1.8 version rockets will build without need of a player.

Why not use combinators or even simple cicruic condition with chest plus alarm if content its lower than x coal trigger alarm.
Since you don't seem to have followed the conversation - we're discussing the tutorial, aimed specifically at new players.

Saintmother
Manual Inserter
Manual Inserter
Posts: 3
Joined: Wed Feb 27, 2019 11:35 pm
Contact:

Re: Version 0.17.1

Post by Saintmother » Wed Feb 27, 2019 11:46 pm

Okay not sure if it's a bug or just a new feature, but it seems that as of 0.17 the "update time" for machines (furnaces, etc.) to display item icons in ALT mode is very long now (up to 1 second) which creates these weird "flashes" whenever new item is created/stacked in the machine. To show what i mean look at these screenshots.

This is how it always should be in ALT view:
Image

But this is how it looks like when that stone furnace creates a new plate - and it stays like that for about a second:
Image

Now I've tested this in 0.16.51 and it seems that although same thing happens there too, the "delay" is almost non-noticable. It's literally in miliseconds and not an issue at all and I've probably not even notice that happening before, cuz its almost instant. But now the "delay" is so long that if you imagine you have a factory with a few hundred machines all having this delay for some reason, it would be very annoying to watch.

Is this intended or is there some option in the menu that let's me "fix" this or is that a known issue that's being worked on? Thanks anyone on answer how to deal with this.

khadgarion
Inserter
Inserter
Posts: 21
Joined: Sun Dec 25, 2016 3:34 am
Contact:

Re: Version 0.17.1

Post by khadgarion » Thu Feb 28, 2019 2:24 am

Koub wrote:
Wed Feb 27, 2019 6:46 am
To all people who report bug reports or technical issues :
There is a "Bug report" subforum for reporting bugs (including in the campaign)
There is a Technical Help for people who experience technical issues that don't seem to be bugs
There is also a Balancing subforum for those who think some things need a balance tweak (including campaign).

Posted here, a bug report is extremely hard to handle.
Thank you for your comprehension.
Roger that. I didn't see those subforums when I posted. I will mention what I said in there.

User avatar
ThaPear
Fast Inserter
Fast Inserter
Posts: 221
Joined: Fri May 30, 2014 8:05 am
Contact:

Re: Version 0.17.1

Post by ThaPear » Fri Mar 01, 2019 8:06 am

Saintmother wrote:
Wed Feb 27, 2019 11:46 pm
Okay not sure if it's a bug or just a new feature, but it seems that as of 0.17 the "update time" for machines (furnaces, etc.) to display item icons in ALT mode is very long now (up to 1 second) which creates these weird "flashes" whenever new item is created/stacked in the machine. To show what i mean look at these screenshots.

This is how it always should be in ALT view:
Image

But this is how it looks like when that stone furnace creates a new plate - and it stays like that for about a second:
Image

Now I've tested this in 0.16.51 and it seems that although same thing happens there too, the "delay" is almost non-noticable. It's literally in miliseconds and not an issue at all and I've probably not even notice that happening before, cuz its almost instant. But now the "delay" is so long that if you imagine you have a factory with a few hundred machines all having this delay for some reason, it would be very annoying to watch.

Is this intended or is there some option in the menu that let's me "fix" this or is that a known issue that's being worked on? Thanks anyone on answer how to deal with this.
The miner creates an item every 4 seconds. The furnace only takes 3.2 to melt it into a plate. This means that there is 0.8 seconds where the furnace is not doing anything.

User avatar
nemostein
Long Handed Inserter
Long Handed Inserter
Posts: 54
Joined: Mon Apr 10, 2017 8:39 pm
Contact:

Re: Version 0.17.1

Post by nemostein » Fri Mar 01, 2019 1:32 pm

ThaPear wrote:
Fri Mar 01, 2019 8:06 am
The miner creates an item every 4 seconds. The furnace only takes 3.2 to melt it into a plate. This means that there is 0.8 seconds where the furnace is not doing anything.
This means that 5 Burner mining drill will feed 4 Stone furnaces now.
"I'd say the main bottleneck is sleep." - AndrewIRL

Post Reply

Return to “Releases”

Who is online

Users browsing this forum: No registered users