[1.1.6] Fast replace of underground belts in Bob's not replace second half

Bugs that we were not able to reproduce, and/or are waiting for more detailed info.
Post Reply
AngledLuffa
Fast Inserter
Fast Inserter
Posts: 183
Joined: Fri Jan 05, 2018 5:18 pm
Contact:

[1.1.6] Fast replace of underground belts in Bob's not replace second half

Post by AngledLuffa »

If I make an underground belt in Bob's mods, and then try to fast replace it with belt, the second half of the belt is not replaced. I do not know if this is present in the base game or not.

To reproduce:
lay out a line of transport belt
replace part of the transport belt with an underground belt
click on the entrance part of the underground belt, trace the path of the belt
the exit from the underground belt is not replaced with transport belt

Expected behavior: the exit should also be replaced with transport belt

I can provide a save game if that's useful.

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 4942
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [1.1.6] Fast replace of underground belts in Bob's not replace second half

Post by Klonan »

I am not 100% sure what exactly what action you are describing,
Could you provide a save with the minimal mods, and a test setup?

Also a screenshot or video of the issue

AngledLuffa
Fast Inserter
Fast Inserter
Posts: 183
Joined: Fri Jan 05, 2018 5:18 pm
Contact:

Re: [1.1.6] Fast replace of underground belts in Bob's not replace second half

Post by AngledLuffa »

Sorry for going AWOL. I don't know if I have the patience to advance a Bob's Mods map to a "minimal" demonstration of the problem, so I am just attaching the launched rocket save I have. I put a belt with an underground belt next to my character, and the replacement belt should be in hand. If you click on the south underground belt and drag north, it does not overwrite / fast replace the north underground belt.
Attachments
bobs post 2.zip
(21.05 MiB) Downloaded 17 times

AngledLuffa
Fast Inserter
Fast Inserter
Posts: 183
Joined: Fri Jan 05, 2018 5:18 pm
Contact:

Re: [1.1.6] Fast replace of underground belts in Bob's not replace second half

Post by AngledLuffa »

It is completely possible this is an issue with the belts in the mod. I can post it on the Bob's forums if that's the case

Post Reply

Return to “Pending”