Biters don't attack with large bases

Bugs that we were not able to reproduce, and/or are waiting for more detailed info.
Loewchen
Global Moderator
Global Moderator
Posts: 7738
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Biters don't attack with large bases

Post by Loewchen »

factoriouzr wrote:Any update on resolving this issue?
Until someone is able to reproduce this in the latest vanilla ill move this to pending.

factoriouzr
Filter Inserter
Filter Inserter
Posts: 652
Joined: Sat Jun 06, 2015 2:23 am
Contact:

Re: Biters don't attack with large bases

Post by factoriouzr »

Any update? Is anyone working on this issue?

Rseding91
Factorio Staff
Factorio Staff
Posts: 12487
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: Biters don't attack with large bases

Post by Rseding91 »

factoriouzr wrote:Any update? Is anyone working on this issue?
Not currently no because we can't reproduce the issue you're talking about in 0.14 without mods.
If you want to get ahold of me I'm almost always on Discord.

factoriouzr
Filter Inserter
Filter Inserter
Posts: 652
Joined: Sat Jun 06, 2015 2:23 am
Contact:

Re: Biters don't attack with large bases

Post by factoriouzr »

Hi Thanks for the update.

So you can reproduce it with the mods then?

Have you tried just with the power mod? I have seen you fix issues caused by mods before. Why is this any different? It happens with all stock buildings and units aside from the advanced electric for power. I don't see how this mod could cause this issue for two reasons:
1) I have been using it in previous version of the game (though granted it could have changed slightly from version to version)
2) Why would power prevent biters from attacking unless there is a bug with the modding API and how the game loads, runs different events, or the biters have some strange AI where they require pollution producing power buildings to be around to attack or something like that.

I know you guys are busy, but please try to look into this issue. I really like the mods I use and this issue happens with only a single mod for power production. I wouldn't be surprised if you replaced all the power with the equivalent in steam generation or solar the same issue would happen.

Thanks!

factoriouzr
Filter Inserter
Filter Inserter
Posts: 652
Joined: Sat Jun 06, 2015 2:23 am
Contact:

Re: Biters don't attack with large bases

Post by factoriouzr »

I'm not sure what to do with this issue. The biters don't seem to be moving on the map at all and don't seem to be attacking if i'm not near them.

Are you saying that you created a pure vanilla game with the same size base as mine, walk to one end and the biters on the other end are moving when under radar coverage?

Are you also saying that they attack you on the other end of the base?

If you say both of the above statements are true without mods then perhaps the modders will fix the mods in time, but that just doesn't seem to be the case from what i'm seeing. I just need confirmation that both these things are working as I described in vanilla factorio.

Thanks

factoriouzr
Filter Inserter
Filter Inserter
Posts: 652
Joined: Sat Jun 06, 2015 2:23 am
Contact:

Re: Biters don't attack with large bases

Post by factoriouzr »

Even if you don't consider the biter attacks a bug, biters are still not moving on radar when the player is not near them, but those same bases show moving biters on radar and in visual view when the player comes close to them. This is still a big bug. I remember when biters used move around no matter where the player was as long as you had radar coverage over their base and it added to the element of danger. Surrounded on all sides by edgy biters that are massing armies, now all biters on radar just freeze and it looks like there is no activity at all. Then when the player comes close to their base, they start moving. This really breaks immersion, and again, makes having radar coverage pretty much useless. Just stick 4 radars in the middle of your base and they will eventually scan all chunks that you care about, and since nothing really changes, you have the latest update (or close enough) till one of the radars scans the same chunk again.

Loewchen
Global Moderator
Global Moderator
Posts: 7738
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Biters don't attack with large bases

Post by Loewchen »

factoriouzr wrote:Even if you don't consider the biter attacks a bug...
Has nothing to do with considering something a bug or not, this is not going forward because no one could demonstrate the behavior in vanilla.

factoriouzr
Filter Inserter
Filter Inserter
Posts: 652
Joined: Sat Jun 06, 2015 2:23 am
Contact:

Re: Biters don't attack with large bases

Post by factoriouzr »

Thanks for the reply but I was asked to post my saved game and mods, so what's the point of that if the developers will just say, "won't fix, user is using mods"?

I remember reading several changelogs where the developers fixed issues specifically with mods.

Hopefully this won't be an issue in the next factorio version.

Perhaps using mods is exposing an issue in the base game. I have been using these mods for a long time (granted previous versions of the mods :) ) and I don't recall seeing these issues in previous version of factorio. Perhaps something changed in the base game that broke this behaviour with mods. I'm still not convinced it's caused by mods, but even if it is, it used to work before. And besides I'm not using any mods that change biter AI or biter behaviour at all. The only thing i'm using is a power generation mod for better solar panels and accumulators (which has nothing to do with radar or biters). And I'm also using base game radar (i'm not using the bob's mods radars).

rideawalrus
Burner Inserter
Burner Inserter
Posts: 6
Joined: Mon Oct 31, 2016 11:06 pm
Contact:

Re: Biters don't attack with large bases

Post by rideawalrus »

I have a similar problem, I'm version 13.20, no mods, on a map I made in game and have large base with a ton of pollution, and tons of enemies all around it in the pollution field, yet they never attack my base. If I wonder out there they will attack me, and follow be back, but they never attack first. I'd post my save but I'm not sure what files you need.

Loewchen
Global Moderator
Global Moderator
Posts: 7738
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Biters don't attack with large bases

Post by Loewchen »

rideawalrus wrote:I have a similar problem, I'm version 13.20, no mods, on a map I made in game and have large base with a ton of pollution, and tons of enemies all around it in the pollution field, yet they never attack my base. If I wonder out there they will attack me, and follow be back, but they never attack first. I'd post my save but I'm not sure what files you need.
Unless you can reproduce this in .14 it wont be necessary as .13 wont be updated anymore. If you can, then make a dedicated report please.

oggyswe
Manual Inserter
Manual Inserter
Posts: 3
Joined: Fri Jul 01, 2016 8:06 am
Contact:

Re: Biters don't attack with large bases

Post by oggyswe »

im having the same issue in 0.16.25 and only running the autofill mod, incendiarymunitions mod and vtk-cannon-turret mod

when im to far away they freeze

is there anyway to fix that? i could send my save file if you want

Loewchen
Global Moderator
Global Moderator
Posts: 7738
Joined: Wed Jan 07, 2015 5:53 pm
Contact:

Re: Biters don't attack with large bases

Post by Loewchen »

oggyswe wrote:im having the same issue in 0.16.25 and only running the autofill mod, incendiarymunitions mod and vtk-cannon-turret mod

when im to far away they freeze

is there anyway to fix that? i could send my save file if you want
Make a new report please, explain exactly what the issue is, when it occurs and attach the save file and your .ziped mods folder.

Post Reply

Return to “Pending”