[Oxyd] [0.18.22] Launched artillery at bugs which couldn't path, game slowed down significantly

Bugs that are actually features.
Post Reply
AngledLuffa
Fast Inserter
Fast Inserter
Posts: 183
Joined: Fri Jan 05, 2018 5:18 pm
Contact:

[Oxyd] [0.18.22] Launched artillery at bugs which couldn't path, game slowed down significantly

Post by AngledLuffa »

Playing multiplayer with the Natural Evolution mods, we built a landfill bridge across most of a large lake and used artillery to bomb the bejeezus out of either a large island or an area with a connection that wasn't yet explored. The game slowed to 30 UPS for a while. The problem was especially bad for me, running on a less powerful computer than the server; my FPS dropped to 5 for an extended amount of time. Debug information showed many calls to the path finder. When those finally resolved, the game sped back up for all of us.

I can include a save, screenshots, etc, but the guidelines say modded games may not be investigated, so please let me know if that effort is worthwhile first.

User avatar
Klonan
Factorio Staff
Factorio Staff
Posts: 4942
Joined: Sun Jan 11, 2015 2:09 pm
Contact:

Re: [0.18.22] Launched artillery at bugs which couldn't path, game slowed down significantly

Post by Klonan »

Can you include a save game?

Likely it is just a case of a mod being bad, but there might be something we can improve

AngledLuffa
Fast Inserter
Fast Inserter
Posts: 183
Joined: Fri Jan 05, 2018 5:18 pm
Contact:

Re: [0.18.22] Launched artillery at bugs which couldn't path, game slowed down significantly

Post by AngledLuffa »

Glad to help. Hopefully it's useful. I think the pathfinder is going a bit crazy at this exact moment, but there is also some actual attacks happening, which might be a confounding factor.

https://drive.google.com/file/d/1Acokhl ... sp=sharing

Oxyd
Factorio Staff
Factorio Staff
Posts: 1398
Joined: Thu May 07, 2015 8:42 am
Contact:

Re: [Oxyd] [0.18.22] Launched artillery at bugs which couldn't path, game slowed down significantly

Post by Oxyd »

I don't really see anything outright wrong there – it's a case of many biters trying to go somewhere at the same time. The mod contributes slightly to that by putting that many biters there in the first place.

So not a bug, but I will consider this for future optimisations.

Post Reply

Return to “Not a bug”