[0.17.37] Modded / non standard entities are not available in upgrade planner

Bugs that are actually features.
Post Reply
ethernal
Inserter
Inserter
Posts: 27
Joined: Fri Jan 05, 2018 7:07 am
Contact:

[0.17.37] Modded / non standard entities are not available in upgrade planner

Post by ethernal » Thu May 09, 2019 5:45 pm

When using upgrade planner it is not possible to upgrade from entity that normally does not have a second tier level. In case of Alien Loot Economy Mod https://mods.factorio.com/mod/alien-module it's solar panels. For simplicity sake I would like to upgrade all my existing standard solar panels to alien solar panels - this is not possible.

I am not sure if this can/should be fixed by mod author or if it's possible for upgrade planner to detect items loaded by mods and see on what base entities they depend/extend and allow items to be upgraded.

Should I attach log as it seems very unlikely that it will help.

To reproduce: Setup vanilla with alien loot economy and try to use upgrade planner - solar panels cannot be selected.

PS. for some reason Alien Loot interferes with Campaign - I'll add another report for that.
Attachments
factorio-upgrade-planner-items-list.png
There should be Solar Panels and Accumulators here
factorio-upgrade-planner-items-list.png (96.25 KiB) Viewed 190 times

Bilka
Factorio Staff
Factorio Staff
Posts: 2326
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: [0.17.37] Modded / non standard entities are not available in upgrade planner

Post by Bilka » Thu May 09, 2019 6:11 pm

The mod author has to set a fast replaceable group on the entity. Not a bug.
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

ethernal
Inserter
Inserter
Posts: 27
Joined: Fri Jan 05, 2018 7:07 am
Contact:

Re: [0.17.37] Modded / non standard entities are not available in upgrade planner

Post by ethernal » Fri May 10, 2019 5:56 pm

Any way I can fix this as I don't quite understand an example would be great I can deal with the rest.

ethernal
Inserter
Inserter
Posts: 27
Joined: Fri Jan 05, 2018 7:07 am
Contact:

Re: [0.17.37] Modded / non standard entities are not available in upgrade planner

Post by ethernal » Fri May 10, 2019 6:33 pm

OK figured it out and it works. Thanks for the info.

User avatar
darkfrei
Smart Inserter
Smart Inserter
Posts: 2308
Joined: Thu Nov 20, 2014 11:11 pm
Contact:

Re: [0.17.37] Modded / non standard entities are not available in upgrade planner

Post by darkfrei » Fri May 10, 2019 6:59 pm

Enough?

Code: Select all

data.raw.furnace["electric-furnace-2"].next_upgrade = "electric-furnace-3" 

Post Reply

Return to “Not a bug”

Who is online

Users browsing this forum: No registered users