[0.16.29] Regression: entity flag "pushable" unknown

Bugs that are actually features.
Post Reply
glee8e
Inserter
Inserter
Posts: 20
Joined: Sat Dec 30, 2017 7:26 am
Contact:

[0.16.29] Regression: entity flag "pushable" unknown

Post by glee8e » Mon Mar 12, 2018 4:50 pm

This particular issue happens when bobswarfare is installed. In previous versions (0.16.28 and perhaps 0.16.27) no error pops up but now (0.16.29) it bugs out.

To reproduce: install bobswarfare and its dependencies. Launch the game, oops. I've attached a screen shot of the error screen, if you really need it.

EDIT: I'm not quite sure if this is a bug on the mod's side though. I'll now crosspost it to bob's mod's subforum. No need for that.
Attachments
scrn.PNG
scrn.PNG (21.25 KiB) Viewed 583 times
Last edited by glee8e on Mon Mar 12, 2018 5:23 pm, edited 2 times in total.

Bilka
Factorio Staff
Factorio Staff
Posts: 2277
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: [0.16.29] Regression: entity flag "pushable" unknown

Post by Bilka » Mon Mar 12, 2018 5:00 pm

NaB, the flag was removed because it had no effect. The mod authors will have to update their mods.
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

glee8e
Inserter
Inserter
Posts: 20
Joined: Sat Dec 30, 2017 7:26 am
Contact:

Re: [0.16.29] Regression: entity flag "pushable" unknown

Post by glee8e » Mon Mar 12, 2018 5:21 pm

OK... so before bob updated it, I shall unzip the archive and run a grep to clean up all of them...

EDIT: BTW, why this removal isn't stated in the changelog? If it had been there, I'll have no trouble sniffing out why it goes wrong...

orzelek
Smart Inserter
Smart Inserter
Posts: 3613
Joined: Fri Apr 03, 2015 10:20 am
Contact:

Re: [0.16.29] Regression: entity flag "pushable" unknown

Post by orzelek » Mon Mar 12, 2018 6:45 pm

glee8e wrote:OK... so before bob updated it, I shall unzip the archive and run a grep to clean up all of them...

EDIT: BTW, why this removal isn't stated in the changelog? If it had been there, I'll have no trouble sniffing out why it goes wrong...
Yep it's the changelog bug I'd say. Stealth removal of flag that seems to be plastered over quite a few mods :D

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2275
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: [0.16.29] Regression: entity flag "pushable" unknown

Post by steinio » Mon Mar 12, 2018 7:00 pm

glee8e wrote:OK... so before bob updated it, I shall unzip the archive and run a grep to clean up all of them...

EDIT: BTW, why this removal isn't stated in the changelog? If it had been there, I'll have no trouble sniffing out why it goes wrong...
Bob's Warfare has an update. Check out the mod portal.
Image
Transport Belt Repair Man
My little mods: Link | My favourite mods: Bob's Mods | Angel's Mods | Yuoki Railway Core | EvoGUI | Logistic Train Network
Factorio Cheat Sheet by Denis Zholob

View unread Posts

Post Reply

Return to “Not a bug”

Who is online

Users browsing this forum: No registered users