[0.17.55]Trees not marked for destruction when ghosting belts

Bugs that are actually features.
Post Reply
KrazyTygr
Burner Inserter
Burner Inserter
Posts: 16
Joined: Fri Apr 13, 2018 8:39 pm
Contact:

[0.17.55]Trees not marked for destruction when ghosting belts

Post by KrazyTygr » Thu Jul 11, 2019 3:56 pm

I don't know if this is a bug or a feature, but on occasion a tree will not be marked for destruction when ghosting a belt. When the bots place the belt the tree remains, but it has no effect on the belt physics - items pass through/under the tree.
2019-07-11_164349.png
2019-07-11_164349.png (1.09 MiB) Viewed 144 times

posila
Factorio Staff
Factorio Staff
Posts: 3657
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by posila » Thu Jul 11, 2019 4:03 pm

Any mods? Because it looks like mod issue to me.

jodokus31
Filter Inserter
Filter Inserter
Posts: 438
Joined: Sun Feb 26, 2017 4:13 pm
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by jodokus31 » Thu Jul 11, 2019 4:09 pm

It could be "squeak through"-mod, which reduces the hitboxes

KrazyTygr
Burner Inserter
Burner Inserter
Posts: 16
Joined: Fri Apr 13, 2018 8:39 pm
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by KrazyTygr » Thu Jul 11, 2019 4:19 pm

Yes, I've got several mods, but I did try it in vanilla before posting and got the same problem - and now I realise that I forgot to sync mods with the save. So testing in a proper vanilla game I can not reproduce the glitch.

And yes, I do use squeak through, but I've not noticed this problem in the past.

posila
Factorio Staff
Factorio Staff
Posts: 3657
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by posila » Thu Jul 11, 2019 4:56 pm

KrazyTygr wrote:
Thu Jul 11, 2019 4:19 pm
And yes, I do use squeak through, but I've not noticed this problem in the past.
That's the exact mod I was thinking of, thanks for the confimation.

slippycheeze
Fast Inserter
Fast Inserter
Posts: 225
Joined: Sun Jun 09, 2019 10:40 pm
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by slippycheeze » Thu Jul 11, 2019 11:40 pm

posila wrote:
Thu Jul 11, 2019 4:56 pm
KrazyTygr wrote:
Thu Jul 11, 2019 4:19 pm
And yes, I do use squeak through, but I've not noticed this problem in the past.
That's the exact mod I was thinking of, thanks for the confimation.
I hit this, or something similar, when using Squeak Through, and also Fish and Wildlife - which causes trees to regrow, but using the tiny little box that Squeak Through set for them. All the original trees behaved reasonably, just the new ones didn't.

I ended up replacing both those mods for other reasons, and don't hit this any longer, but that combo, or ST + any tree regrowth mod, might be worth keeping in mind especially.

FuryoftheStars
Filter Inserter
Filter Inserter
Posts: 253
Joined: Tue Apr 25, 2017 2:01 pm
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by FuryoftheStars » Thu Jul 11, 2019 11:50 pm

slippycheeze wrote:
Thu Jul 11, 2019 11:40 pm
posila wrote:
Thu Jul 11, 2019 4:56 pm
KrazyTygr wrote:
Thu Jul 11, 2019 4:19 pm
And yes, I do use squeak through, but I've not noticed this problem in the past.
That's the exact mod I was thinking of, thanks for the confimation.
I hit this, or something similar, when using Squeak Through, and also Fish and Wildlife - which causes trees to regrow, but using the tiny little box that Squeak Through set for them. All the original trees behaved reasonably, just the new ones didn't.

I ended up replacing both those mods for other reasons, and don't hit this any longer, but that combo, or ST + any tree regrowth mod, might be worth keeping in mind especially.
I don’t think it’s necessarily any tree regrowth mod, just ones that change hit box sizes (and saying that, I guess any that create a smaller tree that grows into a larger one might). Anyway, point is, I know Noxy’s tree regrowth mod doesn’t have this issue, but Alien Biomes does. Using AB, I sometimes see this when placing rails. I’d actually rather have the tree hitboxes left alone....

slippycheeze
Fast Inserter
Fast Inserter
Posts: 225
Joined: Sun Jun 09, 2019 10:40 pm
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by slippycheeze » Thu Jul 11, 2019 11:57 pm

FuryoftheStars wrote:
Thu Jul 11, 2019 11:50 pm
slippycheeze wrote:
Thu Jul 11, 2019 11:40 pm
posila wrote:
Thu Jul 11, 2019 4:56 pm
KrazyTygr wrote:
Thu Jul 11, 2019 4:19 pm
And yes, I do use squeak through, but I've not noticed this problem in the past.
That's the exact mod I was thinking of, thanks for the confimation.
I hit this, or something similar, when using Squeak Through, and also Fish and Wildlife - which causes trees to regrow, but using the tiny little box that Squeak Through set for them. All the original trees behaved reasonably, just the new ones didn't.

I ended up replacing both those mods for other reasons, and don't hit this any longer, but that combo, or ST + any tree regrowth mod, might be worth keeping in mind especially.
I don’t think it’s necessarily any tree regrowth mod, just ones that change hit box sizes (and saying that, I guess any that create a smaller tree that grows into a larger one might). Anyway, point is, I know Noxy’s tree regrowth mod doesn’t have this issue, but Alien Biomes does. Using AB, I sometimes see this when placing rails. I’d actually rather have the tree hitboxes left alone....
Fish and Wildlife didn't change the hit box size at all. It used the tree after Squeak Through shrank the hit box; testing confirmed that it didn't have the tiny hit box after growing something if ST was not enabled. Oddly enough, I think I ended up on Noxy's one anyway, but not for this reason. :)

Anyway, my point was much more "here is a sequence of things that may trigger apparently buggy behaviour for users" than anything else, and definitely not a dig at either of those two mods: they both work really well, and I didn't ditch them because of this issue, or in fact, because of other bugs at all.

FuryoftheStars
Filter Inserter
Filter Inserter
Posts: 253
Joined: Tue Apr 25, 2017 2:01 pm
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by FuryoftheStars » Fri Jul 12, 2019 12:14 am

slippycheeze wrote:
Thu Jul 11, 2019 11:57 pm
...
Ah, yup, rereading your other post I realize now I kind of misread what you were trying to say. Sorry about that. :)

User avatar
BlueTemplar
Smart Inserter
Smart Inserter
Posts: 1170
Joined: Fri Jun 08, 2018 2:16 pm
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by BlueTemplar » Fri Jul 12, 2019 1:28 pm

Life... Uh... finds a way :
Image

posila
Factorio Staff
Factorio Staff
Posts: 3657
Joined: Thu Jun 11, 2015 1:35 pm
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by posila » Fri Jul 12, 2019 2:07 pm

BlueTemplar wrote:
Fri Jul 12, 2019 1:28 pm
Life... Uh... finds a way :
Best impression ever. 10/10 Goldblums

jamezhall
Burner Inserter
Burner Inserter
Posts: 11
Joined: Fri Jul 21, 2017 11:27 am
Contact:

Re: [0.17.55]Trees not marked for destruction when ghosting belts

Post by jamezhall » Fri Jul 12, 2019 3:20 pm

posila wrote:
Fri Jul 12, 2019 2:07 pm
BlueTemplar wrote:
Fri Jul 12, 2019 1:28 pm
Life... Uh... finds a way :
Best impression ever. 10/10 Goldblums
Hot wings episode reference?

Post Reply

Return to “Not a bug”

Who is online

Users browsing this forum: No registered users