Enemy behavior bug?

Bugs that are actually features.

Enemy behavior bug?

Postby Maja153 » Wed May 17, 2017 4:34 pm

I noticed some weird behavior with the biters at one point when i was looking around the map in the zoomed view,so i was kinda off-set by what is happening here, like are they meant to do that?
Attachments
nimetön1.png
nimetön1.png (1.03 MiB) Viewed 245 times
Maja153
Inserter
Inserter
 
Posts: 40
Joined: Wed May 11, 2016 12:03 pm

Re: Enemy behavior bug?

Postby Aeternus » Wed May 17, 2017 5:09 pm

I have noticed this too. The game I am in is a long-duration vanilla rail world with heavy pollution (building a megabase for the fun of it). The biter bases showing this behaviour are across a lake in a very heavy pollution area, but have stopped absorbing pollution from the look of it.
I don't think the biters are able to find a path to the pollution source, and this behaviour is the result.
Aeternus
Filter Inserter
Filter Inserter
 
Posts: 390
Joined: Wed Mar 29, 2017 2:10 am

Re: Enemy behavior bug?

Postby Oxyd » Thu May 18, 2017 2:00 pm

Hi. Screenshots won't tell me much. Post the saves, please. Also tell me what exactly you think is wrong – the screenshot looks completely okay to me.
Oxyd
Factorio Staff
Factorio Staff
 
Posts: 959
Joined: Thu May 07, 2015 8:42 am

Re: Enemy behavior bug?

Postby Aeternus » Thu May 18, 2017 5:08 pm

The biters spawn in a wide circle as in the screenshots, and... just sit there. Never attack. Never move. They remain in that circle. As if they're conducting some secret occult ritual... The Cult of the Biters. To doom all things technological.

*ahem*
Save attached (game uses default railworld settings, no mods, started in 0.15.6, updated to 0.15.11). See most Biter bases to the south of the factory, there's several with circles of biters. I strongly suspect this is due to the Biter pathing AI not finding an attack vector for the surplus biters, while railworld also denies them the ability to migrate and spawn a new Biter colony.
Attachments
TmpRailworld.zip
(14.24 MiB) Downloaded 9 times
Aeternus
Filter Inserter
Filter Inserter
 
Posts: 390
Joined: Wed Mar 29, 2017 2:10 am

Re: Enemy behavior bug?

Postby BHakluyt » Thu May 18, 2017 6:40 pm

I wanted to check out the save, but the game crash with an unexpected error, log attached.

edit - AH its probably because I didn't disable my mods... Though it should work?
Attachments
factorio-current.log
Log file?
(28.92 KiB) Downloaded 9 times
BHakluyt
Inserter
Inserter
 
Posts: 40
Joined: Sat Oct 08, 2016 12:43 pm

Re: Enemy behavior bug?

Postby Oxyd » Fri May 19, 2017 3:54 pm

I see nothing wrong with those biters. They're just inactive, so they don't move.

Aeternus wrote:I strongly suspect this is due to the Biter pathing AI not finding an attack vector for the surplus biters, while railworld also denies them the ability to migrate and spawn a new Biter colony.


That sentence makes absolutely no sense to me. If they decide to attack, they will activate and stage an attack. But they don't activate unless they have a reason to be active. :)
Oxyd
Factorio Staff
Factorio Staff
 
Posts: 959
Joined: Thu May 07, 2015 8:42 am

Re: Enemy behavior bug?

Postby Aeternus » Sun May 28, 2017 4:44 am

I thought their general behaviour was "spawn until there's a certain number or time limit reached, then make a beeline for whatever source of pollution is causing their spawning, attack whatever you find along the way". I thought that their path being blocked by a large body of water might glitch out the AI causing it to stall, and behave as described.

Regardless, this behaviour seems to have been fixed as of 0.15.16 :)
Aeternus
Filter Inserter
Filter Inserter
 
Posts: 390
Joined: Wed Mar 29, 2017 2:10 am


Return to Not a bug

Who is online

Users browsing this forum: No registered users and 3 guests